Rising Storm/Red Orchestra 2 Multiplayer

View Stats:
Multinationals? May 10, 2014 @ 6:12am
Punkbuster service keeps disapearing?
This is totally random but I notice sometimes in game or even after restarting computer that pnkbstrb.exe is not running and when I check services the entry is gone only pnkbstra is there.
I have no idea why this is happening. I reinstalled PBsetup and pbsvc 10000000000000 times and it still keeps happening. Even went through an entire steam and RO2 reinstall and still same crap. I am not running AV or firewall right now, just basic windows firewall and have specifically allowed both pnkbstra.exe and pnkbstrb.exe as well as ROgame.exe through.
WHAT IS CAUSING THIS?
Showing 1-15 of 15 comments
< >
Multinationals? May 10, 2014 @ 7:02am 
BUMP!! ANYONE!!!
Multinationals? May 10, 2014 @ 7:50am 
Whats even more ironic is that if I run pbsvc and test services it says test completed without error, but it opens and then CLOSES pnkbstrb.exe.

But what boggles me the most is when the service itself is GONE from services.msc panel, wtf is going on?!?!/!
Multinationals? May 10, 2014 @ 8:19am 
This is the pcsvc test log

Starting PunkBuster Service Installer (v0.992) (05/10/14 11:16:14)
Windows NT 6.2 (build 9200) 64-bit
PunkBuster DLL Install Files IncludedStarting PunkBuster Service Tests (v0.992) (05/10/14 11:16:17)
PunkBuster DLL Install Files IncludedChecking OS
Windows NT 6.2 (build 9200) 64-bit
Checking PnkBstrA service status RUNNING
Checking PnkBstrA Version OK (1035)
Extracting "PnkBstrB.exe" to:
"C:\Users\xxxxxxx\AppData\Roaming\PnkBstrB.exe"
OK
Checking firewall settings OFF
Is PnkBstrA explicitly allowed?
C:\Windows\system32\PnkBstrA.exe NO
Is PnkBstrB explicitly allowed?
C:\Windows\system32\PnkBstrB.exe NO
Checking if PnkBstrB is running RUNNING
Manually stopping PnkBstrB STOPPED
Getting port for PnkBstrA OK (44301)
Opening socket for packet send OK
Sending version packet to PnkBstrA SENT
Receiving version from PnkBstrA OK
Received 6 bytes from 127.0.0.1:44301
Response = 11266 (ms) Version = v1035
Getting PnkBstrB install instance OK
Sending start packet to PnkBstrA SENT
Waiting for packet from PnkBstrA OK
Received 3 bytes from 127.0.0.1:44301
Response = 25563 (ms) PnkBstrB started.
Load SUCCESSFUL.
Watching for PnkBstrB instance change (1) CHANGED (2)
Getting port for PnkBstrB OK (45301)
Sending version packet to PnkBstrB SENT
Receiving version from PnkBstrB OK
Received 5 bytes from 127.0.0.1:45301
Response = 3062 (ms) Version = 2202
Checking PnkBstrK driver status NOT FOUND
Manually stopping PnkBstrB STOPPED
Removing test PnkBstrB file OK

----------------------------------
Tests finished.


Multinationals? May 10, 2014 @ 11:29am 
BUMP

I know im not the only one this is happening too, google is reporting it not only with this game but plenty of other PB games. And no its not my AV or firewall doing this. I have none installed.

This is ♥♥♥♥♥♥♥ me off.
Moskeeto May 10, 2014 @ 12:54pm 
Try completely uninstalling pb before reinstalling it.
Multinationals? May 11, 2014 @ 2:22am 
Already tried that....
Even reinstalled steam and the entire game still same problem.
Sedgmachine May 14, 2014 @ 4:58pm 
I'm seeing the same issue. Zakarro did you ever figure it out?
Fuse May 14, 2014 @ 6:33pm 
I got the same issue today and I have tried a lot to fix it. Somehow I got it working and I am not 100% sure what did the trick but here's what I did.

1. Click Start -> Control Panel -> Programs and Features and uninstall "PunkBuster Services"

2. Go to (C:\Program Files (x86)\Steam\steamapps\common\red orchestra 2\Binaries\Win32) or (C:\Program Files\Steam\steamapps\common\red orchestra 2\Binaries\Win32) depending on your OS and locate "pbsvc_hos.exe"
-> Rightclick on "pbsvc_hos.exe" -> Properties -> Compatibility -> Tick the box next to "Run this program as an administrator" and click OK
- Now run "pbsvc_hos.exe".

3. Go to (C:\Windows\SysWOW64) or (C:\Windows\System32) and locate "PnkBstrA.exe" and "PnkBstrB.exe" (again folder depends on OS).
-> Rightclick "PnkBstrA.exe" -> Properties -> Compatibility -> Check the box next to "Run this program as an administrator"
DON'T close the window yet.
Click the Digital Signatures tab -> select "Even Balance, Inc." -> Details -> View Certificate -> Install Certificate... -> Next -> select "Automatically...etc." -> Next -> Finish
-> Click "OK" in all windows to save&exit
(Do the same for "PnkBstrB.exe")

4. Start RS/RO2 and when you're in the mainmenu press ALT+TAB
Rightclick on your taskbar and Start Task Manager
Click Services and check if both PnkBstrA and PnkBstrB are running. If so, you are good.

I hope this helps you in any way and good luck!
Multinationals? May 15, 2014 @ 6:59am 
Originally posted by Harmonica:
I got the same issue today and I have tried a lot to fix it. Somehow I got it working and I am not 100% sure what did the trick but here's what I did.

1. Click Start -> Control Panel -> Programs and Features and uninstall "PunkBuster Services"

2. Go to (C:\Program Files (x86)\Steam\steamapps\common\red orchestra 2\Binaries\Win32) or (C:\Program Files\Steam\steamapps\common\red orchestra 2\Binaries\Win32) depending on your OS and locate "pbsvc_hos.exe"
-> Rightclick on "pbsvc_hos.exe" -> Properties -> Compatibility -> Tick the box next to "Run this program as an administrator" and click OK
- Now run "pbsvc_hos.exe".

3. Go to (C:\Windows\SysWOW64) or (C:\Windows\System32) and locate "PnkBstrA.exe" and "PnkBstrB.exe" (again folder depends on OS).
-> Rightclick "PnkBstrA.exe" -> Properties -> Compatibility -> Check the box next to "Run this program as an administrator"
DON'T close the window yet.
Click the Digital Signatures tab -> select "Even Balance, Inc." -> Details -> View Certificate -> Install Certificate... -> Next -> select "Automatically...etc." -> Next -> Finish
-> Click "OK" in all windows to save&exit
(Do the same for "PnkBstrB.exe")

4. Start RS/RO2 and when you're in the mainmenu press ALT+TAB
Rightclick on your taskbar and Start Task Manager
Click Services and check if both PnkBstrA and PnkBstrB are running. If so, you are good.

I hope this helps you in any way and good luck!

Will try that if I still get problems, I just went through a clean OS install. Will keep you updated
Multinationals? May 26, 2014 @ 12:35pm 
Hmm well it seemed to work for a day, now the service is gone again, no punkbusterb
Something keeps deleting it, I thought maybe anti vir and firewall but they would do it immediatly. So I doubt them doing it. Any other ideas?
Hot Mustard Beaver Biscuits May 26, 2014 @ 4:25pm 
Punkbuster A service will shutdown Punkbuster B service if you don't run a game requiring it. As long as Punkbuster B runs when the game is started, you're ok. Source: You can check the Punkbuster logs in one of the Windows log folders. There's a line that shows Punkbuster A is shutting down Punkbuster B service.
Fuse May 26, 2014 @ 9:31pm 
Iirc there is another PnkBstr file in your Windows folder, it's something like PnkBstrB.xtr
Try step 3 from my previous post on that file as well.
Multinationals? Jul 16, 2014 @ 2:04am 
Its not that the file is not only not running, THE ENTIRE SERVER IS DISAPEARING.
Which means pnkbstr A cant invoke it when needed.
Ice_ Dec 10, 2014 @ 7:54am 
Hello from the future.

Got problems with pnkbstrb myself...

Not had any issues with Punkbuster for years but all of the sudden I am getting kicked out of games because pnkbstb can't communicate with the servers.
After trying to reinstall the punkbuster service using latest pbsvc.exe from evenbalance.com, it gives errors:

ERROR: Copy from [C:\Windows\system32\PnkBstrB.xtr] to [C:\Windows\system32\PnkBstrB.exe] failed; Load denied. (32)
[12.10.2014 15:52:45] ERROR: Copy from [C:\Windows\system32\PnkBstrB.xtr] to [C:\Windows\system32\PnkBstrB.exe] failed; Load denied. (32)
[12.10.2014 15:53:27] ERROR: Copy from [C:\Users\Robert\AppData\Local\PunkBuster\HOS\pb\PnkBstrB.exe] to [C:\Windows\system32\PnkBstrB.exe] failed; Load denied. (32)
[12.10.2014 15:54:09] ERROR: Copy from [C:\Windows\system32\PnkBstrB.xtr] to [C:\Windows\system32\PnkBstrB.exe] failed; Load denied. (32)
[12.10.2014 15:55:47] ERROR: Copy from [C:\Users\Robert\AppData\Roaming\PnkBstrB.exe] to [C:\Windows\system32\PnkBstrB.exe] failed; Load denied. (32)


Load denied it says. If I try to do a service test through pbsvc.exe, it gives me another error which seems to be related to the above and it's more clear:

"can't open file 'C:\Windows\system32\PnkBstrB,exe' (error 32: the process cannot access the file because it is being used by another process.)"

I'm trying to find out how this file can be magically used when it doesn't even exist, must be black magic.

I can fix all of these errors though by reinstalling punkbuster after a computer reboot - weird.
My anti-virus software is not blocking punkbuster in any way (Windows defender - tried even while it's deactivated).

I came here with the help of Google and surprise surprise, it's in the RO2 category, a game which I recently started playing (a couple of days ago) and that's when punkbuster decided to play mind games with me - coincidence? I think not!

I reinstalled Punkbuster after a reboot yesterday and it all worked perfectly fine (woop woop) for a whole day, wow. It started to screw up today again after I played RO2 for an hour, then Heroes of the Storm and when I decided to go back to RO2 I had one of the best moment in my life and I got kicked from the server, complaining about pnkbstrb not being able to communicate - ugh... Here we are again...

EDIT: Oh I should add that pbsvc.exe starts to fail after numerous attempts of uninstalling/installing punkbuster, it'll just close without any sort of notice - quality product!

EDIT #2: Hm, I still had problems installing punkbuster after a restart... I'm also having DNS server problems the past few days as well, so in the middle of all this I got so fed up with my ISPs DNS servers that I switched to Google DNS and now, the punkbuster installer worked like a charm. Related? I don't know but could be. I sure hope it's that simple at least!
Last edited by Ice_; Dec 10, 2014 @ 8:16am
Multinationals? Dec 10, 2014 @ 8:52am 
Funny my pbsvc test passes. The service would just randomly disapear and actually running pbsvc would fix it. But it was annoying to do it everytime. In any case I think issue is gone, either PB fixed it with an update or I dunno maybe it was a software conflict on previous rig.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50

Date Posted: May 10, 2014 @ 6:12am
Posts: 15