sinsorrow1 May 4 @ 5:51am
German C96 pistol
It seems that the pistol is bugged. Whenever I empty the whole mag and try to reload nothing happens. I am trying with both "R" and LMB, but nothing. It only reloads after like 2 minutes, after bashing the walls, the ground, and switching to my other weapon a couple of times. My pistol is level 0 or 1, and before you ask I do have more clips for the weapon.
Last edited by sinsorrow1; May 4 @ 5:54am
Showing 1-10 of 10 comments
< >
♥ Miss Ellery ♥ May 4 @ 6:03am 
I don't get that, but I do notice it has bugged sound, when you put it in semi auto the gunshot sound seems like its places 10ft infront of you rather than actually on the gun. Only problem I've had with the C96's reload is when you finish the reload theres about a second delay between when the animation finishes and when the gun is actually reloaded.
skydancer May 4 @ 9:14am 
I've same problem. Pistol don't reload when empty. (the only time it is supposed to reload)
R5CYA May 4 @ 9:18am 
what happens if you drop it and pick it back up? that works for broken scopes on the sniper.
Scytale May 4 @ 9:31am 
I had a similar bug with the german AT rifle, i wasn't able to reload with half empty magazine, no matter standing, laying or deploying. had to fire a shot, then reload worked. I cannot say it for sure, but i had the same thing with P38 pistol. But it is not every time and it happend on one map (that snowy map with a perimeter defence line and a hanger on the left and barracks in the mid, sovjets attacking)
What larks!! May 4 @ 12:59pm 
With the AT rifles, you can only reload them after you have fired all five rounds.
Scytale May 4 @ 2:11pm 
Is that the case? i have to test it, i could swear i reloaded after 3 shots yesterday
SturmRatt May 4 @ 2:48pm 
I tested this out on a few empty serves and my own host. On my own "host", everything worked perfectly, but on the empty servers, rapidly firing the basic C96 caused me noticable lag and the weapon jammed, seemingly empty. Dropping it and picking it up again revealed the weapon still had 2-3 rounds in it and after firing those I could reload. Dropping the weapon caused my lag to disappear.
Did any of you notice lag, or difference between rapid fire and "slow count every bullet fire"? Throwing 3 nades and waiting around seemed to cause a reload to happen.

Atm my best guess is something is causing packageloss between the client and the server, causing the gun to appear empty to client, but still partially loaded for the server, thuss stopping the player from reloading. After a while, the message gets trough (client side hit detection still has to reach the server), but if you throw the weapon down and pick it up again, the server updates your client with the same info it had, so thus the c96 now still has few bullets loaded in.

I will check the TWI forums for this when they return online, since my lvl 50 full auto Mauser works perfectly under rapid fire and the firerate is much higher. (Mauser upgrades include a magazine, stock and firemode toggle)
Might also have to try this on one of my usual servers instead of crappy empty botfests to make certain it wasn't the server hardware.

Originally posted by Scytale:
Is that the case? i have to test it, i could swear i reloaded after 3 shots yesterday
AT-rifles should require you to empty the inbuild magazine.
Last edited by SturmRatt; May 4 @ 2:56pm
sinsorrow1 May 7 @ 3:52am 
Originally posted by SturmRatt:
I tested this out...

Best answer ever! Thank you for the information, I am going to try what you said!
Wii Remote Victim May 7 @ 4:34am 
Happened to me while I was leveling it to 50. Only happened before unlocking the detachable mag at 25. Solution is to mash reload and fire until it triggers.
SturmRatt May 7 @ 5:34am 
Originally posted by Wii Remote Victim:
Happened to me while I was leveling it to 50. Only happened before unlocking the detachable mag at 25. Solution is to mash reload and fire until it triggers.
Mashing reload and mb1 it takes about a minute and causes slight (20-40) ping increase according to the games stat net command. Dropping and picking it up does the job quicker, atleast for me :P
I dont recall having these issues when I levelled it at 2012, would have propably given up with the amount of stutter I experienced using it these last few weeks. None of this using the one with separate magazine.
Sometimes it works fine, but there hasn't yet been a server I haven't been able to replicate this by trying.

Edit. TWI forums are back online, seems there wasn't anything of this. Could have very well been caused, or made worse, by the second latest patch.
"Weapons now track ammo on both the client and the server, stopping players to fire more shots with a weapon than the mag contains"
Last edited by SturmRatt; May 7 @ 4:24pm
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: May 4 @ 5:51am
Posts: 10