Rising Storm/Red Orchestra 2 Multiplayer

Rising Storm/Red Orchestra 2 Multiplayer

View Stats:
PUNKBUSTER B IS OBVIOUSLY AN ISSUE
Slowly but surely the posts are accumulating and this seems to be a new bug and common issue now. I have tried everything. It doesn't matter. I uninstall/install just to get B to run and it's just a matter of time before it vanishes. I have to manually activate it after I install it (even though it's set to run automatic, yep). After it vanishes after a couple matches it appears as though it was never installed, it's not there to reactivate.

Don't bother with telling me to reinstall, uninstall, run test or check firewall settings. It's been done a dozen times. You can "solve" the issue temporarily and then it will crash 20 minutes later.
< >
Showing 1-6 of 6 comments
And for the record this isn't a ro2 issue, it's a punkbuster issue. I had both A and B running. I haven't played ro2 since the last uninstall/reinstall/activate B process. - and guess what I just checked and B isn't running and doesn't appear to be installed (no ro2 launch involved)
Grizzly Jun 20, 2014 @ 9:37pm 
IMO, i see Punkbuster to be the worst service. It has quite alot of issues and most of them get very annoying, like the one you have been experiencing
Grizzly Jun 20, 2014 @ 9:38pm 
The best i can do is lead you to Moskeeto's FAQ, thanks to him some issues have been resolved
NETSCAPE NAVIGATOR Jun 23, 2014 @ 12:51am 
UPDATE: After doing everything as mentioned and recommended in the faqs ect ect..... I came across an issue that isn't brought up much...

Right click on pbsvc_hos.exe, go to properties, make sure to check run as admin. Then perform typical uninstall, install and update.

Seems to be working, so far.
Booger Mar 5 @ 11:04pm 
i have tried all the above including what you had mentioned "uninstall/ reinstall, run as admin and all other solutions i found online and none seems to work for me. im not sure if this is a windows 10 issue only and i cant just reinstall windows 7 since ive already invested alot oftime on windows 10.
No it's not. It's just a massive POS. I tried every fix over 20 times. The issue started at liike around 600 hours in game out of no where.

I avoid PB servers at all cost. PROBLEM SOLVED.

Don't waste your time.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: Jun 20, 2014 @ 6:01pm
Posts: 6