Rising Storm/Red Orchestra 2 Multiplayer

Rising Storm/Red Orchestra 2 Multiplayer

View Stats:
*AS* cruzsharky (furry) Jun 14, 2014 @ 7:10am
help me i had this game for 3 days and then punkbuster kicks me out
every time a join a server 1 minute later punkbuster kicks me out something failure it saids
< >
Showing 1-15 of 22 comments
Shamit Jun 14, 2014 @ 8:52am 
Do you have punkbuster enabled in the settings?
*AS* cruzsharky (furry) Jun 14, 2014 @ 9:04am 
idk
Warden of Icewrack Jun 14, 2014 @ 9:06am 
go to punk buster site and download the newest version. Sometimes punkbuster doesn't update automaticly.
*AS* cruzsharky (furry) Jun 14, 2014 @ 9:08am 
any other way
☭Terrible Player☭ Jun 14, 2014 @ 1:48pm 
Ive been playing this game for over 640h, and ive never had any problems with PB. until now. Suddenly when i join a server i get kicked soon due to error "service communications failure, or something like that. 1 i have reinstalled my game. 2 i also reinstalled punkbuster from the evenbalance site. no luck 3 i tried reinstall/update from binaries/windows/pbsvc_hos. still getting the error. 4.ive tried checking my firewall. there is nothing blocked from Ro2/punkbuster a,b.

This problem started today, i bought and installed rust, but idont know does it matter. Completely feeling annoyed. id so much like to play. i still this morning played it succesfully, no problems. only thing i can think of is a problem with rust.
Bodkins(UK) Jun 14, 2014 @ 4:41pm 
I had the issue - I Dled the PBsetup.exe and run that when it failed i dled the pbsvc.exe and run that which fixed the issue.

Both from the pb website
Last edited by Bodkins(UK); Jun 14, 2014 @ 4:42pm
Chocolate Treats Jun 14, 2014 @ 11:19pm 
Could this be related to the new system where you are banned from every server if you have ever had a VAC ban?
*AS* cruzsharky (furry) Jun 15, 2014 @ 8:55am 
it saids something about communication failure i think
*AS* cruzsharky (furry) Jun 15, 2014 @ 8:56am 
or was it cus i was kicked out of a server
*AS* cruzsharky (furry) Jun 15, 2014 @ 8:56am 
cus people voted me off
☭Terrible Player☭ Jun 15, 2014 @ 10:29am 
it IS a preoblem with punkbuster, and there is only one fix that has worked for me, removing the HOS folder from appadata/punkbuster. It is not perfect, as i have to do it EVERY TIME when i want to play ro2.
☭Terrible Player☭ Jun 15, 2014 @ 10:30am 
otherwise sometthing corrupts the file and it no longer works.
Zyfer Jun 16, 2014 @ 4:14am 
Originally posted by rainbowdash(brony+furry):
it saids something about communication failure i think

pnkbstr b is prob not running, find administrator tools under control panel > under the cat system and security, down the bottom, look for Services wherein you should be able to find both pbA and B (even tho i cant find pbB now that i checked, strange, i remember battling with it in there with bf2) but i'm "kinda" sure the problem might be coming from there
Last edited by Zyfer; Jun 16, 2014 @ 4:14am
[HS]=>®omano Jun 16, 2014 @ 6:41am 
Something that can work is to uninstall PB (go in C:\Program Files (x86)\Steam\SteamApps\common\Red Orchestra 2\Binaries\windows and run pbsvc_hos.exe as administrator, choose to uninstall)
Reboot computer.
Go in C:\Program Files (x86)\Steam\SteamApps\common\Red Orchestra 2\Binaries\windows and delete pbsvc_hos.exe. After deleting, verify the RedOrchestra2 files in steam, the pbsvc_hos will download to latest version.
Run this newly downloaded pbsvc_hos.exe as administrator to reinstall it.
Reboot computer and test if it worked.

One of my friend had problem and reinstalled many times from RO2 setup to other setup on evenbalance and nothing worked, and finally do what I wrote and then it worked.
Last edited by [HS]=>®omano; Jun 16, 2014 @ 6:41am
< >
Showing 1-15 of 22 comments
Per page: 15 30 50

Date Posted: Jun 14, 2014 @ 7:10am
Posts: 22