Batman: Arkham Asylum GOTY Edition

Batman: Arkham Asylum GOTY Edition

View Stats:
luca_starks Nov 27, 2012 @ 3:09pm
Arkham Asylum: Why is it not working?
I just bought Arkham Asylum GOTY Edition during the Steam Autumn Sale, but when I ran it for the first time, I received this error.

---------------------------------------------------------------------------------------------------

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileLoadException: Could not load file or assembly 'Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. Access is denied.
File name: 'Microsoft.DirectX.Direct3D, Version=1.0.2902.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'
at BmLauncher.DisplaySettings.IsNVIDIACard()
at BmLauncher.Form1.Initialise()
at BmLauncher.Form1.OnLoad(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].



************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4234 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
BmLauncher
Assembly Version: 1.0.1.0
Win32 Version: 1.0.1.0
CodeBase: file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Batman%20Arkham%20Asylum%20GOTY/Binaries/BmLauncher.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4228 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4234 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4230 (VistaSP2GDR.050727-4200)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------
BmLauncherUtils
Assembly Version: 1.0.0.0
Win32 Version: 1.0.1.0
CodeBase: file:///C:/Program%20Files%20(x86)/Steam/steamapps/common/Batman%20Arkham%20Asylum%20GOTY/Binaries/BmLauncherUtils.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50727.6195
Win32 Version: 8.00.50727.6195
CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d09154e044272b9a/msvcm80.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

_________________________________________

I got the EXACT same thing when trying to start up Arkham City GOTY Edition (which I got at the same time) as well.

HELP!!! :O I really want to play this game.
< >
Showing 1-15 of 56 comments
Bilbro Baggins Nov 27, 2012 @ 8:04pm 
I got the GOTY edition as well during the sale, and it will take me all the way to the launcher whenever I hit play in Steam. However, whenever I hit play on the launcher menu, the menu closes and the game doesn't ever come up. I don't understand what the issue is.
luca_starks Nov 27, 2012 @ 10:07pm 
Originally posted by CamryCowan:
I got the GOTY edition as well during the sale, and it will take me all the way to the launcher whenever I hit play in Steam. However, whenever I hit play on the launcher menu, the menu closes and the game doesn't ever come up. I don't understand what the issue is.

Did you get a window pop up with this error? That's what I got too...
TechnoRoadie Nov 28, 2012 @ 3:25am 
Saaaaame. -_-
Mr.Isma Nov 28, 2012 @ 5:20am 
Originally posted by Leon Wolftail:
Originally posted by CamryCowan:
I got the GOTY edition as well during the sale, and it will take me all the way to the launcher whenever I hit play in Steam. However, whenever I hit play on the launcher menu, the menu closes and the game doesn't ever come up. I don't understand what the issue is.

Did you get a window pop up with this error? That's what I got too...

I get an error message every time i hit the Play button..also the key that was given to me is invalid and can't be found in the database.
luca_starks Nov 28, 2012 @ 10:18am 
What? Seriously? That is not cool. I'm glad I'm not the only one with this issue.
Han Jabba Nov 28, 2012 @ 11:11am 
I also cannot launch it. I think I'm getting a different error than any of you guys. It says that it couldn't launch, and it the details of why, it says appcrash. Another error it shows after this, is General Protection Fault.
Han Jabba Nov 28, 2012 @ 11:29am 
it also mentions missing xlive.dll files, in the description of the error. I already looked that up, and installed the Windows Live thing that has fixed the issue for others, but with no luck. I may try and reinstall the game. Considering this is happening a bit with people who recently got the game, I am not positive a reinstall will work, though.
luca_starks Nov 28, 2012 @ 3:01pm 
Originally posted by Han Jabba:
it also mentions missing xlive.dll files, in the description of the error. I already looked that up, and installed the Windows Live thing that has fixed the issue for others, but with no luck. I may try and reinstall the game. Considering this is happening a bit with people who recently got the game, I am not positive a reinstall will work, though.

I don't think so either...and I can't even get the Live Client to work...
Mr.Isma Nov 28, 2012 @ 3:10pm 
I'm still waiting an answer from steam support..i send a ticket 5 days ago and still no response
luca_starks Nov 28, 2012 @ 3:48pm 
Originally posted by Mr.Isma:
I'm still waiting an answer from steam support..i send a ticket 5 days ago and still no response

Let us know what they say.
TechnoRoadie Nov 28, 2012 @ 5:37pm 
Mine works now; I installed everything in the "redist" folder in steam>steamapps>common>arkhamasylumwhatever>redist . Even the physX thing and I have a radeon card >_> Whether or not this works for anyone else I'm not sure, but I thought I'd mention it. Sounds like there's a bunch of different issues, so good luck to everyone. :\
Han Jabba Nov 29, 2012 @ 11:16am 
I finally got it working for me. It was Microsoft Live related. It was not fun, mind you. I had to install Games for Windows Marketplace, which still complained about xlive.dll. I restarted to see if that would help, and it did let me have the option to sign in, and then I was able to launch the game. The next problem I had was remembering my account info, and then the system being temporarily down when I tried to change my password. Of course, that has little bearing on the fact that the game launched, finally.
Lokig Nov 29, 2012 @ 12:24pm 
odd, similar query here although the game worked fine for me yesterday then similar issues to reported above
uppityplayer Nov 29, 2012 @ 12:38pm 
What system are you running on with to get this issue? Try downloading the latest Microsoft Directx setup and install. And try launhing by right click game and launch as administrator
Last edited by uppityplayer; Nov 29, 2012 @ 12:41pm
Lokig Nov 29, 2012 @ 1:11pm 
ok, got it working, you need to uninstall the windows live client, windows marketplace and Live sign in assistant. then reinstall fresh. you'll have to restart your computer at least once and then it works!
< >
Showing 1-15 of 56 comments
Per page: 15 30 50