legofpeace Jan 3, 2013 @ 7:20pm
bmgame has stopped working (solved for radeon (or ATI) cards)
I have an AMD A8 with AMD Radeon HD 6*** series graphics card. I found this patch download
http://www.gamershell.com/download_51260.shtml
which is version 1.1. I dodwnloaded and extracted to a folder I made on the desktop and then copied the files to the BatMan AA folder in steam aps. I then went into control panel and clicked on windows live esentials and chose to repair all live programs. Then I verified the game through steam where it corrected a few files and voiela, the game is up and running for me. If I run into any other issues I will figure out the fix and post them.
Side note, this was for GOTY running windows 7 home premium.
Hope this helps.
Showing 1-7 of 7 comments
< >
Flegias Jan 4, 2013 @ 5:15am 
i hope this will work.
win7 x64 ultimate and sapphire amd radeon 7970oc
batman aa goty
every software is up to date, bmlauncher keep crashing before even the splash screen.
now downloading the patch, fingers crossed
Flegias Jan 4, 2013 @ 8:29am 
no dice, still crashing.
btw i have noticed that if i start manually the physx installer, even the one in this patch says "text" while on the installation status, and won't proceed.
Voltouse Jan 4, 2013 @ 2:37pm 
I have a Radeon Sapphire 6850 and I believe my issue was that the game wouldn't launch because I didn't have physX installed. I had tried many solutions for my problem from GFWL to downloading DirectX.dll. It always came up as microsoft.NET framework exception and then the splash screen would show up after clicking continue. The splash screen however was having errors as well showing black rectangles instead of the "play"and "options" selections. After searching the internet over several days I found my fixes. I found the physX installer under this,

C:\Program Files (x86)\Steam\steamapps\common\Batman Arkham Asylum GOTY\redist

my file's name was: PhysX_9.08.14_9.09.0814_SystemSoftware
not sure if it is the same for everyone.

Now I had an additional problem where I couldn't move in the game but my "Esc" key would work. I had to go to this file,

Documents\Square Enix\Batman Arkham Asylum GOTY

and then delete the BmGame folder. I haven't had any issues since, no crashes yet and game saves just fine. Hope this helps some people.

P.S. If anyone knows Harmlesstank I had the exact same issue as him/her right down to the same errors with framework and general proctection fault. I don't know if that person was able to get the game fixed on their own. And the last post they made about the game was back in May 2012.
Flegias Jan 4, 2013 @ 4:12pm 
yeah, same installer as yours. but that installer just shows a screen with the word "text" in it instead of the classic progression bar. and does nothing else. so i think that it must be a broken physx installer. however borderlands 2 works just fine.
and about .net framework? what do you mean?
Voltouse Jan 4, 2013 @ 6:39pm 
It would be the same screen shots that this link has in first posting.

http://forums.steampowered.com/forums/showthread.php?t=2684705

I looked around to see how to fix it but came up with nothing for days. I tried to uninstall and re-install microsoft.NET framework 4 and 4.5 to get the game to work with no results.
Last edited by Voltouse; Jan 4, 2013 @ 6:42pm
"Ironwolf" Jan 6, 2013 @ 3:50am 
its a realtek on board sound issue . when you disable the realtek it launches fine. There is a conflict there ugh... but great i'll delete that folder atleast we know the cause now.
Fluttershy Feb 14, 2013 @ 3:13am 
how i can disble the realtek? (win 7)
Last edited by Fluttershy; Feb 14, 2013 @ 3:14am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jan 3, 2013 @ 7:20pm
Posts: 7