graymoor.66 Apr 28 @ 10:31pm
Cant play it.
I press play and get a message about please install latest Physx, I tried to do so, and my laptop is a brand new PC with Nvidia 860m and it tells me I have the latest Physx installed. Any help? It keeps saying Physx failed to initialize
Last edited by graymoor.66; Apr 28 @ 10:33pm
Showing 1-10 of 10 comments
< >
antonsheronov May 2 @ 11:47pm 
On the video settings page i get a message that my system is incompatible with PhysX, but i know that it is compatible for sure. Though graphics in the game looks like PhysX is actived (i checked the difference on youtube videos. So, maybe, that's not a problem at all.
NastyMarine May 3 @ 12:25pm 
Im having the same problem as OP. Dont know what the issue could be.
steeve May 3 @ 3:00pm 
Goto physx website and re-download latest version and install. Or get an earlier version.
http://www.nvidia.com/object/physx-9.13.0604-driver.html,

Hope that helps coz im loving it so far, its like a movie but you bash lots of mobs
Last edited by steeve; May 3 @ 3:03pm
graymoor.66 May 4 @ 2:51pm 
Thanks steve, I had a problem with MOH sp and downloaded drivers and that got Asylum and City working!! It is great isnt it?
steeve May 4 @ 2:55pm 
Originally posted by graymoor.66:
Thanks steve, I had a problem with MOH sp and downloaded drivers and that got Asylum and City working!! It is great isnt it?

Congratz.
Yep, I got it on a sale ages ago and installed it ..Really good gameplay, graphics and story :D
NastyMarine May 10 @ 2:41pm 
Im still having a problem with phyx. I've reinstalled B:AA, PhysX, and my entire Nvidia assets. Anyone find a work around for this?
NastyMarine May 10 @ 2:54pm 
AC and AO work fine for me. Its just AA giving me a problem. All my games work fine except AA.
kkumikeijjo May 11 @ 2:03am 
Not sure if it's patched yet. But earlier atleast if you just deleted PhysX and let the game download it's own version of PhysX (starting game without PhysX downloaded on your computer) worked great. Then it downloads PhysX when you launch game and with that version it should work. Worth trying if you don't get it to work.
graymoor.66 May 11 @ 1:02pm 
Originally posted by NastyMarine:
Im still having a problem with phyx. I've reinstalled B:AA, PhysX, and my entire Nvidia assets. Anyone find a work around for this?
Tried that link Steve put in this thread?
NastyMarine Jul 28 @ 4:38pm 
I got it to work sorry for the late reply!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50