Sgt. Zavatzky Mar 27, 2013 @ 5:21pm
Siberian Strike DLC - ERRORS thread
I got new DCL today in the morning and was happy about playing S:GW2 in the evening.

Unfortunately: I can not!

I start the Siberian Strike campain, the mission briefing screen shows,
in the upper-right corner appears the saving game icon and HD starts working heavily.
Then, after a few seconds of freezed screen all I get is this "CryEngine Error" window:

https://dl.dropbox.com/u/18389410/SGW2_CryEngine_Error.jpg

This is all strange, because the original single player campain still works.
There is no problem with mulitplayer as well.

Anybody with same problems?

Follow this thread and make sure to post your entry at:
http://city-interactive.com/en/Support

***** SOLUTION SUMMARY*****

After the latest patch form CI, relesed 11-04-2013 the memory allocation problem should be fixed:

"- Fixed the Memory allocation Crash at the beginning of Siberian Strike DLC which was occurring on lower end machines"

There is one more thing, not described in the patch summary, but mentioned in this discussion by "CI_tech":

If you have a 32-bit system which recognizes only about 3GB of memory, or your PC has less than 4GB of RAM than you must go to the advanced graphics settings and set texture details to minimum. This should make DLC working.

As my tests showed (Intel Core 2 Quad, Vista 32-bit, 4GB RAM, GeForce GTX 460) you may set all the other graphics settings at maximum. Only texture details should be modified to get rid off this bug.

Finally: If you made and error report and were asked by CI to run game in debug mode, then you have to turn this mode off. Otherwise you will not get the patch! In my case debug mode made also the multiplayer games not working (black screen after loading the map).
Last edited by Sgt. Zavatzky; Apr 18, 2013 @ 5:16am
Showing 1-15 of 168 comments
< >
[gT]lookin4kills Mar 27, 2013 @ 5:47pm 
I am having the same issue . I go to play single player I get to the loading , game save and it frezzes .?????????
netnerd85 Mar 27, 2013 @ 5:59pm 
You guys should post your PC specs. Might be something in common there?
[gT]lookin4kills Mar 27, 2013 @ 6:29pm 
Processor:Intel Pentium Dual CPU 2.00 GHzd. memory :4096mb Ram : directx 11, NVIDIA Geforce GTX 550 TI
[TU]I man a bad man™ Mar 27, 2013 @ 9:59pm 
you guys are lucky to even see it. i cant even find it
Sgt. Zavatzky Mar 28, 2013 @ 2:26am 
Intel QuadCore 2.4 GHz
4GB RAM
WindowsVista 32bit Ultimate (so it reports just 3GB of RAM)
NVIDIA GeForce GTX 460 @ GeForce 314.22 driver
Sgt. Zavatzky Mar 28, 2013 @ 2:30am 
Originally posted by gTlookin4kills:
I am having the same issue . I go to play single player I get to the loading , game save and it frezzes .?????????

Hope, that you wrote a letter to support at CI. I did. Still waiting for answer...
gujodel Mar 28, 2013 @ 7:08am 
Same problem for me ! Still waiting an answer from Steam & CI too.
Sv Mar 28, 2013 @ 7:13am 
Me too. I bought it on the day it released and I can't even play bcos of the that cryengnine error. Damn! But my friend do not have this problem. He is able to play. How come?
Sv Mar 28, 2013 @ 7:16am 
I am runing win7. Core 2 Duo. 2gb of ram. No problem with the main game. Even completed the game. Only DLC problem. Someone pls help!
gypsy-joker Mar 28, 2013 @ 1:48pm 
yes I am also getting the same error. Arma 2 OA plays fine. sure hope CI fixes this otherwise $10 dollars down the drain on a dlc
[gT]lookin4kills Mar 28, 2013 @ 1:59pm 
I can play the multiplayer just not the single player. Well I hosted my own server but just me in it .
I can also play the main game with no issues .
Last edited by [gT]lookin4kills; Mar 28, 2013 @ 1:59pm
assiduus Mar 28, 2013 @ 3:35pm 
The same problem here. Running Vista Business 32-bit, 2GB RAM, GTX460.
papabears1son Mar 28, 2013 @ 4:55pm 
same problem in first act, win 7, core 2 dur, 2gb ram, can someone find an answer?
gypsy-joker Mar 28, 2013 @ 7:16pm 
I updated the video driver and still the same problem - game stalls and crashes during the launch.


OS Name Microsoft Windows 7
Intel(R) Pentium(R) D CPU 3.40GHz, 3400 Mhz, 2 Core(s), 2 Logical Processor(s)
RAM 3.00 GB
NVIDIA GeForce 9500 GT 1 GB
[gT]lookin4kills Mar 28, 2013 @ 7:24pm 
Ive sent a ticket into steam support I will inform you all of the answer ,if they have one lol
Showing 1-15 of 168 comments
< >
Per page: 15 30 50