Acidity_Reflex Nov 23, 2012 @ 9:12am
LAGGY
Every time i start playing the game, its very laggy and i cant do anything. even on story mode and multiplayer it lags really bad. Please help.
Showing 1-9 of 9 comments
< >
Sysgen Nov 24, 2012 @ 3:08pm 
What are your specs?
Acidity_Reflex Nov 24, 2012 @ 11:56pm 
my internet shows full all the time
and i dont know my specs.
its all ok when it starts loading but when it says press any key to start mission or something like that then its all slow and laggy
Sysgen Nov 25, 2012 @ 8:13am 
From the RUN box (WIndows key + R) type dxdiag and press ok

The first tab is the system tab:
Processor: ?
Memory: ?
Page File: ? used, ? available
DirectX Version?

Second Tab is display:
Name: ?


Acidity_Reflex Nov 25, 2012 @ 10:59am 
Intel(R) Core(TM)2 Duo CPU
3072MB RAM
1313MB used, 4825MB available
DirectX 11

ATI Mobility Radeon HD 3470
GRUB Nov 25, 2012 @ 11:05am 
You need to go into options and then video and select best performance (It's the core 2 that is the issue); I had this same issue with my old system. Done a rebuild now and this machine can handle it all full everything.
Acidity_Reflex Nov 25, 2012 @ 1:14pm 
its still a bit laggy and now cant go on multiplayer but did help a whole lot.
thanks
GRUB Nov 26, 2012 @ 10:58am 
Glad it helped; don't think anybody can go on multiplayer ~ lobby/servers seem to be down.
Gary Nov 28, 2012 @ 7:17am 
I'm running Intel Core 2 Duo on this game, and I've had no problems. However I wouldn't advise putting all the settings on high, but on medium, and put post process quality on simple, not normal. The normal post process setting is a resource hog.
Guilmon Aug 17 @ 3:57pm 
intel core i5-3210m cpu 2.50ghz (4 cpus) ~25ghz
4096mb ram
11530mb used 3465mb available
directx 11

intel HD graphics 4000
Showing 1-9 of 9 comments
< >
Per page: 15 30 50