PenultimatePain Feb 4 @ 12:12am
Can't launch Peggle(any version)
Wanted to play some peggle deluxe, extreme, or nights today but I can't seem to launch any of them and I get an error that I have already tried all the normal ways to fix.

Error: "Failed to startup Steam: SteamStartup(0xe,0x0018E350) failed with error 108: The local Steam Service is not running"

If anyone knows anything about this, please post here.
Showing 1-10 of 10 comments
< >
Meteorite Feb 4 @ 12:54am 
Same here; working fine earlier but now I get the same error and the standard fix doesn't apply.

Also happens with my Zuma game, so it's looking to be the PopCap games in general.
MrZoolook Feb 4 @ 1:29pm 
Same issue.
aiusepsi Feb 4 @ 6:12pm 
Are you in the Steam Client Beta?
Hatty Feb 4 @ 6:17pm 
Originally posted by aiusepsi:
Are you in the Steam Client Beta?
Reverting back from the beta helped me run the game. Thanks!
PenultimatePain Feb 4 @ 6:49pm 
I have to be in the beta, i'm using family sharing :(
Psomaster Feb 4 @ 8:18pm 
Same here, in the same boat as PenultimatePain, Can't leave the beta to play because of family sharing.
Noobus Feb 5 @ 1:25pm 
Just wanted to chime in and say I too amd getting thise message , nothing much else to report but hopefully that it gets fixed soon.
Psomaster Feb 5 @ 1:51pm 
It was just fixed for me, reload steam in order to get an update. It might be beta only tho.
raymondbreed2012 Feb 12 @ 10:28am 
do this i got mine to work by doing this
Solution here:

-Go into C:/Windows/SysWOW64
-There should be a single file called bass.dll
-Remove it
-Start the game
MrZoolook Feb 28 @ 3:55pm 
for the record, using beta client no longer appears to bomb out Peggle for me!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50