Total War: SHOGUN 2

Total War: SHOGUN 2

View Stats:
Crashes in multiplayer
Hi i got Shogun 2 and FOTS.Anything runs perfect : medium - high settings no lagg , Singleplayer , Campaing Runs without crashed and anything.But in multiplayer i get crash after 3-4 battles than i click on Conquest Map.How do i fix it it's really anoying rejoining game.I can play but i just don't wanna get crashed.

Thanks
< >
Showing 1-11 of 11 comments
Nicklaus@CA  [developer] Sep 26, 2012 @ 1:42am 
Hi Iskrax, sorry to see you're having problems. As there is no dxdiag, I will have to post a variety of steps:


1) Go to C:\Users\YOURUSERNAME\AppData\Roaming\The Creative Assembly\Shogun2 (You may have to enable “Show Hidden Files” in Windows Explorer in order to see the folder)
2) Delete the following folders: (if some folders are not present, don’t worry)
- Army_setups
- Battle_preferences
- Fx_cache
- Ui_Cache
- Scripts
3) Right click on the Steam icon in Windows toolbar and exit Steam
4) Go to C:\Program Files\Steam and delete the following folders:
- AppUpdateStats.blob
- ClientRegistry.blob
5) Go to C:\Program Files (x86)\Steam\steamapps\common\total war shogun 2 and delete the shogun2.dll
6) Start Steam as an administrator (it will update) and validate Shogun 2 and validate Shogun 2 via Right Click on Total War: SHOGUN 2 > Properties > Local Files tab > Verify Integrity of Game Cache.



If you have 32-bit Windows:
1) A crash in Shogun 2 or FotS in conjunction with 32-bit Windows is due to the memory limitations of 32-bit Windows in conjunction with the increase in memory requirements for Fall of the Samurai.
2) To fix this, apply the fix known as “Mad Boris”. Detailed information on the problem and the workaround can be found here : http://www.twcenter.net/forums/showthread.php?t=238484

Windows Vista and 7
3) Run the Command Prompt as an administrator
4) Type the following: bcdedit /set increaseuserva 2500
5) Hit enter, and you should get a message confirming the change.
6) Reboot the PC and start Shogun 2

Windows XP
7) Find your Boot.ini, usually located on the C drive (may have to check Show Hidden Files and Folders)
8) Right click on the Boot.ini and choose properties. Uncheck “read only”
9) Open the boot.ini by double clicking it.
10) Under the section called [operating systems] find the line that says "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP...". Yours may look a bit different. We are going to make a duplicate, so that if you make a mistake you will not harm yourself from booting into your computer. Drag you're mouse across the entire line, right click and choose copy. Then right below the line you just copied right click your mouse and choose paste. You should now have two lines one after another that are exact duplicates.
11) Change the bottom line that you just copied with the following addition on the end. Add a space at the end of the line and then this without the quotes "/3GB /USERVA=2500"
12) In that lower boot entry you just made, find the name of the operating system in quotes and change it to something like "Windows XP 3GB", so you can differentiate at boot up.
13) Close and save the boot.ini.
14) Right click on the boot.ini, hit properties, check read only.
15) Reboot the PC and start Shogun 2


If that does not work, please create a new thread in our official Shogun 2 forums, which can be found here:
http://forums.totalwar.com/forumdisplay.php/96-Total-War-Shogun-2-Support-Forum

Our forums have a number of moderators who, along with myself, are willing to help you out with any problems you may have.

Nick Claus i posted this on forums about 2 weeks ago but noone helped me from yours administration.Thanks for help i will try do that but i won't go into Boot.ini i don't want risk.

If you can please go here http://forums.totalwar.com/showthread.php/43166-FOTS-keep-crash?s=b24031b7a805dcf5d4716c63d948b0e0
Last edited by [KING SHASHLYK] Iskrax; Sep 26, 2012 @ 1:51am
Nicklaus@CA  [developer] Sep 26, 2012 @ 2:42am 
Hi Iskrax,

I came back from a three-week long holiday two weeks ago, and unfortunately your post was within my holiday period, which is why I was unable to respond to your post. I have responded now, and I do think you should try the "Mad Boris" fix for your 32-bit Windows XP.
I will try Thanks...
Last edited by [KING SHASHLYK] Iskrax; Sep 26, 2012 @ 3:07am
Thanks for reply but i didn't understood what to do after 4-6 can i get something like video or something like eassy language ? Thanks
NoSyde Jul 30, 2013 @ 2:51pm 
ok, i tried this to get into a multiplayer game 20 minutes before this post. and your steps have made sure my game wont even start! whats the default value of the bcdedit /set increaseuserva?
Delta Mar 29 @ 12:11pm 
WHY IS THERE NO WINDOWS ME OPTION??!?!?! I NEED HELP HERE.
Iceira Mar 29 @ 12:41pm 
Originally posted by Delta:
WHY IS THERE NO WINDOWS ME OPTION??!?!?! I NEED HELP HERE.

because that OS is outdated and dead and gone, several years ago, if you cant get it to work under windows7+ , then game was build for that, then you are in serious trouble.
Windows ME? I'm fairly sure there there was a mad dash to dump that in short order once XP came around. Though given the necromantic nature and dramatic tone, I suspect trolling.

4 year old topic......the humanity.
Iceira Apr 1 @ 5:42am 
Originally posted by Hellsteeth30:
Windows ME? I'm fairly sure there there was a mad dash to dump that in short order once XP came around. Though given the necromantic nature and dramatic tone, I suspect trolling.

4 year old topic......the humanity.

well i agree on this , but it see several time ppl give/dump old pc away to another new pc owner and they dont know much what has been going on with lifecycle on such old OS.

ps.
just because XP OS pc is outdate its still the best system for Black and white 1, because MS has not fix own older titles. well this was not a topic for what dont work, just that xp pc could be a good idea to keep if you love older titles that still dont work on win7+ or vista
SkidaRu Apr 1 @ 2:16pm 
I had this problem over Lan. I found that by reducing all Ultra visual settings to High/Medium on the affect PC cured the problem. This combined with better system cooling. I experiance an increased frequency of soft crashes to desktop with hotspot system temps. Increasing system cooling and reducing overall GFX settings solved my problem. Cooling the Motherboard chipset is as crucial as CPU / GPU cooling.



Affected PC -

Windows 8.1
6GB Corsair
Asus GTX680
Asus Crosshair III MB
AMD Phenom II x4 955

Last edited by SkidaRu; Apr 1 @ 2:25pm
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: Sep 26, 2012 @ 1:12am
Posts: 11