[TFD] PyroManiiac Dec 21, 2012 @ 3:01pm
Game Crashes at Main Menu
This is my first post on steams forum, so I don't know the rules etc.

I recently update my PC hardware to better versions, Before that I played Shogun 2 no issues. Now when the game starts it goes through the intros etc. but it stays open in the menu for a seconds, then crashes and throws me back to the desktop. In the menu the there is sound etc.
Iv'e checked the forums briefly, couldn't find a solution.

Can somebody please help, I love this game, want to play it so bad.
Showing 1-9 of 9 comments
< >
Gashua Dec 21, 2012 @ 3:08pm 
total war shogun 2 just will not start meaning it wont launch it just says it does but doesnt i wonder what is going on it is happening to me as well i tried many things but i heard some theroies it could be any recent patch it just went bad im not sure what went wrong.
Gashua Dec 21, 2012 @ 3:09pm 
now that i take a look at yours mine wont even play the music or go to its crash mine is in a format that it can not start u launch from steam you wait a minute and it just doesnt get past that no matter how many times i might try it just will not budge
[TFD] PyroManiiac Dec 21, 2012 @ 10:11pm 
Is your video and sound drivers up to date? Did you install directx?

Mine does everything fine, up until about 1 second after the intro videos. It then just bums out.
Emmet Dec 22, 2012 @ 4:40am 
My friend had the same problem, he had to redownload EVERTHING again. Its a bummer because the game is so huge.
[TFD] PyroManiiac Dec 22, 2012 @ 4:57am 
If that atleast solves the problem for me then i'm fine with the update. Got Black Ops 2, gonna play that for now while it updates. Thanks for the info, hope it works.
[TFD] PyroManiiac Dec 28, 2012 @ 10:08pm 
Hey, I downloaded the game again. It didn't work, but now instead of crashing it freezes. I usually figure out whats wrong with games, but I can't seem to crack this one.
Please help if you can!
Gashua Dec 29, 2012 @ 3:09pm 
i fixed it after alot of hours all i did was delete the creative assembly folder in %appdata% then delete all the windows c+++ stuff then deleted local content of shogun 2 and reinstalled and manually installed its c+++ it worked for me
[TFD] PyroManiiac Dec 30, 2012 @ 1:10am 
Ill try that thx, hope it goes this time.
Gashua Dec 30, 2012 @ 4:02pm 
it worked for me took less then half of a week to solve the problem and take it out as well as discovering the locations of what to remove
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Dec 21, 2012 @ 3:01pm
Posts: 9