Star Wizard Dec 8, 2012 @ 1:53pm
Shogun 2 Crashes on first Load Screen with Corrupted Steam Error
Shogun 2 (I recently bought FoTS and RotS but haven't been able to play because of this) gets to the first Screen after launching at which point I get an error saying that my Steam installation is corrupt and this could be do to pirating the game (Which I am not doing of course) or mods or a virus/ cheat program. I have never downloaded mods for Shogun 2 or any Steam game, I have run MULTIPLE virus scans and Malware scans and have nothing. I have checked my registry for anything even close to the name "Incredibar" with no results. I have reinstalled Steam AND shogun 2 at least twice, Deleted .blob files and .pack files. and the folders battle preferences and script folders and verified game cache probably a dozen times. All very lengthy processes. NOTHING WORKS. PLEASE HELP!
Showing 1-15 of 61 comments
< >
Star Wizard Dec 8, 2012 @ 1:57pm 
I hesitate from posting my dxdiag because it will flood the screen with info, but if it is needed please let me know!
ShoobyUSMC Dec 8, 2012 @ 9:01pm 
same here amd no sollution in sight
Star Wizard Dec 8, 2012 @ 11:03pm 
Are they even working on it? Im just so distressed right now. I have 2 open tickets and one at Sega too and no one is answering or even acknowledging anything. Even the forums I read up on are from a few months ago and nothing recent. I'm so lost lol.
ShoobyUSMC Dec 8, 2012 @ 11:41pm 
I dont think they care bud, migh as well find a new game. In my experience they never lift a finger
Star Wizard Dec 9, 2012 @ 1:12am 
:( well thanks for posting something. At least I don't feel like the world ended and Im the only person living lol. It sucks because I bought FoTS and RoTS and never even got to play them. I doubt I will get me money back, but Im going to find some sort of Number and bug the ♥♥♥♥ out of someone!
baia74 Dec 9, 2012 @ 1:42am 
I´ve exactly the same problem... already tried every tipps there are, game and steam installed more then 6 times each and nothing works.... it´s a shame that CA still makes such ♥♥♥♥ mistakes and ♥♥♥♥ all their customers...
ShoobyUSMC Dec 9, 2012 @ 8:21am 
amen
Nicklaus@CA  [developer] Dec 10, 2012 @ 1:01am 
Hi, please try refreshing Steam, as it might need an update:
1) Exit Steam
2) Navigate to your Steam installation directory
3) Delete everything in the directory EXCEPT the following:
- Steam.exe
- Steamapps directory (All of Steam’s game files are kept here)
- Restart Steam to test the issue
Ceolnariazz Dec 10, 2012 @ 5:20am 
that one rly didnt work any othersolutionsplz ?!
baia74 Dec 10, 2012 @ 9:09am 
Didn´t worked out... same error... Corrupted steam..?????????
[GBG]DonutLove Dec 10, 2012 @ 12:03pm 
Sorry to hear u can play the game ,i havnt had any issues with it so i couldnt tell u what to do ,but u can try to go to the Total War Center website and ask for help there in the forums.Iam sure u can get a solution there
baia74 Dec 10, 2012 @ 2:43pm 
Its really sad that there isn´t any help from Steam.... i even bought Shogun 2 and some couple of clan packs 2 hours ago to try to play but no chance.... then game developers admire them selfs if people go pirates... next time its what ill do... at least will not have such problems.
Star Wizard Dec 10, 2012 @ 6:35pm 
Im thinking about pirating it just so i can play lol. As sad as that is, I see more help from people on Pirate cracking websites than on this issue. I do have a great admiration for Nicklaus@CA I see you everywhere man, every forum and relevant discussion you have given suggestions and helped a lot of people, I feel just from your efforts that CA is trying to make things better, but Steam is just failing so bad for us right now.
rolfskalder Dec 10, 2012 @ 8:40pm 
I gave up on this game long ago. When I first got it, it ran great. I played several campaigns on it. Then after a couple of patches, it began crahsing (and yes, I did update my drivers and my computer totally meets spec requirements). several months later, on a lark, I tried again and now it doesn't even get past the load screen. I went to TWI forum and saw that I indeed am not alone. Much as I would like to buy Rome II when it comes out, if they can't resolve issues with Shogun, I'm not giving them anymore of my money.
Star Wizard Dec 10, 2012 @ 9:51pm 
Yeah sorry Nicklaus, I tried your fix but it didn't work. I've reinstalled Shogun 2 and Steam multiple times. Checked for Incredibar in ym registry and ran several virus and malware scans. What is the cause of this? is it a certain file or what? it just baffles me that Steam would do this and that CA would let them... No one with these problems is going to buy Rome II lol.

On a second note, if no one has checked their registry for the Incredibar virus PLEASE do. It interferes with Shogun 2 in some way. Hit the windows Key then R (to get the the RUN box, I don't know if its still like this because I have XP lol) Once in the run box type regedit. Click on My Computer in the registry then press CTRL and F at the same time, when the box comes up type Incredibar and delete all instances of Incredibar from your registry. I saw this post when I first started looking for an answer, and it didnt work for me because I had no instances of Incredibar, but it seems like deleting the .blob files and all that seems to be said a lot, but I only saw the one instance of this from the main "READ FIRST" thread.
Showing 1-15 of 61 comments
< >
Per page: 15 30 50
Date Posted: Dec 8, 2012 @ 1:53pm
Posts: 61