voyager Mar 14 @ 11:53am
Shogun 2 won't start.
When I click on Play, nothing happens. steam status says "Playing Shogun 2" for a few seconds, then goes back to normal online.

Already tried checking game cache and deleting blob file but nothing helped me.
Windows 7 x64, 2Gb Ram, Intel Core 2 Duo E8400, Nvidia GT 430 1Gb
Showing 1-5 of 5 comments
< >
voyager Mar 14 @ 12:01pm 
Wow, steam forums seems broken right now, i were creating only one thread but instead it created 4!
Lbrand Mar 14 @ 5:06pm 
got same issue tried mby 20 different things to get it working but still no results
mater_tenebrarum Mar 14 @ 6:52pm 
Try the Pinned thread: "nothing happens".
Last edited by mater_tenebrarum; Mar 14 @ 6:53pm
Yankee Mar 19 @ 3:47pm 
Just bought the game and have the same problem.

I tried everything I found on the Interent for the last 2 hours but nothing worked.

This problem is there since 2011 and still not fixed.

Does anyone have any ideas? (tried verifying integrety; reinstalling c++, reinstalling .Net, reinstalling directX, reinstalling steam, reinstalling flash, deleting scrip files, deleting clientregestry.blob and a bunch of other things)

Seems like I wasted my money again on a game which doesn't even start......


EDIT: finally found a working sollution

go to "C:\Users\D\AppData\Roaming\The Creative Assembly\Shogun2\logs" then opened the txt file named modified. Inside it there were file names that were located in Steam's Shogun 2 "data" folder. delete all files in the modified list and it works
Last edited by Yankee; Mar 19 @ 6:08pm
Bouma Mar 23 @ 10:36am 
I cant even download this game off of steam anymore! It freezes up at preparing files for install. Its been like this for months and I thought it was just a steam problem that would get fixed eventually. Ive put many hours into this game in the past. It just times out before the download ever starts....
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Mar 14 @ 11:53am
Posts: 5