Sonic and SEGA All Stars Racing

Sonic and SEGA All Stars Racing

My Game is Kinda choppy...
Yeah, so i entered the game and it was really freezy, i freaked out because i thought at that timei did not spend my 50.00 correctly. i figured out it was just lag, but please. i need a lil' at LEAST a lil' help.
< >
Showing 1-5 of 5 comments
ThatNormalBunny Sep 7, 2015 @ 1:49am 
I don't know if you have sorted it out but take a look at this. I had some freezing problems and this guide helped me sort it all out :)

http://forums.steampowered.com/forums/showthread.php?t=2681565
funewchie Sep 7, 2015 @ 9:53am 
The advice in the pinned thread can help.

But to fix the stuttering issue, they recommend installing a .dll file called D3D9.dll in the game's folder.
Sadly the link they gave was removed by Steam's link auto-remover (which sometimes misreads things as phishing sites or spam sites).

But you can easily find it by Googling it.

Copying that into the Sonic & Sega All-Stars folder should improve things drastically.
---

In addition to that, you also might need to adjust the screen's resolution. Not too high, not too low, or it'll cause lag either way.

My dual-core Windows 8 laptop is normally 1366x768, but can smoothly run the game at 1028x768. I found when I had it set to a lower resolution, it actually made the lagging worse. And of course at 1366x768 it lagged.
So, you'll need to find that zone where it works beautifully.

But the D3D9.dll should help the stuttering a lot.
NecroMaster™ Sep 9, 2015 @ 5:42pm 
I made this when my grammar was crap. Sorry if my overimpatience for the game annoyed you guys, because there are those kinda people.
After toying with the graphic settings for about half an hour, (as well as installing that D3D9.dll file) turns out what was causing me the most lag was the model quality. Tthink the default is two players, set it to one and things ran much smoother.

Disabling the other stuff helped, but it was the model detail setting that was single-handedly the cause of the stuttering.
Blue Jan 29 @ 3:59am 
I set everything on high and it was smooth as butter.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50