Psychedelic Jan 5, 2013 @ 7:13pm
[FIXED - CHECK COMMENTS] ARMA II / ARMA II - OA "Bad Serial number given in setup" (actually tried everything)
Recently, I (as well as plenty of others) have been receiving an error from both ARMA II and ARMA II - Operation Arrowhead, reading "Bad serial number given in setup" upon starting the game.

After spending about 35 dollars for 2 copies of Combined Operations, I had only played for about week or two when this error started happening. This is money that could have gone towards playing a much better game, considering most servers on DayZ, which I purchased this pack for, are filled with glitches and hackers. I played on a multitude of servers over the course of the time I owned this game (about two weeks) and 9/10 of them, I was killed or lost items due to a hacker (in one case, I was turned into a dog and run over with a pickup truck). The quality of the game itself is abysmal and the support provided by Bohemia Interactive as well as Valve is even worse. After about 6 hours of following EVERY GUIDE ON THE INTERNET (none of which worked) I'm heading to the forums here for help.

I've tried the following:
- Running steam as admin
- Verifying game cache (5+ times)
- Clearing the regedit of both games as well as of Bohemia Interactive
- Restarting both games to allow for initial setup
- Editing permissions to allow for ALL users to have access to every file in the game folders
- Doing ALL of the above after uninstalling and reinstalling both games

This is a last ditch effort on my part; my brother and I have both been players on Steam for several years and I've honestly never been this disappointed with the quality of support. Normally a simple Google search can fix just about any problem in a few simple steps. In this case, the combined (although relatively small/lazy) efforts of both Bohemia Interactive and Valve aren't even enough.

Side note: when I right click on the games in my library and choose "View CD key", the only thing displayed is "requesting key...." - this never changes.

I can give specs if needed. Does anyone have another solution for this problem?
Thanks in advance.
Last edited by Psychedelic; Feb 24, 2013 @ 2:07pm
Showing 1-15 of 91 comments
< >
juhe # Road to MGE Jan 6, 2013 @ 10:25am 
i have same problem i click view cd key and spend about 2hours and it didi give it :/
Psychedelic Jan 6, 2013 @ 10:47am 
If you guys are having similar problems, it may be beneficial to go on other forums and ask other users. If you discover a solution, please inform me, as I have been trying in vain to correct this problem for several days.
Psychedelic Jan 6, 2013 @ 4:08pm 
Originally posted by darthcircuit:
I finally got mine to work. This is what I did:

Close steam completely.

Get into regedit and do a search for "arma 2 oa"

you will see 2 bohemia interactive folders in the left column. delete both arma 2 oa folders.

run steam as an admin, then verify your game cache. A

After that, the game should launch ok.

If that didnt make any sense, I followed this video: http://www.youtube.com/watch?v=_-U9yFhK7S0

Read the discussion buddy. I already did that.
Simon Petrikov B>Steдm Items Jan 6, 2013 @ 4:25pm 
If anyone comes through here telling you do restart steam as an admin and downloading the game again (or running the game again) it doesn't work. I've tried both. I'm also having similar problems to what you're having. Sorry if you've heard that before. But I'm going to be checking back here regualary to see if I can get a solution as well. Sorry for the false notification, but if I learn anything I'll check back here to make sure to tell you.
Phoeniix Jan 6, 2013 @ 7:22pm 
I'd like to see a fix for this as well.
Psychedelic Jan 6, 2013 @ 7:23pm 
Originally posted by Simon Petrikov:
If anyone comes through here telling you do restart steam as an admin and downloading the game again (or running the game again) it doesn't work. I've tried both. I'm also having similar problems to what you're having. Sorry if you've heard that before. But I'm going to be checking back here regualary to see if I can get a solution as well. Sorry for the false notification, but if I learn anything I'll check back here to make sure to tell you.
I'm glad to see that I have someone I can sympathize with, as i know the frustration we both feel. I will continue looking for resolutions, yet all my attempts up to now have ended with the same failing result. I appreciate your help.
Simon Petrikov B>Steдm Items Jan 6, 2013 @ 8:00pm 
Originally posted by Vyprr RyanK42, Bambi Overlord:
Originally posted by Simon Petrikov:
If anyone comes through here telling you do restart steam as an admin and downloading the game again (or running the game again) it doesn't work. I've tried both. I'm also having similar problems to what you're having. Sorry if you've heard that before. But I'm going to be checking back here regualary to see if I can get a solution as well. Sorry for the false notification, but if I learn anything I'll check back here to make sure to tell you.
I'm glad to see that I have someone I can sympathize with, as i know the frustration we both feel. I will continue looking for resolutions, yet all my attempts up to now have ended with the same failing result. I appreciate your help.
Not a problem, also, I've contacted both Steam support and Bohemia Interactive. When (or if when referring to Steam Support) I get a reply I'll make sure to tell you, I made sure to tell them that we've tried almost everything.
Psychedelic Jan 6, 2013 @ 8:07pm 
Originally posted by Simon Petrikov:
Not a problem, also, I've contacted both Steam support and Bohemia Interactive. When (or if when referring to Steam Support) I get a reply I'll make sure to tell you, I made sure to tell them that we've tried almost everything.
Great. I have not contacted either group, but if they do not respond to you I will be happy to contact (spam) them. Thanks!
Simon Petrikov B>Steдm Items Jan 7, 2013 @ 9:21am 
Hey m8, I got my copy to work. On the chance that you havent have you tried reinstalling steam? Go to your steam folder and delete everything except Steamapps and Steam.exe. Thats what fixed it for me. Bohemia Interactive customer support sent me some other fixes if that doesn't work for you.
Simon Petrikov B>Steдm Items Jan 7, 2013 @ 10:48am 
Originally posted by darthcircuit:
Originally posted by Vyprr RyanK42, Bambi Overlord:
Read the discussion buddy. I already did that.

No need to be rude. I was just posting what worked for me. You aren't the only person in the world with this same problem.
I don't think it was rude at all. I understand him being fustraited because of all of these diffrent fix's that havent worked for him, and even if you think he was still out of line he DIDN'T post what he had done already for people NOT to read it.
Phoeniix Jan 7, 2013 @ 2:35pm 
Gonna go ahead and bump this thread. Still in need of a fix.
Psychedelic Jan 7, 2013 @ 4:41pm 
Originally posted by Simon Petrikov:
Hey m8, I got my copy to work. On the chance that you havent have you tried reinstalling steam? Go to your steam folder and delete everything except Steamapps and Steam.exe. Thats what fixed it for me. Bohemia Interactive customer support sent me some other fixes if that doesn't work for you.
This sounds like a good idea... only problem is that I have other games than ARMA II Combined Operations, with a similar gigabyte size. Redownloading all my other games ( TF2, Terraria, Planetside 2, Just Cause 2, etc. ) would take quite a long time. I understand by what you said that it would not delete the games, but if i accidentally corrupt them ( like ARMA II seems to be like now ) I don't want to have to redownload them all. Just a question though, did any of your games corrupt? If they didn't, I may try this solution. Much appreciated.
jonahmoter Jan 7, 2013 @ 9:17pm 
Originally posted by Iimel_Boy FIN:
i have same problem i click view cd key and spend about 2hours and it didi give it :/
i get an error code that says i have bad pixel shading or something when i launch the game , really annoying cuz it wont let me play and more :( :/
jonahmoter Jan 7, 2013 @ 9:20pm 
Originally posted by Vyprr RyanK42, Bambi Overlord:
Originally posted by darthcircuit:
I finally got mine to work. This is what I did:

Close steam completely.

Get into regedit and do a search for "arma 2 oa"

you will see 2 bohemia interactive folders in the left column. delete both arma 2 oa folders.

run steam as an admin, then verify your game cache. A

After that, the game should launch ok.

If that didnt make any sense, I followed this video: http://www.youtube.com/watch?v=_-U9yFhK7S0

Read the discussion buddy. I already did that.
i dont get redgedit but i have a differnt prob mine says that i have bad pixel shading
black KIMMI Jan 7, 2013 @ 10:50pm 
ull have to start upp as admin
Showing 1-15 of 91 comments
< >
Per page: 15 30 50
Date Posted: Jan 5, 2013 @ 7:13pm
Posts: 91