Eversion > 综合讨论 > 主题详情
obi 2013年2月13日上午11:14
Started crashing on Linux
Except for the time attack crash I mentioned in another thread the game worked fine. Today when I wanted to run it I got the following error:
Failed to load installscript ~/Steam/SteamApps/common/Eversion/installscript.vdf
Game update: AppID 33680 "Eversion ", ProcID 30824, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Setting breakpad minidump AppID = 33680
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198039999416 [API loaded no]
Available Modes
1920 x 1080
1680 x 1050
1600 x 900
1440 x 900
1400 x 1050
1280 x 1024
1280 x 960
1280 x 768
1280 x 720
1152 x 864
1024 x 768
1024 x 600
800 x 600
800 x 480
640 x 480
ALSA lib dlmisc.c:270:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
/dev/dsp: Device or resource busy
embedded: [BUG] Segmentation fault
ruby 1.9.3p194 (2012-04-20 revision 35410) [i386-linux]
The library it's looking for is in /usr/lib/alsa-lib/ rather than /usr/lib/i386-linux-gnu/alsa-lib/ but the error persists even if I make a symlink.

Works fine if I run it outside of steam.
正在显示第 1 - 6 条,共 6 条留言
< >
flibitijibibo 2013年2月14日上午11:30 
Try adding this to the ./Eversion script, somewhere before it actually executes the game binary:

export SDL_AUDIODRIVER=alsa
最后由 flibitijibibo 编辑于; 2013年2月14日上午11:30
obi 2013年2月14日下午12:08 
Thanks for the input but I already know about this workaround, and it's not ideal, since my soundcard isn't capable of hardware mixing. It works to some extent, but the sound is distorted and it only works if no other program is using the soundcard, else it keeps crashing.

The main problem is that is used to work just fine with pulseaudio and it stopped working with one of the recent updates (looking at steamdb.info it seems Eversion didn't get changed at all, so it must be a Steam problem).
flibitijibibo 2013年2月14日下午12:56 
Ah, fair enough.

If you happen to have build tools, you can build Audiere for that particular setup:

https://github.com/flibitijibibo/Audiere

Just undo this commit here:

https://github.com/flibitijibibo/Audiere/commit/c1e405a7cdb303bdd7522cb5dc9e6e260637bb0e

And it should give you better audio via PortAudio rather than ALSA.
obi 2013年2月19日上午5:46 
I was just about to try out your suggestion when I remembered that the last time I made the symlink it was to the 64bit libraries.

Now I just did a
ln -s /usr/lib32 /usr/lib/i386-linux-gnu
since it searches for them in that directory. Game works ok now (with sound through pulseaudio).
flibitijibibo 2013年2月19日上午9:12 
Weird, I just got this with Beat Hazard, but only when running via Steam. I'm wondering if the search for i386-linux-gnu/ is the result of the Steam runtime, as we don't have this on Fedora either (Eversion and its libs were built on this distro, so that original ALSA failure came as a surprise).

Edit: Sure enough, Eversion doesn't always work for me on Steam either. And I ported the dang thing!

We need to file this with Valve, as it's a Steam bug.

Edit 2: Ah, found your report, nevermind. https://github.com/ValveSoftware/steam-for-linux/issues/1730
最后由 flibitijibibo 编辑于; 2013年2月19日上午9:27
obi 2013年2月19日上午9:59 
Ah good thing you reminded me about the report, I just updated it to include my workaround.

Ah, didn't know you did the porting. Thank you for the port.

Edit: According to the feedback I got: "This will be fixed in the runtime for the next update.".
最后由 obi 编辑于; 2013年2月20日上午3:25
正在显示第 1 - 6 条,共 6 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年2月13日上午11:14
帖子数: 6