fluent2332 Dec 26, 2013 @ 3:56pm
Crash upon start up (Solved)
Hello. I'm running Win 7 64-bit and the game crashes after the Ascaron logo. Any ideas what could be causing this? I've tried fiddling with compatibility modes, running as admin, etc. and nothing has seemed to fix it. I really want to play this game, so if anyone has any tips, please let me know. Thanks!

Last edited by fluent2332; Jan 15 @ 5:53pm
Showing 1-5 of 5 comments
< >
DEDALX305 Dec 30, 2013 @ 6:19am 
чето смысл игры я не понял
fluent2332 Jan 4 @ 4:10pm 
Can anyone help? Steam doesn't even respond to my inquiries about this game. There has to be something I can do to get this game to run on my computer....
noivoieidoi Jan 5 @ 10:07am 
I have no idea what's going on with this game - I played it for almost 30 hours and suddenly something went wrong. Right after manually deleting a bunch of save files, it didn't work anymore (crash right after the intro). Restoring them didn't help. Said something about not having the necessary permisions to access some file. Tried myself a lot of things after carefully reading the error log and in the end I manually deleted every single related file I could find and reinstalled the game. Didn't work. On the Internet I couldn't find any help. Gave up.

Recently I reinstalled Win7x64, then everything else. This time, the game works again (~20h, so far). I guess that doesn't help much, but I can't think of anything else, other than some radical solution, like install it on another PC, or find and correct the files or registry entries I couldn't find, or delete them and reinstall the game. I cannot remember if one year ago, when it stopped working, I used a decent uninstaller or not (like IOBit Uninstaller), but I believe I did.

However, before doing anything you might regret, make sure you checked all the usual suspects: antivirus, firewall, any other application running in the background which might cause the crash, audio and video codecs/filters you installed on your PC (various versions of ffdshow caused me problems with some games in the past)
fluent2332 Jan 15 @ 5:53pm 
I fixed it!!! Here's how:

Another game I installed (Age Of Wonders) was crashing, too, so I searched on how to fix it. Turns out, I had to create a DEP exception for the older games (I'm using Win 7 64-bit). So, to do that, do this:

Go to Control Panel, click System and Security.

Click System

Click Advanced System settings on the left

Click Performance - Settings

Go to the Data Excecution Prevention tab

Check the circle that says "Turn on DEP for all programs except those I select..."

Click Add - go to the directory of the game, add all the .exe files.

Click apply and you're done! The game will now work on Win 7 64-bit!

Yeehaw!


blueak Aug 26 @ 6:51pm 
Thanks for your help, fluent!
Showing 1-5 of 5 comments
< >
Per page: 15 30 50