Tropico > General Discussions > Topic Details
sendingsignal Jan 8, 2013 @ 6:08pm
Game won't launch.
I checked the thread below but it seems I've got a different problem. The game simply won't launch at all. I tried running tropsafe and launching in xp safe mode.
Showing 1-7 of 7 comments
< >
Twelvefield Apr 5, 2013 @ 12:10pm 
I just bought the game and installed it. I also had trouble launching it. STEAM claimed the game was running, but it was doing nothing at all. Even task Manager did not show anything. Then after about five minutes the game kicked in and ran fine. I guess it's the initial game set-up, but with no popup window to say what is going on. The second time I ran the game, it worked just fine.
Last edited by Twelvefield; Apr 6, 2013 @ 4:19pm
qashqai2 Aug 15, 2013 @ 4:19pm 
To sendingsignal, Have you tried lauching the game as an Administrator. Never had this with Tropico but had it with other older games.
neviem Oct 22, 2013 @ 12:23pm 
same here, game wont launch no matters what i try (admin, compatibility mode) :(
[_-= Zer0 =-_] Jan 17, 2014 @ 5:26am 
If you have technical problems with Tropico please write an e-mail to the Kalypso Media Support " support@kalypsomedia.com ".

Please include a description of your problem, a DxDiag.txt. and a link to this thread within the mail.


To create the DxDiag.txt, please do the following:

Click "Start" button and choose "Run". Or alternatively, press (Windows-Button)+R.
Then type "dxdiag" (without quotation marks) and click Ok.
You will find all relevant information in the following window.
Click the "Save all Information" button, located at the bottom of the program window.
Save the file as "dxdiag.txt".
Attach the file "dxdiag.txt" with your E-mail reply.

Thank you very much for your assistance.
Zapp3012 May 18, 2014 @ 4:37pm 
Sorry to bump an old thread, but has anyone got a solution to this?
I'm trying to launch the game, and steam briefly says 'In game - Tropico' then back to 'Online' within a few seconds.
I've tried running as admin, tried compatibility mode for XP, even tried Win98 mode lol.

Basic spec...
Windows 7 X64
AMD FX-8350
Radeon HD7970 3Gb
16Gb RAM
Samsung 840 Pro SSD
Da1n1us Jul 1, 2014 @ 4:51am 
Same here, anyone know solution?
=Snappy= Jul 27, 2014 @ 10:26pm 
didn't work. did "nothing", as described above. (exe was running but didn't actually do anything.)

under compatibility settings...
compatibility mode: win xp SP3
disable desktop composition
run as administrator

then it worked.

GL.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50