From Dust > General Discussions > Topic Details
bronze turkishboy Jun 17, 2013 @ 12:41pm
Ubisoft Game Launcher Error HELP!
I just downloaded the game and I tried the play it but when I press the play button it says "Ubisoft Game Launcher error. Reinstalling the game maybe fix problem." I didn't try the reinstall the game but i won't too.

Anyone knows the solution?
Showing 1-3 of 3 comments
< >
Cyberjoker Jun 17, 2013 @ 7:21pm 
Possible solution!!
1. Delete your old launcher if you have it, it would be located under:
C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher
or C:\Program Files \Ubisoft\Ubisoft Game Launcher
Just delete the "Ubisoft Game Launcher" folder completely.
2. Download the launcher separately (credit to forum user "Chris2Collins" for the link) - http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe
and install.
3. Click play

Found this on the Ubisoft Forums it worked for me
Last edited by Cyberjoker; Jun 17, 2013 @ 7:24pm
bronze turkishboy Jun 18, 2013 @ 5:45am 
There isn't Ubisoft Game Launcher and there is more weird thing, I "can't" install the new launcher because it says "There is already Ubisoft Game Launcher." And I can't find it and uninstall it!
Nao Jul 5, 2013 @ 2:44am 
oh mother of cats! Thanks a lot Ensinge that worked!
The stupid uplay wouldn't even open and kept crashing. The recent security breach and pw changes may have messed it up...
Showing 1-3 of 3 comments
< >
Per page: 15 30 50