From Dust > General Discussions > Topic Details
Rose Omni Jun 6, 2013 @ 2:55am
Game doesnt work.
I ran this game perfectly fine when it was brand new. I have the same computer as I did then, and the game just crashes every time I click Play. It doesnt even start loading or anything, it just immediately gives me an error. Am I missing something? Google doesnt help.
Showing 1-3 of 3 comments
< >
Rose Omni Jun 6, 2013 @ 2:56am 
And before you say it yes, I have made sure my drivers are up to date.
Sveenerton Jun 8, 2013 @ 9:21pm 
KERBAL GUNNERZZ
Cyberjoker Jun 17, 2013 @ 7:21pm 
Possible solution!!
1. Delete your old launcher if you have it, it would be located under:
C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher
or C:\Program Files \Ubisoft\Ubisoft Game Launcher
Just delete the "Ubisoft Game Launcher" folder completely.
2. Download the launcher separately (credit to forum user "Chris2Collins" for the link) - http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe
and install.
3. Click play

Found this on the Ubisoft Forums it worked for me
Last edited by Cyberjoker; Jun 17, 2013 @ 7:22pm
Showing 1-3 of 3 comments
< >
Per page: 15 30 50