homeless12 Nov 10, 2012 @ 12:19pm
Ubisoft Game Launcher not working! Error code 1
When I try opening AC2, I get a message saying "Unable to find Ubisoft Game Launcher," suggesting that I should try reinstalling the game (Error Code 1). I've looked far and wide into the Internet and have tried various techniques (reinstalling AC2, logging off of steam and reinstalling, restarting my computer and reinstalling, finding an updated version of Ubisoft Game Launcher and replacing the old one, etc) will no avail. Has anyone run into this problem recently? If so, what did you do?

It sucks because this is the first Steam game I have bought and I feel like I just threw away $20.

I am running a Mac OSX 10.5.8.

Any help would be greatly appreciated!
Showing 1-6 of 6 comments
< >
xteuk Nov 11, 2012 @ 1:29pm 
Juste the same here. I found something though :
- The downloaded installer of Ubi GameLauncher in Steam's game folder is not working. So i downloaded it from there : http://uplay.ubi.com/.
- You'll have to download it (wait), then run it by yourself, so it can update (wait again). Once this is done, close the Launcher, run the game from Steam (which will run the launcher in another way) and ...
- Wait again for UPlay to download i-don't-know-what-oh-my-god.
- Done on Windows Seven. Hope the same will work for Macintosh.

PS: i haven't created nor used any Ubisoft account for this.
PPS: Just to reassure yourself : i bought a lot of games (25) by Steam, and it's my first problem running one.
homeless12 Nov 11, 2012 @ 9:15pm 
Hey, thank you for the response!

Where did you find the Ubisoft Game Launcher download on the uplay site? Also, can the game launcher just run by itself like you said above?
xteuk Nov 14, 2012 @ 3:57am 
Hi again,
On the french version of the uplay site, there is a big yellow button on the upper-right corner.
And yes, the Ubisoft game launcher is created to be launched by itself, but i haven't tried.
homeless12 Nov 20, 2012 @ 4:59pm 
It didn't work :(. Thank you for trying though!
bequietplease Jan 1, 2013 @ 3:29am 
Xteuk's solution worked fine for me. However, I had to login to UPlay. Thanks!
Detxs34 Jan 11, 2013 @ 8:55am 
When i try to download the game launcher there is an error.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Nov 10, 2012 @ 12:19pm
Posts: 6