Xenohenheim Oct 25, 2012 @ 5:37am
Stuttering Problem
Hello everyone !

First of all, please apologize if my English isn't perfect.

I have a problem with AC2 : Stuttering. The game is very fluid, smooth BUT every 20/30 seconds (generally when I run and jump) the game freezes for half a second. As you can see, it's not terrible but it's damn annoying !

I searched on countless forums but couldn't find an answer to my problem.

- The game runs very well most of the time.
- Whatever the graphics settings I put (Multisampling, quality, V Sync : On or Off), there is no differences
- I had a similar problem with AC1 but I found out that disconnecting Internet solved the problem ! I tried to do this (now that the game can run offline) and it didn't solve the problem
- I have the latest graphics drivers ; I degragmented my disk recently

So, do you have any ideas ? Thank you very much for your help !

Have a nice game ;)

[EDIT : We found the source of the problem. You can thank Steam user "Thrik" for that =P If you have a Nvidia graphics card, try downgrading your drivers. For laptops essentially, this driver version works like a charm : [url=http://www.nvidia.com/object/notebook-win7-winvista-64bit-280.26-whql-driver.html]
If you have a Nvidia graphics card, try downgrading your drivers.

For laptops essentially, this driver version works like a charm :
[url=http://www.nvidia.com/object/notebook-win7-winvista-64bit-280.26-whql-driver.html]http://www.nvidia.com/object/notebook-win7-winvista-64bit-280.26-whql-driver.html
Last edited by Xenohenheim; Nov 25, 2012 @ 2:21pm
Showing 1-15 of 123 comments
< >
jc wondrous Oct 26, 2012 @ 12:22am 
I have the exact problem... Even when I set all graphic settings to lowest, it still freeze although very rarely.
Xenohenheim Oct 26, 2012 @ 11:50am 
Exactly the same here. I think it's due to the fact that Ubisoft isn't really good at porting console games to the PC.

It's not unplayable, just annoying especially when you consider how smooth it appears the rest of time.

Hopefully, someone on this forum will have an idea !
tuktuken Oct 27, 2012 @ 2:25pm 
I have the same.. i try ti fix it all ways i found in google, but any one of them helps :/
jc wondrous Oct 29, 2012 @ 12:05am 
I found disabling the vsync helps a bit.
Xenohenheim Oct 29, 2012 @ 12:31am 
I disabled it in the first place but thanks. And I don't know if it's my imagination or not but disabling Internet seems to slightly improves things (less frequent stutters).

I wonder if Uplay doesn't cause this...
Doomed Avatar Oct 30, 2012 @ 4:15am 
Another one with this problem. The game is running at 45-60 fps, but when i run or make quick actions, the game stops for a second (also the framerate drops to <15 fps) and then it continues as usual. This stuttering is constant and, while the game is playable, it puts me out of my nerves. It's really strange because it seems that my computer can run this game perfectly. I tried everything (gamebooster, disabling internet, reinstall game and nvidia drivers, etc.), but nothing seems to work. It's frustrating because I can run AC1 and Brotherhood without any problem. I know that my system specs aren't wonderful (GT540M 2 Gb, 6 Gb RAM, i5 2400 Mhz), but i can run a lot of demanding games without this problem. I hope someone finds the way to solve this.

Sorry for my english.
Xenohenheim Oct 30, 2012 @ 4:24am 
At least, it's good to know that the problem doesn't extend to Brotherhood. Therefore, we know are sure that the problem comes from the game itself.

I'm sure there is a tweak that suppress this problem because a lot of people are enjoying the game without encountering this kind of stutter. We just have to hope that someone will manifest itself on this forum (finger crossed)
thrik Nov 1, 2012 @ 5:37am 
Do you guys have NVIDIA cards? Just trying to narrow down the problem.

This is ♥♥♥♥ing me off too...
Xenohenheim Nov 1, 2012 @ 11:51am 
Yes, I have a Geforce GT 540M.
thrik Nov 1, 2012 @ 12:17pm 
Which driver are you using? I'm using the latest beta one myself, 310.33
Xenohenheim Nov 1, 2012 @ 12:53pm 
I just know it's the latest one.
Version : 9.18.13.697
As for the latest pack, I think it was : 306.97
thrik Nov 1, 2012 @ 1:31pm 
Hey Xenohenheim, I've just emailed Ubisoft about the issue. I even linked to this thread so they could see what we're going through :)

I will post here if/when they respond back to me.
Xenohenheim Nov 1, 2012 @ 3:00pm 
Thank you Thrik ! I consulted their forums but never took the time to post there.

Hopefully, we'll have an answer soon.
Doomed Avatar Nov 2, 2012 @ 12:35pm 
I have a GT540M too and I'm using the 306.97 drivers. Maybe it's the card, but i've never experienced this kind of stuttering in other games. Yesterday, I realized that the game stops in determined points of the map, everytime I pass throught this points, the game stops for a second.

Thanks thrik, let's hope that Ubisoft will respond you soon.
thrik Nov 2, 2012 @ 1:29pm 
Ubisoft still hasn't responded despite their claim that they would respond within one business day. Sigh... well anyways I'll keep you all posted.
Showing 1-15 of 123 comments
< >
Per page: 15 30 50
Date Posted: Oct 25, 2012 @ 5:37am
Posts: 123