MeatThatDad Mar 17, 2013 @ 10:44am
Just Won't Launch
Bought this the other day just got around to trying to play it.
I click it to launch it and absolutely nothing happens except the box around my steam username turns green for like 2 seconds and says in game but then back to blue. no error messages from steam or windows or anything else, just straight up nothing.
I've tried obvious things like adminstrator and different compatibility modes but nothing i've done seems to get the game going.
Any suggestions?
Showing 1-15 of 47 comments
< >
tristanthurlow Mar 17, 2013 @ 11:41am 
I can't play either. It says ubisofts services are unavailiable. Idk what to do.
Goodguy3 Mar 17, 2013 @ 7:48pm 
Mine just crashes without a word to the Uplay "Thanks for the $5 playing!" thing.
AceOfSpades Mar 17, 2013 @ 9:56pm 
Same problem. When i click to start the game, nothing happens whatsoever.
AceOfSpades Mar 17, 2013 @ 10:02pm 
After some reading and testing i believe the problem to be with uplay, this program wont start either, same thing there. Clicks it, nothing happens. Tried all the common stuff, running as admin, other windowsmodes etc. Way to go Ubisoft.
AceOfSpades Mar 17, 2013 @ 10:23pm 
Some Progress now, managed to install uplay , start it, enter cd-key and get to the gamescreen, however when i click "play" in the uplay window, it loads for a second, then displays the "after game report". Still no way to start the game...
mk220vt (old lid) Mar 18, 2013 @ 2:04am 
I had the same problem, go into c/program files(86)/steam/steamapps/common/assassins creed .. Find the exe. right click go to properties at the bottom click it then select run as administator. Make sure you have exited steam and assassins creed first.
AceOfSpades Mar 18, 2013 @ 5:19am 
Thank you kindly mk220vt, that worked, game runs now.
jianliang_lee Mar 18, 2013 @ 6:44am 
mine cant work even when i run as admin... any suggestions?
Last edited by jianliang_lee; Mar 18, 2013 @ 6:44am
jianliang_lee Mar 18, 2013 @ 6:45am 
its just goes to the update launcher than after awhile the launcher just closes...
mk220vt (old lid) Mar 18, 2013 @ 8:56am 
Try runing the Steam exe. as admin? steam don't reccomend it although I do for some titles it seems to solve some of the issues with non steam games.
[RCG] Wolfswar Mar 18, 2013 @ 11:50am 
Same problem here. But i can't find the exe. file. Is it just me?
(sorry for bad english i am dutch)
OverBah2800 Mar 18, 2013 @ 12:42pm 
hello from Russia
I solved this problem.
Firstly I downloaded Ubisoft Game Launcher:
http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe
Then I installed UGL to the directory "C:\Program Files\Steam\steamapps\common\Assassin's Creed 2\Ubisoft Game Launcher"
So, after that, I chose the compatibility with XP of UPlayBrowser.exe in the folder Assassins Creed 2
And finally I ran AssassinsCreedIIGame.exe in the same folder.

But when the Uplay is run, create a new account
Don't forget copy the game key, when the UPlay will be run.
It works in my situation
Sorry for my level of English
Last edited by OverBah2800; May 16, 2013 @ 5:36am
avanmonsjou Mar 18, 2013 @ 3:58pm 
Originally posted by Glazeek:
hello from Russia
I have just solved this problem.
Firstly I downloaded Ubisoft Game Launcher:
http://static3.cdn.ubi.com/orbit/launcher_installer/UbisoftGameLauncherInstaller.exe
Then I installed UGL in the directory (attention) "C:\Program Files\Steam\steamapps\common\Assassin's Creed 2\Ubisoft Game Launcher"
So, after that, I chose the compatibility with XP of UPlayBrowser.exe in the folder Assassins Creed 2
And finally I just ran AssassinsCreedIIGame.exe in the same folder.

But when the Uplay run, create a new account
Don't forget to copy the game key, when the UPlay will be run, it will asked for the key.
In my situation it works

I had the same problem, and this fixed it
CheekiBreekiIvDamke Mar 18, 2013 @ 4:28pm 
I got to the creating a new account part of Glazeek's solution, but I'm still getting the unavailable server error-- in absence of evidence to the contrary, I guess that Ubisoft servers are actually down. Their website is as well.
DTJ2000 Mar 18, 2013 @ 4:43pm 
can someone help me i get error 83 and im really mad i was hoping to play the game this weekend but it just says error 83. glazeek's solution didint help and im not sure what he said
Showing 1-15 of 47 comments
< >
Per page: 15 30 50
Date Posted: Mar 17, 2013 @ 10:44am
Posts: 47