The Lord of the Rings: War in the North
Bruno Lelé Jan 23, 2013 @ 4:07pm
I can't play. Blue Screen
Hi I bought the Lord of The Rings: War In The North via Steam and at the hour of running it just does not work.

It tries to start and then after the computer restarts. Upon reboot appears an Windowns' error log saying "Blue Screen".

Anyone out there know what to do?

PC Configuration: AMD Bulldozer FX6100 X6;
8GM Ram, Win7 Professional 64-bit,
Nvidia GT430.

I need help. Thanks!
Showing 1-15 of 28 comments
< >
❖๖ƬᏲα║∂єɴ ❖ Jan 31, 2013 @ 2:18am 
Sounds like you have a problem with your computer. The game should not have any effect on your computer after a restart.
folkemon1977 Feb 16, 2013 @ 11:12am 
Same problem by me. I can play, but game freezes and sometimes cause blue screen.
I have no problem with other games, PC is running without problems.
I think problem is in graphics - it need patch, sadly, excelent game... :-(

PC conf.: Intel Core i5-3570K
8 GB RAM, Win 7 Ultimate, SSD
Sapphire HD 7970 OC 3GB GDDR5
folkemon1977 Feb 20, 2013 @ 2:44pm 
All is in AMD drivers.
All you need is older version 12.6.
I can´t play due lagging and blue screen.
After driver reinstall i´m playing fine :-))
All settings is on max and there is no lags nor freeze.
Bruno Lelé Feb 22, 2013 @ 1:57pm 
how i can change my drive to the oldest version?
folkemon1977 Feb 23, 2013 @ 12:55am 
Visit this sites (Windows 7, AMD desktop graphics):
64 bit
http://support.amd.com/us/gpudownload/windows/previous/Pages/radeonaiw_vista64.aspx
32 bit
http://support.amd.com/us/gpudownload/windows/previous/Pages/radeonaiw_vista32.aspx

Download version 12.6, uninstall current drivers, restart PC and install 12.6 version. If installer asked for download new version press button skip.
Hope it helps.
Martin
Mothra Sep 12, 2013 @ 6:33am 
Thanks for link
emob0yflips Nov 9, 2013 @ 5:46am 
Lets hope this works because im getting the same problems and im getting really pissed off and sad about it... but if it works thx for the help!
Stefan Nov 9, 2013 @ 2:03pm 
check your hdd for errors
goat breeder Nov 16, 2013 @ 12:43am 
i cant play ether

my computer:

AMD FX(tm)-6100 six-core
14,0 GB (12,0 GB can be used)
64-bit


can i plz get help? :(
PerspectiveDesigns Nov 16, 2013 @ 7:59am 
I'm having the same problem. The game runs perfectly at maximum settings. But as soon as I get to the first scene with the eagle I get a blue screen.
Mattjamco Nov 16, 2013 @ 9:33am 
Had the problem, damn you BSOD ><
goat breeder Nov 17, 2013 @ 6:52am 
i think that it is some problems whith the graphic card i have the same problems with some other games like border land 2, it might be som connection the the other games?
Last edited by goat breeder; Nov 17, 2013 @ 6:52am
Doomzday Nov 17, 2013 @ 8:41am 
Did downloading the 12.6 Catalyst drivers work for any of you? My friend tried them and it didn't solve his problem.
Last edited by Doomzday; Nov 17, 2013 @ 8:42am
A Stunned Goat Nov 17, 2013 @ 9:41am 
mine wont even start runing haha i get to "click to play" then it goes black and says its not responding
Bruno Lelé Nov 17, 2013 @ 6:12pm 
I have the same problem. I bought this game for over 1 year and never got to play even one minute.

I have the same AMD Bulldozer 6100 and a computer more than enough to run this game, but simply does not work.

I gave up, it was money thrown away.
Showing 1-15 of 28 comments
< >
Per page: 15 30 50
Date Posted: Jan 23, 2013 @ 4:07pm
Posts: 28