The Lord of the Rings: War in the North
Polite Heathen Dec 25, 2012 @ 9:35pm
Problem joining game
My friend and I recently bought this game, and no matter what ports we forward or what we try we simply CANNOT join each other's games. It says can not establish connection to host..

How on earth do you fix this? This is frustrating.
Showing 1-15 of 30 comments
< >
Inkubus Dec 27, 2012 @ 1:26am 
Same here. I completely opened up my router, hosted a game, and nothing..
gvparpura Dec 27, 2012 @ 10:15am 
try making private match, not a public one, that helped me
Inkubus Dec 27, 2012 @ 12:51pm 
I've tried both, nothin
Polite Heathen Dec 27, 2012 @ 5:34pm 
Any way to fix this crap? It's annoying.. it's the entire reason we bought the game
Inkubus Dec 27, 2012 @ 5:35pm 
Same here, I bought it for coop as well. I have no idea how to fix. I'll let you know if I can find a way though.
Polite Heathen Dec 27, 2012 @ 9:03pm 
thanks man, same with me. I might ask for a refund.. pretty unacceptable
Mista 4K Dec 30, 2012 @ 1:44pm 
Same problem, guys. :(
Polite Heathen Dec 30, 2012 @ 5:24pm 
Ugh, I don't understand what could possibly be causing this?
Insanefox Jan 1, 2013 @ 10:30am 
Start the game ! and if you are already ingame and able to walk around - invite your friend. this worked to me and 2 friends!
[2BAO]Orkon Jan 4, 2013 @ 12:51am 
Ive looked everywhere its like no fix exists, this is getting very annoying
Inkubus Jan 4, 2013 @ 1:27am 
Yeah I have too. The thing insane fox said doesnt work for me
mgraise Jan 4, 2013 @ 5:28am 
We have the same problem(( Two of us can connect, but when the 3rd tries to connect to the game there begin connection problems(( We rotate, we try to connect turn by turn, but there is no result((
>> CHRIS << Jan 4, 2013 @ 12:33pm 
same problem / selbes problem :((
BAeHbErLeIn Jan 4, 2013 @ 12:55pm 
The same problem over here!
Tried to play with 3 friends and it always fails after 10 minutes stating "lost connection to host"

3 days ago it worked perfectly fine, now it's unplayable!

We only bought it for the co-op play ... They better fix this!
Last edited by BAeHbErLeIn; Jan 4, 2013 @ 12:56pm
chriso475 Jan 5, 2013 @ 12:03pm 
Bought this to play with a friend and after starting game and walking round for ten minutes it said his connection was lost to me. This problem is ♥♥♥♥ing annoying and the only reason i bought it was for the coop. I want a refund
Showing 1-15 of 30 comments
< >
Per page: 15 30 50