Tron 2.0

Tron 2.0

Tron 2.0 > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
schmatzler Oct 11, 2014 @ 12:39am
[GUIDE] Multiplayer | Widescreen | Bugfixes
In its original state, this game is a bit outdated. It doesn't support widescreen, multiplayer is broken and it has some bugs.

We have compiled a neat little guide for you that covers most of the issues you may have with this game and makes sure you can really enjoy it in 2016:

http://steamcommunity.com/sharedfiles/filedetails/?id=325088441

If you have any questions that are not answered in this guide, please leave us a comment and we'll get back to you as soon as possible.

Thanks! :)
Last edited by schmatzler; Feb 8, 2016 @ 3:37am
< >
Showing 1-15 of 148 comments
Stormkiller Oct 11, 2014 @ 4:41am 
Many thanks for the post, it helped me loads! This definitely needs to be pinned.
Colonel Cabbage Oct 11, 2014 @ 5:00am 
The unofficial patch makes my screen completely black whenever I run the game. Then when I run the killer app installer, it says "TRON 2.0 has not been run before,
you must run TRON 2.0 at least once" constantly although I've ran it at least twice... What should I do?
Last edited by Colonel Cabbage; Oct 11, 2014 @ 5:00am
Oct 11, 2014 @ 5:53am 
Find the tron.exe under the steam install folder, right click it and select properties. The go to Compatability tab and make sure 'Run as Administrator' is ticked. Apply changes and run the game at least once again. Now the Killer App Mod should install. Details taken from - http://www.moddb.com/mods/killer-app
NetSlayer Oct 11, 2014 @ 6:29am 
Originally posted by Colonel Cabbage:
The unofficial patch makes my screen completely black whenever I run the game. Then when I run the killer app installer, it says "TRON 2.0 has not been run before,
you must run TRON 2.0 at least once" constantly although I've ran it at least twice... What should I do?

right click lithtech.exe (in your install folder) and in compatibility settings check:
- run as admin
- disable desktop composition
Colonel Cabbage Oct 11, 2014 @ 7:45am 
Thanks. Disabling desktop composition fixed it. :)
Mcl_Blue Oct 11, 2014 @ 8:05am 
Everything installed correctly, but when I run the game, the mod simply doesn't show up. Instead, the regular game loads. What to do?
NetSlayer Oct 11, 2014 @ 8:22am 
Originally posted by Mcl_BlueMadness:
Everything installed correctly, but when I run the game, the mod simply doesn't show up. Instead, the regular game loads. What to do?
uninstall killer app and start over.
and next time NEVER start using steam. Launch manually by creating a shortcut to lithtech.exe.

Sometimes it installs but thinks you want to play retail.
There is a new custom button on the launcher in this case
(Middle-Bottom of the launcher)
hit that and uncheck retail.

then bob's your uncle.
he used to be my uncle, now you can have him.
LDSO Oct 11, 2014 @ 9:23am 
You can't run TRON 2.0 from Steam after the first time (when Steam goes through its spiel of setting up DirectX and then the game). If you run TRON 2.0 from Steam again after the first time, it resets all the game's settings to default. Which plays havoc with any mods you install.

If you want to use mods, you'll have to follow the advice in this post: http://steamcommunity.com/app/327740/discussions/0/613938693140540232/#c613938693151016390

I know this stinks, because then you can't use the Steam in-game overlay, and you won't be able to use the Steam Sync feature to cloud save your games. I'll try to figure out a workaround that will let you keep running the game from Steam.
Last edited by LDSO; Oct 11, 2014 @ 9:25am
Oct 11, 2014 @ 9:31am 
My control problems go even further. Steam not only takes screenshots when I jump but "A" on the keyboard doesn't work either, so I can't strafe left. Unfortunately disabling the screenshot key in Steam is not an option (it hides the symptom but doesn't fix the cause.)
Running the game as administrator fixes the screenshot bug but doesn't fix the strafe issue.
I'll do some more tests later today. Need to take a break from not being able to play this game :\
nhlkoho Oct 11, 2014 @ 10:40am 
My screenshot key is set to F12 yet the game still takes a screenshot when I jump

edit: running as admin did not help either
Last edited by nhlkoho; Oct 11, 2014 @ 10:42am
NetSlayer Oct 11, 2014 @ 10:50am 
Do not run through steam at all...
Make a shortcut to lithtech.exe and run from there.
Perhaps a further patch will allow you to run from steam without issues but not this time.
~Ren~ Oct 11, 2014 @ 10:58am 
Thanks for the guide, I'm downloading it now so I'm sure this will come in handy
Rex Christus Oct 11, 2014 @ 12:27pm 
I looked through the launcher and the widescreen fix has reset back to 4:3. I had this trouble with AvP 2 (same engine) but the widescrren fix was easy to switch back on. I cannot find any way to do this on Tron. What am I missing?

actually I think the apsect ratio is still 16:9 but the resolution (1920 x 1080) has been reset. I fired up my trusty 'ole CRT and played the game at 1600x1200 and the game looks elongated, as if running in the wrong aspect ratio.
Last edited by Rex Christus; Oct 11, 2014 @ 12:55pm
Black_HobbiT Oct 11, 2014 @ 12:34pm 
Have no sound in game(but have sound in launcher), no matter what sound device chosed (560 Ti, creative live, intel HD) and no matter installed non-off patch and KA mod. Weird.
Last edited by Black_HobbiT; Oct 11, 2014 @ 12:35pm
Dan/Pepper Oct 11, 2014 @ 12:56pm 
3. Steam takes a screenshot every time I jump
No one has mentioned this yet, but I experienced this on my setup after doing all these steps. To stop Steam from doing that, go to Settings->Ingame and remove the key combination for doing a screenshot, so it's empty. [/quote]

If you still want to have screenshots for other games, you can just disable the steam overlay for this game in it's properties in the library.
< >
Showing 1-15 of 148 comments
Per page: 15 30 50

Tron 2.0 > General Discussions > Topic Details