Star Wars: The Force Unleashed Ultimate Sith Edition
backstaber09 May 15 @ 2:03pm
destroy the orbital ship - never getting green
Ok so i am at the mission destroy the orbital ship so i push it down and almost in the end and then it never gets green i am trying to push it to the sides up and down and i am following what it says i need to do and when i am done it dosent get green so i can push it down so i cant beat this mission and its really annoying
Last edited by backstaber09; May 15 @ 2:03pm
Showing 1-8 of 8 comments
< >
JasonPlaysGames May 17 @ 10:05am 
I'm having the same issue. Played that missing for about 30 minutes last night, only got the opportunity to pull it down once. Every other time it may or may not turn green at all, just stuck.
backstaber09 May 17 @ 10:11am 
i beat it just dont stop taking it down last time before that happen so just keep pulling stil even when the tie fighter shot you and you should beat it
JasonPlaysGames May 17 @ 4:52pm 
Yeah, tried that, let the tie fighters take me all the way down to almost no health. I don't remember it being this difficult on xbox360. I'll keep trying, thanks.
filmmakerartist1 May 19 @ 4:39pm 
This part of the game is complete trash. It could have been so cool but instead it's one of the worst moments in gaming.
crowdsourc3d May 22 @ 1:58pm 
Getting the SD into the green was easy once I ignored the key commands. I use A to turn the SD to the left BUT I also have to use S to make the nose move up a bit. If I don't do that, the nose bumps up against soem invisisble barrier and A no longer turns the SD.

But once I get it in the green and the command to pull it out of the sky, the key graphic says press S and pull back on the mouse (while still holding Grip). Nothing happens. I tried all the buttons and direction on the mouse over my dozen+ attempts. I simply can't make the SD move down. I think this is a bug, as I found mention of it from 2 years ago on a gaming blog. No answer, however.

EDIT: I'm on a Mac.
Last edited by crowdsourc3d; May 22 @ 2:00pm
Lor-Oliver Jul 9 @ 8:46pm 
Guys do you need a graphics card to play this game
Nerevar's Goat Butler Jul 9 @ 8:47pm 
Originally posted by Swag Oliver:
Guys do you need a graphics card to play this game
Are you saying my lemon-based rig wont work? I spent so much time and money of this god damn thing!
Aaron O'Regan Jul 30 @ 12:52am 
i had this issue. All you need to do is point the front of the destroyer in the center of the screen and then point the front up and you will pull it down. Ignore the green light at the end.
Last edited by Aaron O'Regan; Jul 30 @ 12:52am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50