Star Wars - Jedi Knight: Mysteries of the Sith
Nagra [CH] Jan 20, 2013 @ 8:43am
Fix for Windows 8 not running the game
Here's a fix for all Windows 8 users whose game simply doesn't launch :

Go to your Steam folder, and from there, go to :

"...\steamapps\common\Star Wars Jedi Knight" for Jedi Knight
"...\steamapps\common\Jedi Knight Mysteries of the Sith" for MotS

For Jedi Knight delete the Jedi.EXE file that you'll find there.
For MotS delete the Sith.EXE file that you'll find there.

Then you must change the compatibility settings for JK.EXE (for Jedi Knight) and JKM.EXE for MotS to Windows XP (Service Pack 3).

To do this, right-click the file, then click "Troubleshoot compatibility". Select "Try recommended settings". Windows should now automatically set the compatibility to Windows XP SP3.

You will then be asked to test the program before closing the window. Both games should now run normally. You're welcome.

Here's where I found the first part of this fix : http://www.overclock.net/t/1343907/star-wars-dark-forces-2-jedi-knight-mots-on-windows-8

Thanks to manuel for finding the second step.
Last edited by Nagra [CH]; Jul 8, 2013 @ 4:16pm
Showing 1-14 of 14 comments
< >
NateTheGreat Jul 8, 2013 @ 4:10pm 
Thanks. This really helped me.
Nagra [CH] Jul 8, 2013 @ 4:17pm 
Originally posted by NateTheGreat:
Thanks. This really helped me.
You're welcome. A little comment on my profile ? :)
tschrotty Jul 13, 2013 @ 1:18am 
Thanks ... great Job
feangren Jul 16, 2013 @ 2:42pm 
Thanks you, that was really helpful ! :)
Nagra [CH] Jul 16, 2013 @ 2:50pm 
Originally posted by feangren:
Thanks you, that was really helpful ! :)
You're welcome. A little comment on my profile ? :)
Sandarr Sep 7, 2013 @ 6:01pm 
Thanks [bli] [WUT] [FRIDOM] Nagra

Great advice. Appears to working fine now. Thanks again.
Nagra [CH] Sep 8, 2013 @ 12:57am 
You're most welcome :)
-{RS}- Berserkorgoth Dec 23, 2013 @ 4:42pm 
thanks for the help and this fix works on Windows 7
Cap10wow Jan 17 @ 5:36pm 
the game keeps telling me to insert the game cd 1 any ideas?
Freedom_Fighter Jan 19 @ 7:01pm 
Same as Cap10wow, please help.
Last edited by Freedom_Fighter; Jan 19 @ 7:04pm
Ajax Jan 26 @ 9:43am 
I have the same problem as Cap10wow and Farix, although I have Windows 7. I've tried the above but it doesn't work. Anyone have any solutions?
Korey Feb 1 @ 3:14pm 
it still doesn't work for me... when i launch it's just a black screen for a second and then back to desk top
mattjames121 Mar 8 @ 1:00pm 
when i play only shows the black screen and the HUD
max May 3 @ 1:33am 
dude thx
u are the best
Showing 1-14 of 14 comments
< >
Per page: 15 30 50