Star Wars: Knights of the Old Republic
Rhaegor Sep 30, 2013 @ 5:16am
Any1 able to help me with this?
http://store.steampowered.com

Much appreciated!
Showing 1-15 of 15 comments
< >
Sesh Sep 30, 2013 @ 6:13am 
That is strange. Any mods?
Rhaegor Sep 30, 2013 @ 7:32am 
none. just installed the game
Sesh Sep 30, 2013 @ 1:40pm 
Try tweaking the video options. Do the cutscenes work? You should also verify the local cache.
Rhaegor Sep 30, 2013 @ 10:52pm 
Cutscenes work but still with the models like in the SS
Sesh Oct 1, 2013 @ 1:39pm 
Are the models animated? Can you walk around? This is a very strange issue that looks most like what happens when you install a bad mod but you don't have any mods. I would try some compatibility modes but I really don't know what is wrong.
Rhaegor Oct 2, 2013 @ 12:26am 
I can move around and the arms are moving.. legs are not.. yeah i'm puzzled too
Rhaegor Oct 3, 2013 @ 12:17am 
I tried playing a little to see if there would be other problems that would perhaps lead to a solution.. oddly enough all I found was that only the "organic" pc's are cut to peices and jumbled. while droids and everythings else is as it should be.
Amagr8 Oct 3, 2013 @ 12:22am 
Thats how thew game started? can you move around at all?
Rhaegor Oct 3, 2013 @ 12:32am 
Yes and yes. No mods. cutscenes work. movement is animated. everything in the game is as it should be except the "organic" N/PC's
Sesh Oct 3, 2013 @ 11:57am 
Have you tried verifying the local content at all?
Rhaegor Oct 5, 2013 @ 2:55am 
Yes I have
Sesh Oct 5, 2013 @ 12:43pm 
Well I have a few ideas that may work or may mess you up worse, but I can't tell what is going on. First, if you haven't tried it already, reinstall. This game also has some issues with some of the extra stuff modern computers have (microphones, and anything removable) if you have any of that stuff unplug it. The final idea is download and install an old driver from the time KotOR was new, this could really mess up other games though and you shouldn't do it without first creating a restore point.

Is Malak (the guy on the main menu screen) the same way?
Rhaegor Oct 5, 2013 @ 12:57pm 
Tried reinstalling that sadly did nothing. could try the old driver idea. and yes malak in menu is the same way as ingame
ghostrecon1997 Oct 21, 2013 @ 4:21am 
made an intelligent axe-wielding virus?
Rhaegor Oct 21, 2013 @ 7:46am 
Oh I fixed it.. tried reinstalling my drivers and that did the trick
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Sep 30, 2013 @ 5:16am
Posts: 15