Star Wars Starfighter

View Stats:
nick.642 May 3, 2013 @ 12:19pm
your 3d adapter is not able to initialize
I get this every time I try and start the game up.

your 3d adapter is not able to initialize the resolution and color depth selected.
please try updating your video drivers, or lowering your display resolution/color depth

I updated my video card drivers. Still does it. I changed the settings and tried everyone I could. Still get it.

I've got a GTX 560 Ti for video card on windows 8.
Showing 1-10 of 10 comments
< >
jimmygwabchab Jan 20, 2014 @ 3:13pm 
I know I'm pretty late but hey. I too am having this issue. Running Windows 8 but have GTX 660. Did you ever manage to fix it?
AstroGinga Jan 21, 2014 @ 12:24am 
i gave up like 6 months ago XD
nick.642 Jan 26, 2014 @ 10:39am 
I ended up getting a new video card a few months ago and when I changed the options with the new one it works. dunno why it wouldn't work with my 560 though.

try
options
configuration options
and play with those a bit.
jimmygwabchab Jan 29, 2014 @ 5:50am 
Got it working in the end. It was all to do with a bad monitor :S I have no idea why that has anything to do with anything
nick.642 Jan 29, 2014 @ 7:22am 
that's good i enjoyed this game back when i had it for my ps2 lol
jimmygwabchab Jan 30, 2014 @ 9:36am 
yeah same haha. It was cheap on steam so thought I'd rebuy for a bit of nostaglia. Not disapointed
Volsong Jan 7 @ 7:58pm 
I still can't get this working and there isn't much info on the net about it. I'm running a GTX 660 Ti on Windows 7 64 bit with latest drivers. Won't even work in compatibility mode or under Administrator.

Does not compute. =\
evilgenius92 Feb 10 @ 5:46pm 
So I believe i have found a solution for nvidia cards. If you go into nvidia control panel go to "adjust desktop size and position" after that click on the tab "scaling". Make sure the box is checked for override the scaling mode set by games and programs. This has worked for me so far without any problems.
Last edited by evilgenius92; Feb 10 @ 5:47pm
AHordeOfBunnies Feb 11 @ 12:54am 
I found a fix. After installing DirectPlay and DirectX 8.1 (as the game prompts you to) I went into Options -> Configuration Options and on the first Tab (Video) there is a menu labeled Display adapter. Mine was set to "Primary Display Adapter" instead of my actual graphics card. The thing is, I only have one graphics card. So i dont know what it was trying to use initially. Once I changed that the game ran for me. It's surprisingly playable too!
caste1200 Feb 11 @ 1:28am 
I can't get it to work with my 295x2 :(
Showing 1-10 of 10 comments
< >
Per page: 15 30 50