TRON: Evolution

TRON: Evolution

LDSO Oct 7, 2014 @ 10:24am
Having trouble getting TRON Evolution to work? Possible Solution.
So I'm seeing a lot of people complain that they can't get TRON Evolution to work. I posted some tips in a couple of other topics, but I thought I'd create a new topic so people can more easily find this.

I don't have the Steam version, it's a Retail DVD copy I bought several years ago. I'm not sure if the Games for Windows Live client that comes with the Steam release is up to date. But on the retail copy, it's old and what causes the game not to work on Windows 8/8.1/10.

I made a video showing the steps I took to get TRON Evolution working on Windows 10. The same steps apply to Windows 8/8.1. (You can skip ahead to the part about Evolution by clicking on the number 2 when the sidebar on the left appears.)

http://www.youtube.com/watch?v=u1YL1flpadk
Now I'm not going to force you to watch the video, but if at any point you're unsure of what to do, the video should help because you can visually see what steps to follow.

Here's a download link to the most recent version of the GfWL client. This version is NOT available from Microsoft's site, for some idiotic reason.

{LINK REMOVED}

Extract the files from the .zip, and run the XLiveUpdate.msi installer. This will install a GfWL update over top of the one that came with the game.

After installing this update, Evolution SHOULD now work properly.


EDIT:

Your software firewall may block Games for Windows Live and prevent you from signing in. You need to add an exception to your firewall that allows "C:\Program Files (x86)\Disney Interactive Studios\Tron Evolution\Binaries\Win32Live\GridGame.exe" to always communicate with the Internet.

Also, there's a service called the "Microsoft Account Sign-in Assistant" that needs to be running. Without it, GfWL will not work.

Go to the Start menu on XP/Vista/7/10 and type services.msc in the search box, then hit Enter. On Windows 8/8.1, just start typing on the Start screen.

Make sure the "Microsoft Account Sign-in Assistant" service is running. If it's not running, then start the service. Then try signing in again with GfWL in TRON Evolution.


And just to prove that GfWL does work and is NOT shut down, I took a screenshot of being signed in on TRON Evolution. Check out the time and date. 10/7/2014 (October 7th, 2014).

http://abload.de/img/evo_signed_inj7ds3.jpg

It's possible you may have to visit the Xbox.com site, sign in with your Microsoft/GfWL/Xbox Live account, and agree to the updated Terms of Service. Not agreeing on the site could also prevent you from logging in.

Do not try to run GfWL before starting the game, or you will get the error message in the screenshot below. The latest version of GfWL only works in-game now.

http://abload.de/img/evo_gfwl_errorznreg.png


Also see this topic, the game not loading at all may have to do with Nvidia's PhysX (thanks to Tozzeb and Chaz for figuring this out):

http://steamcommunity.com/app/315440/discussions/0/613938575218987331/
Last edited by LDSO; Oct 8, 2014 @ 7:31pm
< >
Showing 1-15 of 25 comments
LDSO Oct 7, 2014 @ 10:28am 
Sigh, great. Is it possible for a moderator to restore the download link that's been automatically removed from the post? In the meantime, the link to the updated GfWL client is in the description of the video.
Boonedale Oct 7, 2014 @ 10:58am 
GfWL is shut down, dont install it.
LDSO Oct 7, 2014 @ 11:01am 
Originally posted by boonedale:
GfWL is shut down, dont install it.
GfWL is not shut down. Microsoft originally was going to shut it down, but changed their mind and are still supporting it. (For now.)

If I'm correct, there is no way to get Evolution working on 8/8.1/10 without installing the updated GfWL client. Unless Disney patches the game to use Steamworks.
DigitalPanther Oct 7, 2014 @ 11:12am 
Originally posted by redrain85:
Originally posted by boonedale:
GfWL is shut down, dont install it.
GfWL is not shut down. Microsoft originally was going to shut it down, but changed their mind and are still supporting it. (For now.)

If I'm correct, there is no way to get Evolution working on 8/8.1/10 without installing the updated GfWL client. Unless Disney patches the game to use Steamworks.
I tried the update as well as the original install and GfWL keeps telling me communication issues. SO it is looking like they may have shut down GfWL after all. Going to the MS site for it and its all pointing to XBL now there is no where to DL the GfWL client. SO I may have just wasted 20 bucks.
Last edited by DigitalPanther; Oct 7, 2014 @ 11:15am
LDSO Oct 7, 2014 @ 11:18am 
Originally posted by DigitalPanther:
I tried the update as well as the original install and GfWL keeps telling me communication issues. SO it is looking like they may have shut down GfWL after all. Going to the MS site for it its all pointing to XBL now there is no where to DL the GfWL client. SO I may have just wasted 20 bucks.
The video I posted above was made two days ago. I was able to sign in to GfWL then.

But I just tried now, and it looks like it's currently down. (The Windows Update servers are also down today.)

Just wait a while and try again.


EDIT: I tried again and the GfWL servers responded. I was able to sign in.

Just to be sure, temporarily disable any software firewall you have. Also, go to the Start menu on XP/Vista/7/10 and type services.msc in the search box, then hit Enter. On Windows 8/8.1, just start typing on the Start screen.

Make sure the "Microsoft Account Sign-in Assistant" service is running. If it's not running, then start the service. GfWL won't work without the service running.
Last edited by LDSO; Oct 7, 2014 @ 11:30am
Boonedale Oct 7, 2014 @ 11:26am 
I wont get a game that has GfWL since MS prity much fracked everyone because of it.
LDSO Oct 7, 2014 @ 11:32am 
Originally posted by boonedale:
I wont get a game that has GfWL since MS prity much fracked everyone because of it.
That's fine, and I even agree with you somewhat. I don't like Microsoft's invasive policies, either. But don't say GfWL is shut down, when it isn't.
DigitalPanther Oct 7, 2014 @ 11:43am 
Originally posted by redrain85:
Originally posted by boonedale:
I wont get a game that has GfWL since MS prity much fracked everyone because of it.
That's fine, and I even agree with you somewhat. I don't like Microsoft's invasive policies, either. But don't say GfWL is shut down, when it isn't.

I don't know if it is shut down or not but BOTH versions of the client, the original that comes with the game and the one you linked to error out saying they are unable to communicate with the GfWL servers. Sounds pretty compelling to me.
I want to play this game again only on my PC this time (already have it on the PS3) it is looking more and more like I wasted my purchase.

LDSO Oct 7, 2014 @ 11:50am 
Originally posted by DigitalPanther:
I don't know if it is shut down or not but BOTH versions of the client, the original that comes with the game and the one you linked to error out saying they are unable to communicate with the GfWL servers. Sounds pretty compelling to me.
I want to play this game again only on my PC this time (already have it on the PS3) it is looking more and more like I wasted my purchase.
I updated my first post with some additional tips. If your firewall is blocking GfWL, or the Sign-in Assistant service is not running, then that will happen.

I just signed in to GfWL a few minutes ago.

EDIT: And just to prove that GfWL does work and is NOT shut down, I took a screenshot of being signed in on TRON Evolution. Check out the time and date. 10/7/2014 (October 7th, 2014).

http://abload.de/img/evo_signed_inj7ds3.jpg
Last edited by LDSO; Oct 7, 2014 @ 12:22pm
DigitalPanther Oct 7, 2014 @ 1:38pm 
Originally posted by redrain85:
Originally posted by DigitalPanther:
I don't know if it is shut down or not but BOTH versions of the client, the original that comes with the game and the one you linked to error out saying they are unable to communicate with the GfWL servers. Sounds pretty compelling to me.
I want to play this game again only on my PC this time (already have it on the PS3) it is looking more and more like I wasted my purchase.
I updated my first post with some additional tips. If your firewall is blocking GfWL, or the Sign-in Assistant service is not running, then that will happen.

I just signed in to GfWL a few minutes ago.

EDIT: And just to prove that GfWL does work and is NOT shut down, I took a screenshot of being signed in on TRON Evolution. Check out the time and date. 10/7/2014 (October 7th, 2014).

http://abload.de/img/evo_signed_inj7ds3.jpg

I am fully willing to believe it is working for you.
But it is refusing to work for me. and it is the only thing that isn't.
I work in tech support for a living so I have done all the usual fixes as well as the ones you suggested above(thank you for those btw) unfortunately none of them have worked.

I will just have to try and see if Valve will do anything...not counting on it given their pretty strict no refunds policy.

LDSO Oct 7, 2014 @ 2:31pm 
Originally posted by DigitalPanther:
I am fully willing to believe it is working for you.
But it is refusing to work for me. and it is the only thing that isn't.
The only other thing I can think of is: visiting the Xbox.com site, signing in with your Microsoft/GfWL/Xbox Live account, and agreeing to the updated Terms of Service. Not agreeing on the site could also prevent you from logging in.

But, you shouldn't have to do that. When I installed the latest GfWL it notified me of the updated ToS and I was able to agree to it in-game, which let me sign in.
Julian Oct 8, 2014 @ 5:47am 
I got Tron to work. I went into the steam folder, then into steamaps folder, then common folder, then into tron evolution folder, then the binarys folder, and then win32live folder. I right clicked the GridGameLauncher and selected to put a shortcut on my windows screen, once you have shortcut Icon on screen right click on it and run troubleshoot compatibility option, when the program loads select the option troubleshoot program select the 1st option box and the 3rd option box click next select windows 7 and click next you shuold see test program settings click test program and hopefully tron should work on windows 8.1 then you can save settings to load tron. I hope this helps.
LDSO Oct 8, 2014 @ 9:44am 
Is anyone trying to run Games for Windows Live before starting the game? The latest GfWL doesn't work outside of games any more. You get an error message like this: http://abload.de/img/evo_gfwl_errorznreg.png

GfWL only works in-game now.
LDSO Oct 8, 2014 @ 11:24am 
Originally posted by Julian:
I got Tron to work. I went into the steam folder, then into steamaps folder, then common folder, then into tron evolution folder, then the binarys folder, and then win32live folder. I right clicked the GridGameLauncher and selected to put a shortcut on my windows screen
Wow, it can't be as simple as just creating a shortcut to launch the game from the Desktop/Start menu/Start screen, and bypassing Steam. That would make Disney (or whoever they hired to put it on Steam) utterly incompetent. LOL.

But if the version of GfWL that comes with the game is out of date, then downloading and installing the update from the desktop is still a good idea. Otherwise, GfWL will probably download the update in-game, and that usually doesn't work too well.
Last edited by LDSO; Oct 8, 2014 @ 11:30am
Tozzeb Oct 8, 2014 @ 12:23pm 
Important Notice: This solution might cause problems in other games!

Update #3: I can gladly report that downloading an older version of PhysX solved my problem! I uninstalled PhysX and installed PhysX version 9.12.1031, and that solved my problem!

Update #3 (continue): To see if you have the same problems as me, go to Documents - Disney Interactive Studios - Tron Evolution - UE3 - GridGame - Logs, and then click on the latest Launch-backup log (it should look something like this: Launch-backup-2014.10.09-00.19.57, but the numbers depends on when you tried to launch the game). If you can see the error "Critical: appError called: Assertion failed: GNovodexSDK [File:C:\Tron_Installation\Grid\MilestonesPC\MilestoneBeta\UnrealEngine3\Development\Src\Engine\Src\UnPhysLevel.cpp] [Line: 1534]" in the log, you have to install an older version of PhysX (End of update #3)


I'm probably repeating somebody now, but this is my experience and stuff:
The game works fine if you use the retail disc, but the steam version seems to have some problems. I can log into GFWL just fine in the ingame client on games (such as fable 3(steam version) and gears of war (retail disc) ), but the desktop app is what is broken for most people atm.

The error which pops up for me says "The client must point to the same Windows Live ID environment as the Windows Live ID SIgn-in Assistant service."(even though the sign-in assistant is running) It worked just fine until a few weeks ago or something, but that's only when I try to start the desktop app, and not the game.

However, when I try to start the game, I can see two programs in processes tab. I don't have the game installed atm, and I can't remember what they said, but I think they said "GridGame" and "GridGameLauncer (which seems to be related to SeCuROM according to the description.) And they both disappear after a few seconds, they do not show up on the screen at all, not even in the "programs" tab on the task manager, just the "processes" tab.

I checked the launch log, and it said something about unphys error or something like that.
I'm redownloading the game from steam atm, and I'll update when I can see the error in the launch log.

But I'll try Julian's workaround as well. (Thank you guys for the workarounds! I'll give them a try!)

Update #1: I tried to reinstall Windows Live Essentials and GFWL to try to solve the app login problem, but it did not help. I'm still downloading Tron, so we just have to wait and see.

Update #2: Reinstalling the game did not help. I checked the launch log, and this is the error I get:

Critical: appError called: Assertion failed: GNovodexSDK [File:C:\Tron_Installation\Grid\MilestonesPC\MilestoneBeta\UnrealEngine3\Development\Src\Engine\Src\UnPhysLevel.cpp] [Line: 1534]

Stack: Address = 0x0 (filename not found)

Sounds like a physx error, but don't quote me on that.

I'll try to install an older version of Physx. It solved the problem when I had the problems with starting Turok (2008) so it might solve this problem as well. I'll update when I'm done.
It will might cause some problems, but I'm going to reinstall windows on my computer soon anyway, but yeah, I'll give you an update soon!
Last edited by Tozzeb; Oct 8, 2014 @ 3:28pm
< >
Showing 1-15 of 25 comments
Per page: 15 30 50