Sam & Max 305: The City that Dares not Sleep
Cradive Jun 8, 2013 @ 12:13pm
Vacuum Robot Stuck!
did anyone get stuck at this part
Last edited by Cradive; Jun 28, 2013 @ 8:51am
Showing 1-6 of 6 comments
< >
CelestialSushi Jun 28, 2013 @ 7:56am 
My brother had that happen. It was weird o_.
Cradive Jun 28, 2013 @ 8:52am 
took me hours to figure out a way around it, they should really fix it
[AD-V] Kit the Kat Jul 7, 2013 @ 7:45pm 
What did you do? It keeps "freezing" at this part?
CelestialSushi Jul 7, 2013 @ 8:51pm 
Basically, you're driving the vacuum robot around one location and it just kind of gets stuck in one spot. The game doesn't freeze, it's just that, somehow, like a real vacuum robot is sometimes prone to doing, it gets stuck in one spot and can't move out of it :/ It's an odd bug.
[AD-V] Kit the Kat Jul 7, 2013 @ 10:09pm 
Thanks ! I tried it a bunch of times and it eventually worked!!! I am glad I am not a robot vacuum!
jb Jul 16 @ 4:44am 
No, it is frozen, you can't access any of the menus to load, save or quit.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50