Armello

Armello

View Stats:
Armello > Bugs > Topic Details
Game laggy and jerky after 1.6
So my game updated with 1.6 today and now the performance is so slow that it is quite unplayable. Granted, I have an old computer (2011 Macbook Pro running Yosemite) but my game ran fine yesterday before the update as long as I played on very low graphics. Is anyone else having difficulties after 1.6? Is there anything I can do? Could this get fixed eventually when they go through bugs?
< >
Showing 1-14 of 14 comments
Tokfan Feb 1 @ 6:14pm 
Dunno which version you have, some 2011 macbooks have integrated graphics and some have an radeon card in them. If you have the latter make sure the computer hasn't defaulted back from your gfx card to cpu powered graphics.
That's usually the villian when it comes to windows laptops.
Dust? harddrive temp? cpu temp? gpu temp? Those things can toss a wrench in the system since newer laptops have this "feature" to throttle down performance when heat starts to build up.
Here's the info from my "About this mac." Its an "early 2011."

Processor: 2.3 GHz Intel Core i5
Memory: 4 GB 1333 MHz DDR3
Graphics: Intel HD Graphics 3000 384 MB

How would I be able to look at your suggestion for the graphics cards? And it might be dust too. I'll give it a good cleaning later.
Tokfan Feb 2 @ 5:02am 
Whelp, since there are 5 variants of the macbook pro from 2011 and 2 of them didn't have a dedicated gfx card I'd figured odds were that you had one. Nope you won't be able to switch back to your dedicated gfx card since you do not have one.

Leaving some auto update & dust.
checking system installation logs and installing a monitoring program should track down where the issue is.
Kenwa Feb 2 @ 9:33am 
A friend of mine is now also experiencing severe lag / choppiness (graphical) on his mac after updating to 1.6. He was able to run the game fine on low settings before. I'm not sure exactly which model macbook he has, but I'm certain it does not have a discrete gpu. I'm fairly certain his integrated gpu is Intel HD Graphics 3000.

Sounds like this is probably an issue introduced by 1.6 and not dust.
Mornstar Feb 2 @ 12:23pm 
I have problems too. Running on Sierra latest update and my Mac is a 2009. It did just fine before 1.6. Gotta brace ourselves for bugs after game updates...
Exactly the same problem here.. before the 1.6 everything was fine and now it's unplayable

Config: Mac OSX 10.12.3, Mid 2010, 2.53 GHz Intel Core i5, 4 Go 1067 MHz DDR3, NVIDIA GeForce GT 330M 256 Mo - Intel HD Graphics 288 Mo
GX4000 Feb 2 @ 2:52pm 
Since the 1.6, the game doesn't start anymore on my wife's MacBook,and on my PC, it's extremly lagy and freezy.
Tokfan Feb 2 @ 3:33pm 
So, is there someone with a more beefy mac with the same issues or are these issues only affecting macs in the very-low end range?

Originally posted by GX4000:
...and on my PC, it's extremly lagy and freezy.
specs and os of your PC?

Kenwa Feb 5 @ 3:26pm 
I just tested the game on my Macbook Pro (15 inch, late 2013, Yosemite) with a 2GHz i7 cpu, 16GB of memory, and iris pro graphics. Game seems to run fine on medium/high settings.

Maybe this is more of an issue with lower end computers?

https://steamcommunity.com/app/290340/discussions/1/135508031955377422/
I have a Macbook Pro (13 zoll, 2012, Sierra), with 2,3 GHz Intel Core i5 with 4GB memory. Armello worked just fine before the update. Now it is so laggy that it is not playable anymore.
[LoG] yosafbridge  [developer] Feb 7 @ 4:06pm 
Hey all!

For v1.6 we updated the version of Unity that we develop on. Everytime we update Unity (especially for machines below our Minimum specs) there maybe conflicts with out of date drivers etc.

As a reminder here are our Minimum specs:
OS: OSX 10.9 (64-Bit)
Processor: Dual-core 2.2GHz
Memory: 2 GB RAM
Graphics: OpenGL SM3.0 capable GPU with 1024MB VRAM
Storage: 4 GB available space

OS: Windows 7 (64-Bit)
Processor: Dual-core 2.0 GHz
Memory: 2 GB RAM
Graphics: DirectX 10 class GPU with 512MB VRAM
DirectX: Version 9.0c
Storage: 4 GB available space

If you're above those minimu specs but below the recommended, still make sure all of your drivers and OS are up to date.

Also make sure you've tried playing Armello on Very Low or Low.

If you are above our Recommended Specs and experiecing lag, please send us a bug report using the in-game bug report tool (Pause, Bug Report).

<3

Lisy
Kenwa Feb 8 @ 2:19pm 
I'll ask my friend to make sure everything's up-to-date and to submit an in-game bug report. Although, I suspect his computer is below the minimum specs. I also doubt there's anything mac users can do since most drivers are bundled into major OS updates, which are infrequent.

If the culprit is the new version of unity, would it be possible to move back to the old version, or are there new features in 1.6 which depend on the new version?

What about releasing a legacy, pre-1.6 build for users?

Personally, it seems like a bad idea to update the core game engine post-release.
[LoG] yosafbridge  [developer] Feb 8 @ 4:38pm 
We also recommend, as well as trying "Low or Very Low" trying to reduce your Screen Resolution as well.

Kenwa - the conflicts that Unity might have are going to be with systems that are below the minimum specs as their version increases.

We have been continuing to update the version of our Engine we use ever since launch and the reason for this is because we're a post-release game that's always evolving and changing and we need to stay on the latest version to keep up to date with the rest of the technology ecosystems e.g. graphics cards.

Let me know if you have any success with changing your Screen Resolution.
I decided to try the resolution change described above. Loaded Armello again, and it installed a new update. Game works fine now. I even put the resolution back to what it was before I played, and the game still works. in fact, its better than before 1.6. Even before 1.6 I had to play on very low graphics to make the game run smoothly, but now I can increase it to Medium with only a little jerkiness. Game still runs best on very low, but before 1.6 anything higher was slow.

However, a new bug with swapping card art appeared. Sometimes a card will have different art work than it should, and other times it would be the artwork for the Helm of Heroes. Lastly, sometimes the card would shimmer with a TV static appearance.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Armello > Bugs > Topic Details
Date Posted: Feb 1 @ 4:38pm
Posts: 14