Sid Meier's Civilization VI

Sid Meier's Civilization VI

View Stats:
 This topic has been pinned, so it's probably important
Aspyr-Blair  [developer] Jan 9, 2017 @ 11:01am
The official Linux thread
Alright party penguins. We are proud to announce the launch of Civ VI Linux today (Feb 9th)!

I'll keep this thread updated with the most current info possible, so check in frequently for updates and of course to share your experience.

A huge heartfelt thanks to all the patient Linux gamers that supported our efforts. Especially those that sent cookies to our office with notes of Civ VI encouragement ;)

System requirements below:

Operating System: Ubuntu 16.04 / SteamOS
CPU Processor: Intel Core i3 530 or AMD A8-3870
CPU Speed: 2.93 GHz
Memory: 6 GB
Hard Disk Space: 15 GB
Video Card (NVIDIA): GeForce 650
Video Card (ATI): Not Supported
Video Card (Intel): Not Supported
Video Memory (VRam): 1 GB

If you dont meet the above system requirements, that does NOT mean you wont be able to run Civilization VI. If we know anything about the Linux community, its that you all find a way to make something work on your specific distro and comparable hardware sets. Chime in here with issues, and we will either help you get a ticket into our support system, or if unsupported there are many penguins that can help.

Note: Currently Linux multiplayer is compatible with Mac, and we are working towards making full cross platform multiplayer a reality.

UPDATE 3/14/17 - We are live with Australian Summer! Linux and Mac are still in sync. Full details from the Windows announcement: http://steamcommunity.com/games/289070/announcements/detail/576861888092920827

UPDATE 4/20/17 - We are finally live with the Spring update!

Important note about cross platform multiplayer: While it was our sincere goal to have cross-platform play between Windows and Mac/Linux in this update, we were unable to meet that goal due to some immersion-breaking bugs that occur specifically with cross-platform play. Quality is simply too important to Aspyr and our partners so we elected to release this update while we continue to work on these remaining issues. Linux and Mac can still play with each other.
Last edited by Aspyr-Blair; Apr 20, 2017 @ 8:41am
< >
Showing 331-345 of 1,282 comments
AWildBeard Feb 11, 2017 @ 1:53pm 
Originally posted by Fedaykin:
Originally posted by AWildBeard:
Wondering if anyone has this working on Arch yet. Tried launching it and the steam launch dialog just flashed before dissapearing, no game launch.

RTFM =P

J/K, I am on Debian =p Scroll down to the section for Civ 6.

https://wiki.archlinux.org/index.php/Steam/Game-specific_troubleshooting

Thanks, finally got it to play! 10/10 no problems with the game now!
AWildBeard Feb 11, 2017 @ 1:57pm 
Just noticed a folder called ~/FiraxisLive/ that generated on first launch of my game. Has anyone else noticed this and.. Can I remove it? lol
King Buzzo Feb 11, 2017 @ 2:03pm 
Originally posted by AWildBeard:
Just noticed a folder called ~/FiraxisLive/ that generated on first launch of my game. Has anyone else noticed this and.. Can I remove it? lol

That's an excellent question, I keep forgetting to ask about that.

AspyrBlair hopefully will answer that. Really bad form on a Linux system.
Last edited by King Buzzo; Feb 11, 2017 @ 2:03pm
t-rax Feb 11, 2017 @ 3:25pm 
Originally posted by Hoganbeardy:
The graphics card I have is not showing up on the graphics menu options, it seems to be working off of the intel integrated graphics. It's causing some really weird graphical problems.
System Specs:
Linux Mint 17.3 Cinnamon
Intel i7-4510U dual core 2.0 ghz
8 gigs ram
Nvidia geforce 840m
440 Nvidia Graphics Drivers
Do You think problems caused only GPU selections?
I have the same 17.3 Cinnamon, so interesting to know how it works on this OS' version.
Btw, isn't Ur graphic drivers a little bit old? Means many fresh games needs 367.
DJViking Feb 11, 2017 @ 3:47pm 
What do you think of the gameplay compared to Civilization V? There are a few points I am not so keen about. These are the actual gameplay and nothing to do with Aspyrs work of porting.

Builders vs Workers: Builders only have 3 "build", then they are "destroyed". Thus one needs to create more builders, which takes time away from building anything else in the city.
Though improvements are built instantly.

Districts: These are built around the city on any tiles, and they displace any improvements done, like farms and mines. One can't have to much districts for one city because how would it then get any food, gold or production.

The music: Some of the music is really bugging me, while some are OK.

Barbarian scouts: Feels like I am chasing a rabit. Only way to kill these are to have fast units, box them in or out flank them.

After I destroy an enemy horseman at the coast, the horse runs away... on the water... My legion hops on the mountain after acrobating around the killed unit.

I like the classical era with Rome, Greece, Persia and the likes. Building the civilization and waging war with nations and barbarians. Hope there will be a mod soon so that I can extend the classical era throughout the marathon length gameplay. When playing in this era I am not interesting in Science like the Steam engine eventually popping up....

Some nice new things:
Though you have explored the map, the area is only visible if there are units or cities nearby.
I like now that I can create the Legion unit without the need for Iron resource.
Though it makes sense that we can only create the Pyramids wonder around a desert city. Like a lighthouse must be at a coast city.


One last remark. I am playing this game with a 2560x1440 resolution on Ultra setting. Some of the text in the game is so small I need to stick my nose onto the monitor to read... like the the year in top right corner. Perhaps I need better glasses.
Last edited by DJViking; Feb 11, 2017 @ 3:50pm
Tower_9 Feb 11, 2017 @ 4:27pm 
Well finally there is version for penguin. Bet VGA req is disturbing me... anyone have tried running on Intel video chip which comes with CPU? I have quite old one:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Dell 3rd Gen Core processor Graphics Controller Flags: bus master, fast devsel, latency 0, IRQ 29 Memory at f6400000 (64-bit, non-prefetchable) [size=4M] Memory at e0000000 (64-bit, prefetchable) [size=256M] I/O ports at f000 [size=64] Expansion ROM at <unassigned> [disabled] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [d0] Power Management version 2 Capabilities: [a4] PCI Advanced Features Kernel driver in use: i915 Kernel modules: i915
I guess not even worth a try huh? Seems I should consider acquiring new laptop first...
leo Feb 11, 2017 @ 4:42pm 
Worked perfectly under Linux Mint 17.3!

Has anyone managed to get Gedemon's Ynaemp working under Linux?
I tried putting his mods in .local/share/aspyr-media/Sid Meier's Civilization VI/Mods
but I got a CTD a little while after the leaders pic came up.

AI+ v9 seemed to work Ok on its own, however, which is terrific news!

t-rax Feb 11, 2017 @ 5:09pm 
Originally posted by leo:
Worked perfectly under Linux Mint 17.3!
Great thanks, M8, very nice to hear it.)))
hagabaka Feb 11, 2017 @ 6:11pm 
Originally posted by Pope'sDU:
Success here too.
Gentoo on a Xeon E5472 + 8GB + GTX 750 Ti.
I get these odd black screens once in a while, I suspect it's the diplomacy scenes (ie when you meet a new civ, etc) I can hit escape and skip whatever's there.
I also have this problem. Sometimes during my turn and sometimes during AI turn, when a leader talks to me or I click on a leader icon, the screen becomes black, but the leader's background music plays. I can press Esc to get out of it. Checked file integrity and that didn't fix it.
maxxedout Feb 11, 2017 @ 6:23pm 
I am dittoing other peoples' report of occasional black screens-- seems to be the diplomacy/trade screen since it only started happening when I met another civ. Escape clears it. 64-bit Linux Mint 18 with proprietary nvidia graphics.
krazedkannibal Feb 11, 2017 @ 6:42pm 
I am running Intel Iris 640 graphics so I know it is unsupported. But I am able to get the game to open and with fast clicking I can get to the benchmarks and the game runs fine during the benchmark tests. Everything renders and moves along well.

The problem is once Civ VI gets to the main menu after about 10 seconds it crashes to desktop. No error warning. If I click fast enough in those 10 seconds I can get it to do things, but otherwise it crashes. I can't seem to figure out what's causing the problem. Anyone have a clue?
Pope'sDU Feb 11, 2017 @ 8:07pm 
Originally posted by Tronil:
Originally posted by Pope'sDU:
I get these odd black screens once in a while, I suspect it's the diplomacy scenes (ie when you meet a new civ, etc) I can hit escape and skip whatever's there.
I had the same issue - going into the graphics settings and setting "Animated Leaders" to something other than "Disabled" fixed it.

That fixed it for me! I get the diplomacy cutscenes now.
King Buzzo Feb 11, 2017 @ 8:34pm 
Originally posted by librin.so.1:
had to
cd /usr/lib64 ln -s -T libcurl.so.4 libcurl-gnutls.so.4
to get it running on funtoo

it quietly segfaults on loading a scenario for me, though.
Will try to toss under a debugger to see why when I get back from work.

I made a note to myself to respond to this.

On my system, Civ6 runs fine. See below

[20:28 ...eier's Civilization VI]$ ldd Civ6 | grep found libssl.so.1.0.0 => not found libcrypto.so.1.0.0 => not found libcurl-gnutls.so.4 => not found

The reason for the other two is I run libressl not openssl (hardened system) but it doesn't fail on that either. You should be okay.
proj3ct13 Feb 11, 2017 @ 11:08pm 
thanks im loving it on my alienware steam machine run really smooth have everything except anti al max out
Last edited by proj3ct13; Feb 11, 2017 @ 11:09pm
LinuXiarz Feb 12, 2017 @ 12:35am 
Working Perfectly on High settings on i5 3470 Nvidia 560Ti 16GB RAM [Debian Jessie 64bit]. And I want too know what about FIRAXISLIFE folder? Can we remove it?
< >
Showing 331-345 of 1,282 comments
Per page: 15 30 50