X Rebirth > General Discussions > Topic Details
dach Nov 15, 2013 @ 1:58pm
Wong default graphic card (for nvidia owners)
The game uses my integrated intel graphic card and not my nvidia card.

To force the nvidia card :
- nvidia configuration pannel
- 3D parameters
- software param
- add xrebirth.exe
- force nvidia processor

The fps is FAR FAR better now.
Showing 1-15 of 68 comments
< >
Fived Nov 15, 2013 @ 2:11pm 
This made the game actually playable. Thanks a bunch!
Omnisandro Nov 15, 2013 @ 2:12pm 
I wonder if AMD users are experiencing the same bug.
dach Nov 16, 2013 @ 12:06am 
Originally posted by Omnisandro:
I wonder if AMD users are experiencing the same bug.
It's easy to see wich graphic card is used : the information is displayed in the game's graphics settings.
Sadachara Nov 16, 2013 @ 12:14am 
This is a bug.

Go into Nvidia control panel and select the correct video card to run..

X-Rebirth forces the onboard one. This is causing a lot of trouble for folks but the fix is easy.
Henkie Nov 16, 2013 @ 12:16am 
This is a Steam bug which is around for a year now.
JoxerHD Nov 16, 2013 @ 12:25am 
I'm looking all over for this, but I have no "3D Parameters", I do have a 3D-Settings, when I add X-Rebirth there however i cannot find the video card to use setting, is this the "CUDA-GPU's" setting?
I got a 760GTX, so little confused trying to locate these things in my control panel since i think the OP has a complete different card or OS.
dach Nov 16, 2013 @ 12:34am 
Originally posted by JoxerNL:
I'm looking all over for this, but I have no "3D Parameters", I do have a 3D-Settings, when I add X-Rebirth there however i cannot find the video card to use setting, is this the "CUDA-GPU's" setting?
I got a 760GTX, so little confused trying to locate these things in my control panel since i think the OP has a complete different card or OS.
Yes, and a different langage... it doesn't help.

it's in french but maybe it can help :
http://imgur.com/KYHG3Zf
falcon_x Nov 16, 2013 @ 12:35am 
Why do you have both cards enabled at the same time? That can cause major problems with a lot of games. Disable the onboard in the BIOS. Onboard is junk. Has to go through the system bus to stream vertices and the like to the card. Junk. Definitely won't work with this game.
Last edited by falcon_x; Nov 16, 2013 @ 12:36am
Blackdragon Nov 16, 2013 @ 12:37am 
Originally posted by dach:
The game uses my integrated intel graphic card and not my nvidia card.

To force the nvidia card :
- nvidia configuration pannel
- 3D parameters
- software param
- add xrebirth.exe
- force nvidia processor

The fps is FAR FAR better now.

How is that even possible? Your video card is direcly connected to your monitor. Unless your second card is ALSO connected to your monitor (which I find hard to believe as that would be utterly pointless, esp. with an integrated chipset), the game can't "choose" to use the other card. Even if it did, you'd never get any picture from it on your monitor, as far as I understand things.

Maybe your fps increase was due to some other factor?
Last edited by Blackdragon; Nov 16, 2013 @ 12:38am
falcon_x Nov 16, 2013 @ 12:40am 
No its possible today. In the old days both cards would try to take interrupt 10h and the system would fail to boot. Nowadays cards and BIOS's are smarter and can be side by side (most anyways).

What will happen is that the driver will detect two devices and will give them ordinals. The game will go through code that enumerates the devices and will pick one. Since it has no idea which card is better it will likely pick ordinal 0 which would likely be the onboard card. This is why I always disable onboard cards so there is only 1 device. Now 1 device might have 2 heads (dual head) which means you can do true dual screen (not the fake dual extended Windows desktop ) but it is still one device in the list.

I cannot see how this is a Steam issue since the device selection and enumeration is performed by the game setup code.
Last edited by falcon_x; Nov 16, 2013 @ 12:43am
LTJustesen Nov 16, 2013 @ 12:42am 
Originally posted by JoxerNL:
I'm looking all over for this, but I have no "3D Parameters", I do have a 3D-Settings, when I add X-Rebirth there however i cannot find the video card to use setting, is this the "CUDA-GPU's" setting?
I got a 760GTX, so little confused trying to locate these things in my control panel since i think the OP has a complete different card or OS.

I think it is the CUDA gpu. I chose the other option instead of the global settings and it seemed to work.
Last edited by LTJustesen; Nov 16, 2013 @ 12:43am
MadMax665 Nov 16, 2013 @ 12:43am 
But how in heaven would this game boot up with an onboard graphics card? I'm pretty sure it would crash right to the desktop and not give us about 30 frames if it was indeed using the onboard card to run.
falcon_x Nov 16, 2013 @ 12:44am 
Your post brings up another possibility. For those that have NVidia cards we all love and hate PhysX. I wonder if that could bring the system down. Someone should try to disable it and see if it performs better or worse. Does Rebirth even use PhysX?
Mombasa Raha Nov 16, 2013 @ 12:44am 
so anyone have success witht he BIOS disabling of the intergrated card? i'm still struggling with this problem despite messing with the 3D parameters over and over again.
falcon_x Nov 16, 2013 @ 12:45am 
But how in heaven would this game boot up with an onboard graphics card? I'm pretty sure it would crash right to the desktop and not give us about 30 frames if it was indeed using the onboard card to run.
Quite likely but if there is enough VRAM and it supports the correct shader model the card will work. It will run like utter garbage but it will work. The onboard card would get extremely hot as well as its onboard chipset...prob not a good thing to do.
Last edited by falcon_x; Nov 16, 2013 @ 12:45am
Showing 1-15 of 68 comments
< >
Per page: 15 30 50
Date Posted: Nov 15, 2013 @ 1:58pm
Posts: 68