Dog Sled Saga

Dog Sled Saga

View Stats:
Dog Sled Saga > Technical Support > Topic Details
Dorkus1218 Dec 12, 2014 @ 12:54pm
Report crash on start errors here
Hey all,

I've been trying to get the bottom of the crash issues some of you have been having in this thread - again, so sorry if that's keeping you from the game.

I have some new instructions with the build I uploaded last night, so I wanted to start a new clean thread with the instructions at the top.

Updates

Jan 4 2014

If you're on Windows and you've previously forced an integrated Intel graphics device, restore it to the default settings! Our game library had an update that hints the correct graphics device.

Dec 21 2014

Fixed an issue with creation of the err.txt file, and relocated the save directory according to platform:
  • Windows - %home folder% / Saved Games / Dog Sled Saga
  • Mac - %home folder% / Saved Games / Dog Sled Saga
  • Linux - %home folder% / .dogsledsaga
(home folder by platform[en.wikipedia.org])

Dec 12 2014

I added a code snippet to the game's executable that supposedly tells the game to use your dedicated card, but it sounds like it's not working for everyone. If the first build crashed but this build works, let me know!

I also made the game write its internal error text to a file, which I'll ask you to post if you experience a crash.

If you experience a crash on load, please post the following:
  • Your operating system
  • Your graphics hardware (ideally BOTH cards, e.g. Intel and Nvidia, if applicable)
  • Any workarounds you have in place, such as forcing integrated graphics via Nvidia control panel
  • The contents of the file %save folder%/err.txt (see above for help finding the save folder)
  • Any other info you think might help

Potential workarounds

Make sure you exit and restart Steam to make sure you have the newest update of Dog Sled Saga

Windows:
  • see Melanc's first post here You shouldn't need to force a graphics device anymore - please undo any steps you took previously according to that workaround.

Mac:
  • Use gfxCardStatus[gfx.io] to force either integrated or discrete GPU - let me know if you have success with that!
  • Try disabling automatic graphics switching in System Preferences > Energy Saver

I'll keep trying to find permanent solutions to these crashes that don't require workarounds. Thanks for your help in tracking this down!

Dan
Last edited by Dorkus1218; Feb 10, 2015 @ 2:34pm
< >
Showing 1-15 of 46 comments
N0B0DY Dec 12, 2014 @ 6:27pm 
After update, crash on start error occurred on Macbook air 2014. Here is a error log.

http://pastebin.com/MKfjZJSe


* Macbook air has no discrete GPU. It has only Intel hd 5000. So can't try your workarounds.


N0B0DY Dec 13, 2014 @ 6:16am 
Deleting and reinstalling a game fixed problem! And I don't know what exactly was updated, performance turned slightly better!
Last edited by N0B0DY; Dec 13, 2014 @ 6:36am
TigerWolfe Dec 13, 2014 @ 6:07pm 
I played succesfully once. And now nothing happens when I try and run the game. I've tried telling it to run on both integrated and dedicated graphics card. I also tried the modified .exe you linked in another thread. As far as I can tell my game is up to date, but I'm not seeing the crash report dump folder.
Daene Dec 14, 2014 @ 9:33am 
I am not getting the err.txt :-(

Playing on Windows 7 64 bit
With a GTX 550 ti
No workaround (since it is a stationary and not a laptop)
I have an anti-virus program

Edit: Also not working on another PC anymore and again I do not receive an err.txt
GPU: Geforce GTX 760
Last edited by Daene; Dec 15, 2014 @ 4:31am
TigerWolfe Dec 14, 2014 @ 11:46am 
I killed Steam and restarted, and it worked. Not sure how/why that would of helped, as I'd rebooted Steam in between the initial play time and the time it wasn't working. But maybe give that a shot, if you haven't already.
Darrenm Dec 17, 2014 @ 12:40am 
The game won't boot up for me - I've tried disabling graphics card support and running as administrator and in different compatibility modes. I'm also not getting a crash report dump folder.

Windows 7 64 bit
Radeon HD5870, intel integrated


Darrenm Dec 22, 2014 @ 10:08am 
Unfortunately the error log is still not generating for me - I've tried all this fixes in the other thread as well.
sophie_kitten Dec 23, 2014 @ 10:54am 
The game wasn't starting up, it was kind of a frozen screen but if I alt-tabbed I could see the game in the background but when I went back to it, it was frozen. I was going to try the integrated Inel card instead of the Nvidia, so I plugged in the HDMI cable. I decided to delete and reinstall the game too. It worked on Nvidia card, so I unplugged the HDMI cable and it still worked. I think reinstalling helped. Thanks!

FYI my sister has the EXACT same system and video cards and hers worked on the first try.

Nvidia GeForce GTX 750 Ti GM107 revision A2 28 nm Feb 18, 2014 (EVGA 3842)
Intel GT1 22 nm April 23, 2012 (Dell 1028)
Windows 8.1 6.3.9600 build 9600
%userprofile%>java -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)
IronPhoenix13 Jan 3, 2015 @ 3:09pm 
It was working perfectly fine two days ago and now I cannot open it. It crashes. I am on a Windows 7 laptop. If anyone can give me tips to get it working again they would be greatly appreciated!!
Dorkus1218 Jan 3, 2015 @ 10:39pm 
Echoing from the OP - on Windows, if you've used the NVidia control panel to force any graphics devices, please try putting everything back to defaults. Also, triple check that your drivers are updated, and that you've restarted your computer since your last driver update.

Note that restarting Steam ensures that it sees the latest updates for any installed games, too.
CDAGaming Jan 4, 2015 @ 9:11am 
i have restarted my computer which makes sure all downloads are updated and i reinstalled dog sled saga i will try this everyday just to play this i see youtubers play this game one mostly called Stacyplays she plays minecraft,dog sled saga,and the long dark i wand the long dark and im getting it on monday but i have this for now and i am so sad cause it wont work plz help me or fix this.
IronPhoenix13 Jan 4, 2015 @ 3:43pm 
Can someone please tell me how to do this!!! >> If you're on Windows and you've previously forced an integrated Intel graphics device, restore it to the default settings! I do not know how to fix the setting. PLEASE HELP.
Dorkus1218 Jan 4, 2015 @ 4:20pm 
IronPhoenix13 - here is a good tutorial: http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
You might not have to change anything, but it should probably be on an automatic or default setting.

Can you let me know what kind of graphics card/s you have? Also, can you check if you have an err.txt file in C:\Users\[your login]\Saved Games\Dog Sled Saga\ and if so, paste it?
IronPhoenix13 Jan 5, 2015 @ 3:36pm 
@Dorkus1218
I am not good with technology so I do not know how to find out what graphics card I have. Thank you for the tutorial!
IronPhoenix13 Jan 17, 2015 @ 7:16pm 
I just want to play my game :(
< >
Showing 1-15 of 46 comments
Per page: 15 30 50

Dog Sled Saga > Technical Support > Topic Details