peter_de123 Mar 29, 2014 @ 2:25am
Fix XNA.Framework.Media Crash without installing Windows Media Player
If you, like me, don't have Windows Media Player installed and therefore cannot start the game (check your Application-Eventlog for an "System.InvalidOperationException" at "Microsoft.Xna.Framework.Media.MediaQueue.Play........." you can fix this without having to install WMP by registering the wmp.dll.


If you have a 64-Bit System, do the following:

1. Locate wmp.dll in C:\Windows. The files should be in a folder named something like "C:\Windows\winsxs\wow64_microsoft-windows-mediaplayer-core....."
2. Copy wmp.dll and wmploc.dll to C:\Windows\SysWOW64
3. Go to Start>Run and type regsvr32 c:\windows\syswow64\wmp.dll
4. A "Succeeded" message should appear.
5. Start the game.



For 32-Bit Systems, try this:

1. Locate wmp.dll in C:\Windows. The right files should be in a folder named something like "C:\Windows\winsxs\x86_microsoft-windows-mediaplayer-core......"
2. Copy wmp.dll and wmploc.dll to C:\Windows\system32
3. Go to Start>Run and type regsvr32 c:\windows\system32\wmp.dll
4. A "Succeeded" message should appear.
5. Start the game.


If the game still doesn't start, you might have picked the wrong wmp.dll , at least for 64-Bit there are multiple versions. Search your windows folder for wmp.dll again and see if there are other versions than the one I suggested. To uninstall the previously installed dll, go to Start>Run again and type "regsvr32 -u c:\windows\syswow64\wmp.dll" .


UPDATE:
As pointed out by Snihjen, some Users might not have sufficient Rights to register a .dll by default. So if you get an error message like Error 0x800200009, go to Start Menu -> All Programs -> Accessoires and right-click the CommandPrompt Icon, select "Run as Administrator" and type the regsvr32-command in the shell (followed by Enter, of course).
Last edited by peter_de123; Apr 2, 2014 @ 5:18pm
Showing 1-4 of 4 comments
< >
Snihjen Mar 29, 2014 @ 10:18pm 
This worked.

Thank you.

An issue I ran into: Error 0x80020009, this means you don't have the right to registrer DLLs.

the RUN command has to be, well, run, as a Administrator, and I had to go into:

start menu --> all programs --> Accessories, and then rightclick command promt, run as administrator, and the write it manually.

but yeah, other than that, it worked.
Last edited by Snihjen; Mar 29, 2014 @ 10:21pm
BlueNovember May 5, 2014 @ 2:59am 
Awesome man. Thanks very much.
Spectre Jul 4, 2014 @ 9:21am 
I tried everything in the list and got all the responses that it said I would get and I'm still getting the error message ='(, is there anything else I could try?
Sephres411 Feb 9 @ 12:48pm 
I have tried the XNA, WMP DLL and codec fixes but could not get this to work at all. error below:

Application: UnclaimedWorld.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: Microsoft.Xna.Framework.Audio.NoAudioHardwareException
Stack:
at Microsoft.Xna.Framework.Audio.SoundEffect.set_MasterVolume(Single)
at UWGame.Client.Audio.AudioManager.Init(UWGame.ClientSide.Options)
at UWGame.Control.Controller.LoadOptionSettings()
at UWGame.Control.Controller..ctor(GameStateManagement.UnclaimedWorld)
at GameStateManagement.UnclaimedWorld..ctor()
at GameStateManagement.Program.Main()

I realized earlier today after reading about the WMP issues that every time I have tried launching the game recently, has been after a session on my Xbox which shares my PC speakers. Having plugged my speakers back into the PC, the game launches fine. Unclaimed World will not launch unless you have speakers/headphones plugged into your pc.

if anyone else is using their speakers for multiple systems, be it unplugging and replugging or via a splitter etc. bear this in mind!
Showing 1-4 of 4 comments
< >
Per page: 15 30 50