Commie Apr 22 @ 9:40am
Achievements don't unlock
Am I doing something wrong? Is there a particular mode which lets you get achievements and others do not? I can't even seem to get the basic 'first blood' achievement for destroying a unit, never mind all the other intereseting achievements that look like they add kind of 'missions' such as survive for x turns with y country.
Showing 1-15 of 88 comments
< >
Wastelands Interactive  [developer] Apr 22 @ 11:41am 
some of those achievements are possible to be unlocked only in a specific scenario.
Commie Apr 22 @ 12:52pm 
Yeah I understand..such the one where you have to be Greece in 1940 scenario etc. But I'm talking about achievements that should unlock any time like 'First Blood' for destroying a unit, or conquering Poland in the first turn in 1939 scenario. I'm running Win7 on a laptop. I wonder if maybe the fact that my installation folder is not the default has something to do with it?
Kendil Apr 30 @ 1:59pm 
have the same problem, unlocks no achieviement
Commie Apr 30 @ 2:10pm 
I wish I had another computer to try it on...I'm running 64bit win 7. Maybe that's the problem? Who knows with these things. I've tried playing on the hardest difficulty with the AI getting bonuses and me penalties just to make sure it's not something locked to harder difficulties like with Paradox games and still nothing.
Kendil May 4 @ 2:07am 
i use win 8.1 , also 64 bit
Commie May 4 @ 2:20am 
Hmm, so maybe it's a 64 bit thing.
reason and dignyty of a dog  [developer] May 4 @ 4:36am 
It's definitely not a 64 bit thing, as the achievements were tested and worked on such a system. We'll take a closer look.
Commie May 4 @ 7:32am 
Cool, thanks. Would be good if you guys could work something out. Of course, If it doesn't take too much time as I'd rather you keep working on WoM which I've thrown down Kickstarter money on in both campaigns. ;)
Ret  [developer] May 5 @ 12:52am 
Is Steam overlay working in the background? Which language version you playing? Are you using saves from non-steam version? If game detects that saves or scenarios are modified, you should get message about that. In that case you cannot unlock any achievement.
Commie May 5 @ 1:23am 
I use the overlay, running the game with English though I tried Polish as well. I did have it in a non steam version from Gamersgate before and had saves then, but I formatted the HDD since then so there shouldn't be any residue from the non-steam version. I just started a new quickstart game as axis in 1939 just to see if I could get the 'first blood' achievement and it still doesn't work at all. And I had just uninstalled the game and every reference to it.
Strat1968 May 17 @ 5:21am 
Achievements are not unlocking. Conquered Leningrad as the Finnish on 1941 scenario and nothing. Also 'first blood' not unlocking. Then again, got the Axis controls Gibraltar achievement by playing the naval tutorial so my guess is that achievements are really badly implemented.

Edit: in addition, the statistics on steam achievements page are not updating too, all showing 0/xxx even if you destroy/buy units. Steam overlay is working as intended during the game play, that is when the game is not crashing, it crashes a lot, even during the tutorials.
Last edited by Strat1968; May 19 @ 1:32am
nmargie21122 May 25 @ 9:42am 
I too am suffering from no unlocks.

Running windows 7 64 bit
English
Steam overlay is working

Have not owned the game other than steam version
using no modes

ONE QUESTION (sorry thought of this and have no tiem to see if it is the issue)
I know the unlocks do not happen when using moddified gmaes, is the same true when using customer games? In other words

Will achievments only unlock when playing a quick game?
If they also unlock during custom does changing any AI difficulty (higher or lower) lock them?

Thanks


UODATE

Just played quick match as Russia.
Decleared war on Finland and Turkey
Destroyed units from Finland
Defeated Finland

and no achievments

Strange since I did get two while doingthe training

Last edited by nmargie21122; May 25 @ 11:28am
Ret  [developer] May 26 @ 1:17am 
Achievements should be blocked only if you're playing modified scenarios or modified saves (or if you are using saves from non-steam version).

We're trying to fix this issue ASAP, so please stay tuned.
Paindemonium May 31 @ 9:08am 
I dont modyfie d my game I just start the game and no achievements unlocking... same as first blood.
Wastelands Interactive  [developer] May 31 @ 12:12pm 
We are working on the solution of the issue, this should be fixed early next week.
Showing 1-15 of 88 comments
< >
Per page: 15 30 50