<MMPR>Chocrates May 31, 2013 @ 2:46pm
Linux launch failure
Game has been working great for a week or so since i bought it.
Today I tried to launch it and it crashes with the below:

AL lib: pulseaudio.c:651: Stream did not get ready: Invalid argument
AL lib: alsa.c:642: set params failed: Input/output error
/home/chris/.local/share/Steam/SteamApps/common/X3 Terran Conflict/testandlaunch: line 35: 3793 Aborted ./$1
Game removed: AppID 2820 "X3: Terran Conflict", ProcID 3793
ExecSteamURL: "steam://url/GameHubDiscussions/2820"

(steam:2654): Gdk-WARNING **: XID collision, trouble ahead
ALSA lib pcm_pulse.c:750:(pulse_prepare) PulseAudio: Unable to create stream: Invalid argument

I haven't updated anything on my box recently so anything that changed would be with steam or X3.
Showing 1-8 of 8 comments
< >
<MMPR>Chocrates Jun 1, 2013 @ 7:55am 
Aaannndd it resolved itself.
If i can reproduce it or figure out how it broke again i'll respond
Artemis3 Jun 1, 2013 @ 11:04am 
That sounds like your pulseaudio got killed, it might happen... Pulseaudio is a user process, it's supposed to restart if it crashes; if the alsa driver somehow got occupied with something else when pulseaudio crashed (another user? alsa only program?) it might be unable to respawn.

Restart if in doubt.
Last edited by Artemis3; Jun 1, 2013 @ 11:04am
timon37x25 Jun 7, 2013 @ 12:36pm 
hehehe terrible that the "good old windows mantra" of "restart it" also applies to linux;p One mint user reported that he had to remove the supplied libalsa from the game_dir/lib so there might also be some incompatibilities there. Btw Artemis3 e17 is nice, I happily used it for a long long time before forking dwm.
markdb92 Jun 8, 2013 @ 4:14pm 
The problem with linux port is simily there too many versions of linux thus you have hard time making it work right on all flavors. This is why ms is a good thing when coming to gameing period ie one standard to code on.
blurcks Jul 31, 2013 @ 4:45am 
I am pretty upset right now, X3 TC just worked out of the box on my debian system like most other linux steam games, but then there was a recent update, and now it is completely broken it seems, what did they change???

I get a console window with the following: http://nopaste.info/8954c5ca20.html
which also isn't really helpful as there seems to be something missing too.
blurcks Jul 31, 2013 @ 5:02am 
OK, this was on a ntfs drive, maybe not the best idea overall (performance wise anyway...), I checked the data and there were two damaged files which it said would be downloaded. After that I still had the same issues..... Now I removed local content from both Albion Prelude and Terran Conflict and will now just re-download Terran Conflict ... let's see how that works..
blurcks Jul 31, 2013 @ 6:52am 
Still not working ... any help? Why is this happening? I even bought this game a second time! I previously had the windows only non-steam version and now was very happy to see it available for Linux (otherwise I wouldn't play at all), and it even worked! But now? What is this?
blurcks Jul 31, 2013 @ 7:15am 
for anyone interested, modifying the "testandlaunch" with the ./$1 like described in the egosoft forum worked for me: http://forum.egosoft.com/viewtopic.php?t=335500&postdays=0&postorder=asc&start=360 ..... still this is NOT HOW IT IS SUPPOSED to be. Like I said, the previous version worked without flaws! (But maybe this also comes from the recent update of steam itself?)
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: May 31, 2013 @ 2:46pm
Posts: 8