X3: Reunion > General Discussions > Topic Details
a334atn Sep 21, 2013 @ 7:56am
Rock Candy wired controller buttons don't work
Hi, I'm playing the linux version of X3 and spent hours yesterday mapping the controlls to a Rock Candy wired XBox 360 controller. It was working perfectly yesterday but when I went to play it today I found that none of the buttons or triggers work. The Directional Pad and both sticks are working fine and I have made sure that I am on the right controls profile and that the controls are still mapped to the buttons on the controller.
Restarting the computer doesnt help. I have checked that the controller itself is working with jstest and my computer registers that I am pressing the buttons so the problem must be with X3.
I have also tried setting up a new controls profile but when I try to map a control there is no response when I hit the buttons (although I can still map controls to the directional pad).
Hopefully I am just missing something simple as it's odd that it worked yesterday but doesn't today.
The only thing I can think of that I haven't tried is re-installing X3 but I'm not sure how I go about that (new to steam and pretty new to linux). Any help would be appreciated.

Thanks

Jamie
Showing 1-1 of 1 comments
< >
DarthSide Feb 1 @ 2:34pm 
Were you able to find a fix? I have a Microsoft Sidewinder Precision 2, and all axis work fine, even the POV/hat, but none of the buttons do.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50