X3: Reunion > General Discussions > Topic Details
DarkWolf Jan 28 @ 11:52am
Is there anyone that is able to paly X3?
I see a mass outbreak of X3 crash reports with no solutions. Does anynoe out there have a working copy? If so where did you buy it. (i'm asking because i'm investigating this outbreak)
Showing 1-15 of 56 comments
< >
DarkWolf Jan 28 @ 12:17pm 
Please people. I need to know where people have gotten their X3 reunions from if you didn't buy it on steam. It's needed for my investigation on the matter of all the crash reports.
Last edited by DarkWolf; Jan 28 @ 12:17pm
Dahkteromar Jan 28 @ 8:16pm 
I have got a working copy. I bought it on Steam.

OS: Win 7 x64
DarkWolf Jan 29 @ 8:10am 
then you seem to be a lucky one. Do you know why so many copies aren't working?
Dahkteromar Jan 29 @ 8:51am 
I have no idea.

However I found this: "Ok I finally got it to work, however I had to download and install it outside of Steam. I don't know if this is a coincidence, or if Steam was the problem all along, but it is working now and except for the occasional crash I am enjoying it."

Do you have the latest drivers, DirectX, etc. ?
Last edited by Dahkteromar; Jan 29 @ 8:52am
DarkWolf Jan 29 @ 10:41am 
yea i do
Cooper Feb 2 @ 4:48am 
X3R is better to run outside steam. I believe Egosoft has nosteam .exe file on their website you can download and overwrite existing one. But I got it to work without problems on W7 64bit. For me source of all crashes was steam overlay. I solved it by going to offline mode (friends window), entering game, enter and exit overlay (shift+tab), load game, going online. This way I am able to play X3R no problem while being online and chat with friends.

My post about this from two months ago:
Sigh. I found two ways to solve most of the crashes, still crashes from time to time, thou. First, go off-line in friends window and close it, start the game, enter and exit overlay, load/start game. Try to go online if you want to. Worked few times.
But the only way I found to be working best for me so far to stop most of the crashes, is not to start X3:R from Steam or Steam created shortcut. Instead create your own shortcut to X3.exe from Program Files(x86)\Steam\SteamApps\common\X3 - Reunion\X3.exe. Try run it as admin. Steam overlay shouldn't work. After some testing I agree that steam overlay is the crash source in most cases.

EDIT: Running for over one hour atm without a crash by doing the first mentioned method and going on-line after loading saved game. Folowing saves/loads works fine so far. Alt+Tabing works fine.

EDIT2: Crashed after 85 minutes after trying to observe targeted ship (F1). First method works again. Observation works too.

EDIT3: First method works fine, but most of the times I try to look on a target up close (F1 camera view) game will crash.

Suggestion: If you have DVD version, for example from box/retail SuperBox, running that instead of Steam version may save you your nerves.

EDIT4: Both methods work fine for me. So I hope atleast one of them will work for the rest of you guys to enjoy this game.
Last edited by Cooper; Feb 2 @ 4:55am
DarkWolf Feb 2 @ 6:02am 
I had just tried this idea cooper....it doesn't work.
Letalis Sonus Feb 6 @ 12:14pm 
Well, the Linux version still runs absolutely fine - there was some issue with the launcher, but that was caused by some issue with the Steam runtime (i.e. the set of libraries Steam provides to the games on Linux to prevent incompatibilities with the system's own libs) and not some faulty game update.

Are the Windows binaries really bound to Steam? I can just navigate to the game's folder and start it without Steam even running, the Linux Steam version is basically already "non-Steam".
Sugarfresh Feb 6 @ 1:10pm 
i have it and its runs good. I did have the "jobs file bug" my first play through where practically 99% of the npc disappears. Literally ghost sector after ghost sector, only minor military forces. However a fresh install and i've been playing solid for about 3 game days now. I haven't tried to play it unmodded though. I play it with the official Bonus pack, XTM installed, followed my STO and I have no issues. I'd try the usual full uninstal(delete the leftover stuff steam leaves manually), re-install, check dx9, check game's file integrity.
DarkWolf Feb 7 @ 8:22am 
Originally posted by Sugarfresh:
i have it and its runs good. I did have the "jobs file bug" my first play through where practically 99% of the npc disappears. Literally ghost sector after ghost sector, only minor military forces. However a fresh install and i've been playing solid for about 3 game days now. I haven't tried to play it unmodded though. I play it with the official Bonus pack, XTM installed, followed my STO and I have no issues. I'd try the usual full uninstal(delete the leftover stuff steam leaves manually), re-install, check dx9, check game's file integrity.

i've done all that. My problems is that it ran just fine the day i installed it and now it doesn't work at all.
Cooper Feb 8 @ 4:39am 
Originally posted by ShadeWolf:
I had just tried this idea cooper....it doesn't work.
Sorry to read that. I just wrote what is working fine for me. Thou I have no mods instaled, only the official bonus pack DL from Egosoft web.
Did you deleted shorcut created by steam and made your own linking directly to x3.exe, not steamapp####? Tested all possibilities in compability mode via shortcut properties? Maybe you have some settings either in game or system that game / system can't handle? Enough free Ram, counting that all opened windows and programs consume it? Or maybe you have some corrupted entries in registry that may couse problems (uninstall game, use some tool to clean registry, install game)? Some program or system itself after some corrupted update may couse problems?

Stupid question maybe but you didn't let us know your PC config (CPU, Ram, System etc.). Might help some1 to think out solution for you.

Side note, I have boxed version of Superbox activated on steam (in order to get AP), but I downloaded and installed X3R fully from steam.
Last edited by Cooper; Feb 8 @ 4:41am
wilkinau Mar 29 @ 12:39pm 
I just started having problems with it crashing loading my saved game and when it is loading up. Started right after I downloaded the bonus pack on the DLC page for X3 Reunion
I had to run the launcher as admin from the files directly on my hard drive to get it to even start. WIN7 64bit. It was gifted to me on steam from a friend. Once I got it started that way It has ran fine strting up via Steam except that it comes up windowed no matter what settings I use. Except the windowed setting, then it will crash. The game just recently quit using my joystick. It was working. I quit the game, next day joystick won't work. Getting around the menus looking for how to reset it is a nightmare. Everything in the menus look fine. just can't find anything that says joystick on or off.
Siddha Apr 8 @ 10:10am 
Well I bought X3 Reunion and run it as normal in Steam with zero issues.
Zero.
I'm still on XP 32bit so maybe that's why it runs well for me.
Last edited by Siddha; Apr 8 @ 10:10am
DarkWolf Apr 8 @ 11:30am 
i'm just surprised and happy people are actually seeing about this problem because according to the producers "it has to be a problem on your end only because we see no issues with our game" -.-.... seriously i can't get any help from them because they think it's a problem with my graphics and sound cards. i kept tellnig them "if that's the issue then technically the game wouldn't have even installed"
Showing 1-15 of 56 comments
< >
Per page: 15 30 50