SmileyChris 14. jul 2013 kl. 1:14am
[SOLVED] New PC, Windows 8 64bit. Game doesn't launch :-/
Install seemed to go fine (tried manually running the dist files afterwards too)

When attempting to launch the game (or the settings option) all I get is a new dxhr_651_crash_<time>C0.mdmp file created in C:\Program Files (x86)\Steam\SteamApps\common\Deus Ex - Human Revolution

Does anyone have this game working on Windows 8?
Oh, and files verify fine. Running as administrator and changing compatibility do nothing.

SOLUTION (thanks mattG!):
Disable integrated onboard graphics. Either disable it in BIOS or:
1. Open windows explorer, right click on 'My Computer' and click 'Properties'.
2. Click on 'Device Manager' and look under 'Display Adapters'.
3. Disable the option that isn't your main GPU (for me it was Intel HD Graphics 4600).
Sidst redigeret af SmileyChris; 11. sep 2013 kl. 3:22pm
Viser 1-15 af 34 kommentarer
< >
MrsBlizetta 14. jul 2013 kl. 2:52pm 
same for me..got it of steam sale to play on my brand new PC and it keeps crashing on launching :(
icysoft 15. jul 2013 kl. 11:41am 
It worked fine for me on win 8 x64, also works for me on win 8.1
Did you try to update all drivers, gfx card etc?
MrsBlizetta 15. jul 2013 kl. 11:59am 
Oprindeligt skrevet af icysoft:
It worked fine for me on win 8 x64, also works for me on win 8.1
Did you try to update all drivers, gfx card etc?

pretty sure i did...got this new computer infact 3 days ago updated with all the latest drivers

checking some more tho
SmileyChris 15. jul 2013 kl. 3:06pm 
Yep, ditto. New computer with all drivers updated.

Thanks for the reply though, icysoft -- good to know that some people have it working.
MrsBlizetta 16. jul 2013 kl. 12:20am 
still not working for me..checked all drivers and stuff but no go

only thing that helped is using a older .exe that i found on the web it will run but crashes sometimes on dialogue wich is annoying... such a good game i want to play it without crashing :(
Pudgy Astronaut 16. jul 2013 kl. 1:38am 
Mine also works but I bought the game before windows 8 I think. Anyhow I am playing right now running Windows 8 Pro 64 bit. I also don't have any crashes, the game runs fantastically (unlike fallout 3 which I had to do some fixes for), so I wouldn't fear too much, I am sure you'll get it working.
SmileyChris 16. jul 2013 kl. 4:54am 
Perhaps it's an issue with new hardware as opposed to new OS, since tnt and me both have new computers too.

I'm running a GTX 660 and i5 4670K on a Z87 board
Maybe a Haswell issue? Maybe multicore issue?

I'm running Geforce 320.49 driver.
Sidst redigeret af SmileyChris; 16. jul 2013 kl. 5:07am
Malugre 16. jul 2013 kl. 5:01am 
I'm running a GTX 770 with 320.49 driver, a Z87 board, an i5 4670K, Windows 8 and the game won't launch for me. I've tried everything suggested and still no luck. Tried contacting Square Enix and their support forms don't even work. I'll update if I manage to find a fix though.
Sidst redigeret af Malugre; 16. jul 2013 kl. 5:04am
MrsBlizetta 16. jul 2013 kl. 6:58am 
only thing that worked for me was a old .exe i found off internet, but i now have the crash on dialogue so im still screwed so to say :|
MrsBlizetta 16. jul 2013 kl. 7:01am 
Oprindeligt skrevet af Pudgy Astronaut:
Mine also works but I bought the game before windows 8 I think. Anyhow I am playing right now running Windows 8 Pro 64 bit. I also don't have any crashes, the game runs fantastically (unlike fallout 3 which I had to do some fixes for), so I wouldn't fear too much, I am sure you'll get it working.

i just got a new pc 4 days ago with windows 8 64bits and the new haswel cpu, z87 mobo and a nvidia 660

my friend got a new computer as well windows 8 64bits a nvidia 660 but he has a AMD cpu and his game is working..
BluChew 16. jul 2013 kl. 8:42am 
bump, Having the same issue. win8, i7-4770, GTX 660 on a Z87 Mobo.
Malugre 16. jul 2013 kl. 3:31pm 
Ok, I found a fix that works for me: disabling integrated onboard graphics.
Open windows explorer, right click on 'My Computer' and click 'Properties'.
Then click on 'Device Manager' and look under 'Display Adapters'.
Then just disable the option that isn't your main GPU (for me it was Intel HD Graphics 4600).
RingwormFTW 16. jul 2013 kl. 3:37pm 
Disabling the onboard GPU worked for me too :o Thank you very much for that :D Just remember to enable it when you're not playing the game lol
wtfwasthat111 16. jul 2013 kl. 4:28pm 
I'm still getting nothing. Drivers updated, files verified, disable Intel HD Graphics etc etc, the window for 'preparing to launch' comes up and then nothing else happens. Has this only happened to the people who got it for 85% off?
Hekistylz 16. jul 2013 kl. 9:17pm 
Same here cant play the game. Preparing to launch then nothing happens
Viser 1-15 af 34 kommentarer
< >
Per side: 15 30 50