Deus Ex: Human Revolution

Deus Ex: Human Revolution

View Stats:
BillTheInhaler Apr 13, 2013 @ 7:27pm
Game not launching
Whenever I try to launch, I get a window saying "A fatal error has occured while playing Deus Ex". When I click "Show Extended Information", it says "Wrong DRM version data 0, code 15
rebuild of pc-w\object\effects\fx_art\textures\weaponfx\pt_muzzle_sideflames_4x1.drm needed
". What can I do?
< >
Showing 1-4 of 4 comments
Sir Olfs Apr 14, 2013 @ 4:18pm 
Has anyone worked this out yet? I seem to have the exact same issue as the OP, the only difference is I'm installing from a DVD so uninstalling and reinstalling didn't take me long, and I don't have the Missing Link (which he was able to run the game via) I have I've tried everything else mentioned here, to no avail. I'll summarise

Disabled UAC yes
Verified Files yes
Deleted the exe and steamapi and verified again yes
Disabled antivirus yes
Checked latest drivers installed yes
Uninstalled and reinstalled game yes
Restarted computer yes
Looked for clientregistry.blob... doesn't appear to exist on my computer

Whether I try to open it by running the exe file launching through steam, through the shortcut on the desktop, through the DLC pages on steam (which I think is a shortcut to steam anyway) or through the launcher dialog that appears when I insert the DVD, the same thing happens; basically nothing at all, more specifically, doing this with task manager open, the process dxhr.exe *32 appears uses 73MB of RAM and 0% of the CPU, does nothing, then disappears.

Disabling UAC did get it to download DirectX before then proceeding to once again do nothing, then disappear.
Sir Olfs Apr 14, 2013 @ 4:20pm 
recently i did buy other copie of the game and i cant even add other... semeone did told me to "Try disabling integrated graphics in the bios. I found that having it enabled can cause issues.".
Good luck.
coolcursive Apr 16, 2013 @ 1:48am 
i have a similar issue. when i forced the game to run on nvidia 555m, it will fail to launch at all. meanwhile, using intel integrated graphics, the game will launch, but will be laggy. anyone has a remedy for that?
RD Ghost Apr 18, 2013 @ 4:58pm 
I had this problem turn off Lucid Virtu MVP if you have it works now for me
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Apr 13, 2013 @ 7:27pm
Posts: 4