X2: The Threat

X2: The Threat

CareFactorZero Aug 21, 2013 @ 6:54am
X2 sound issues
Been having problems with the sound in this game. When I start it up, All I hear in place of sound is static. The proper game sound can be heard just under. For some reason, when I run in benchmark, the sound plays fine.

I've tried:
reinstalling my audio driver
installing new audio codecs
patching to 1.5
reinstalling the game
verifying the game cache
changing the default format of my speakers (it's at 16bit, 48000 hz at the moment)

Any help would be appreciated.
< >
Showing 1-9 of 9 comments
jwrealing Sep 14, 2013 @ 12:17pm 
what audio codecs are you talking about? As well as what sound card do you have? Also go to run and type in DXdiag.exe go to save all information and post it here. One thing I will say the X Series games do not like thrid party codecs.
Steel Sep 17, 2013 @ 8:35am 
Same thing with sound. It has some crappy white noise background. Don't know what to do! Any suggestions would be highly appreciated
Koryitsu Sep 18, 2013 @ 8:43pm 
ffd codecs. if you have cccp uninstall it. nothing wrong with cccp, i love it and use it, but it borks x games, and almost always has.
takos Sep 19, 2013 @ 5:29pm 
If you running this game on windows 7. try compatible mode with XP. I solved some constant noise thing on my pc.
FatnBalding Sep 20, 2013 @ 2:52pm 
Just posted in the other thread that turning off the music did the trick. Something simple that you may have overlooked. Took me forever to realize that's what the problem was.
Sorry if I'm necroing. Takos has the correct fix (At least for windows 8.1, but it should work on 7 as well) Use XP SP3 if possible. That one does it for me!

...Incase you haven't yet fixed it, or someone else stumbles on this for help....
Last edited by ✯✯✯✯✯ Admiral Squackie; Nov 27, 2013 @ 7:53pm
*Dead* Kriis Dec 18, 2015 @ 10:08pm 
Not to Necro a post or anything... but I never would have thought to uninstall KLite Codec Pack, but that seems to have done the trick for me... Never had a game (or anything for that matter) borked because of KLite...

I'll have to plug around with it, but definitely XP isn't a realistic option for normal people - even in 2013...

Edit: After some quick searches, it does seem to be something in KLite... the problems disappear when I disabled LAV (Codec Tweaks > DirectShow (x86) > LAV Audio Decoder)... not sure if this will affect anything else. Others mention Fallout 3, but I don't recall having issues with it.
Last edited by *Dead* Kriis; Dec 18, 2015 @ 11:02pm
XP SP3 compatibility mode. Right click the executable in Vista, 7, 8, 8.1, or 10, and go to the compatibility tab. Select the check box for Run in Compatibility Mode, then choose Windows XP (Service Pack 3) from the dropdown box.
Originally posted by Shaku the Squirrel Warrior:
XP SP3 compatibility mode. Right click the executable in Vista, 7, 8, 8.1, or 10, and go to the compatibility tab. Select the check box for Run in Compatibility Mode, then choose Windows XP (Service Pack 3) from the dropdown box.
this wont let me play the game at all. since the display settings i can choose from are changed and it wont launch with those.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50