DYNASTY WARRIORS 8: Xtreme Legends Complete Edition
D4NG3R15M May 15 @ 5:33am
Windows 8 users change to Win98 compatibilty
Hilariously, it seems to work. I've tried the Win7 compat supposed fix, the core affinity supposed fix, and the don't play movie supposed fix, none work as good as this solution (so far).

Waiting for the game to break again though. :P
Showing 1-15 of 26 comments
< >
Espionage724 May 15 @ 5:41am 
I'm on Windows 8.1 and have had absolutely no problem with DW8 so far. Is there something I should do specifically to run into a problem?

Edit: I use a quad-core CPU (Phenom II X4 @ 3.3GHz)
Last edited by Espionage724; May 15 @ 6:32am
Toyotomius May 15 @ 5:43am 
I was highly skeptical but this worked for me. Up till now I was running it on high priority / bottom core affinity to play it, which made it a bit janky of course.

Not all 8.1s have had issues, and it hasn't been relegated to only 8.1 Espionage. It seems to be more of a cpu core thing. I have 8 cores and the game doesn't seem to know how to handle it.
AlexC May 15 @ 5:48am 
OP, if you do run into a problem while in 98 comparability then please say, would be interesting to see if this could be a permanent workaround.
fcorazao May 15 @ 6:15am 
I too believe it's a core think. I have a 12 core CPU and it's nearly unplayable. Even changing cores before battles it eventually breaks. I'm going to try this solution and see what happens.
Ogare May 15 @ 6:19am 
Oh my god, it actually works. I tried to set compatibility mode to win7/winxp but never tried 98 before.
buddymanson May 15 @ 6:28am 
WOW It works, but now my game is stuck at 30fps. Vertical sync is off in game and in the control panel. So I can play the game without the loading bug at 30fps or with the loading bug at 60fps. I think this game hates me.
fcorazao May 15 @ 6:43am 
Amazingly, it seems to work! I only had time to try one quick fight but it seems to work without any problems for me (no lag or fps loss). I'll try Ambition later since that seems to be the most troublesome and I'll let you know!
Your Friendly Yandere May 15 @ 6:46am 
I think what that does is setting affinity to 1 core
buddymanson May 15 @ 6:48am 
That could explain why I'm getting 30fps.

@fcorazao - Ambition mode is loading fine now and it never did before.
Last edited by buddymanson; May 15 @ 6:51am
fcorazao May 15 @ 7:30am 
Amazing that this fix it.... It does make sense that Windows 98 would automatically set it to one core. I'm guessing, in my case at least, that the video card is picking up the workload and that's why I'm getting a fluent game -- just FYI, I have not used a FPS counter or anything, the game just 'looks' smooth.
rip internet May 15 @ 8:10am 
Setting to Windows 98 seems to automaticalliy force one core. You can get the same effect by manually setting cores. Also, if you find that performance drops because of one core, you only need one core to load a stage; once the stage has actually been loaded feel free to turn on all cores again. (Of course before loading the next stage you need to set to one core again)
fcorazao May 15 @ 8:19am 
@xD.Deezee I don't think it's just that. With the 'change to one core' fix many people still couldn't load Ambition mode and got crashesh after a while. I think it does something else (and it also keeps you from having to change cores every time a battle loads)
Zantagor May 15 @ 8:33am 
Funny, I spot a couple of dirty pirates in this thread
AlexC May 15 @ 8:36am 
Originally posted by Zantagor:
Funny, I spot a couple of dirty pirates in this thread

Spotted quite a few on here since release sadly.
D4NG3R15M May 15 @ 9:22am 
It runs in dual-core mode, pretty much what the core-affinity fix is, without the hassle.
http://imgur.com/y6I8WJU

Fps is 60 in vsync 0, but sometimes may drop to 45 on my setup. And using SweetFX kinda kills off Fps using this fix as well.

Oh, and I could not even begin to pursue Lu Bu without blackscreening prior to this, this worked for Story mode as well.
Last edited by D4NG3R15M; May 15 @ 9:29am
Showing 1-15 of 26 comments
< >
Per page: 15 30 50
Date Posted: May 15 @ 5:33am
Posts: 26