DYNASTY WARRIORS 8: Xtreme Legends Complete Edition
Blueberry May 14, 2014 @ 12:57pm
[For those Black Screening] See if this works
--> Do all these at once
1. Create a shortcut for the game- turn compatibility mode into [Windows XP (Service Pack 2)].
2. Go into config and Turn off Play Movie, Make VSYNC 0. Turn on Windowed Mode. Make all graphic settings normal including characters! (Dynamic Shadows can be on)
3. Start the game and open task manager fast --> Go to details and change the program priority to [High] and Go to Affinity and make sure only the BOTTOM CPU is checked.


Give it a shot. Tell me if it works. <3


Edit: Some people have stated that you might be able to select more than one core. Try without it first though.
Last edited by Blueberry; May 15, 2014 @ 2:37pm
Showing 1-15 of 21 comments
< >
LusterPurge May 14, 2014 @ 2:36pm 
It worked! Thanks buddy! <3
K Money Deluxe May 14, 2014 @ 2:55pm 
Holy ♥♥♥♥ this worked! Thanks a ton. I'm in Free Mode!!
Last edited by K Money Deluxe; May 14, 2014 @ 2:55pm
Blackwing May 14, 2014 @ 3:03pm 
You only need to follow 3rd step. It should work just fine :)
terranrus64 May 14, 2014 @ 5:21pm 
Blackwing is right only step 3 is ultimately needed for a temporary fix:

1. BEFORE you click any kind of "Begin Battle" button, Open up the task manager
2. Set affinity to just ONE core
3. Set priority to high
4. Click "Begin battle" button
5. wait for game to load (It will almost instantly) and change back to all cores IF you so desire.
Last edited by terranrus64; May 14, 2014 @ 5:23pm
Rogue_Zephyr May 14, 2014 @ 5:33pm 
I can't even get to the stage where I can begin a battle :(
terranrus64 May 14, 2014 @ 6:24pm 
Originally posted by Rogue_Zephyr:
I can't even get to the stage where I can begin a battle :(

Hey Rouge,

my friend had this problem too but I can confirm the solution I mentioned above works.

Assuming the game loads and you can select your character it is important that BEFORE you select "begin battle" (or continue if you managed to save the game before) that you:

1. Open up the task manager
2. Set affinity to just ONE core
3. Set priority to high
4. Go back to your game
5. NOW you can Click "Begin battle" button
6. The game should load almost instantly

I hope this helps. Let me know if you get through. I think we all are awaiting KOEI to provide a proper patch for this game.....
Last edited by terranrus64; May 14, 2014 @ 6:24pm
Rogue_Zephyr May 14, 2014 @ 6:32pm 
Originally posted by terranrus64:
Originally posted by Rogue_Zephyr:
I can't even get to the stage where I can begin a battle :(

Hey Rouge,

my friend had this problem too but I can confirm the solution I mentioned above works.

Assuming the game loads and you can select your character it is important that BEFORE you select "begin battle" (or continue if you managed to save the game before) that you:

1. Open up the task manager
2. Set affinity to just ONE core
3. Set priority to high
4. Go back to your game
5. NOW you can Click "Begin battle" button
6. The game should load almost instantly

I hope this helps. Let me know if you get through. I think we all are awaiting KOEI to provide a proper patch for this game.....

I really appreciate the fact that you are trying to help, but you have missed my point. I try amd start the game, I get a black window appear for a second, and it then quits.
[]D [] []V[] []D [] []\[] May 14, 2014 @ 6:43pm 
just a note. it doesnt have to be one core... im working on 2 core affinity. so far a world of difference. max all settings minus the fact you have to work in windowed mode to access the task manager. cheers!
Omen May 14, 2014 @ 6:57pm 
Originally posted by Tomoe:
There is a working fix for this damn bug, but I'll be banned from steam community if I were to link to it. See "Rules and Guidelines for Steam Community Discussions" for details.

If I'm correct in thinking I know what you're talking about, I've tried that as well, it actually doesn't fix the problem (for me).
terranrus64 May 14, 2014 @ 7:01pm 
I see now Rouge your game crashes before it even starts :( I will keep looking.

Originally posted by Rogue_Zephyr:
Originally posted by terranrus64:

Hey Rouge,

my friend had this problem too but I can confirm the solution I mentioned above works.

Assuming the game loads and you can select your character it is important that BEFORE you select "begin battle" (or continue if you managed to save the game before) that you:

1. Open up the task manager
2. Set affinity to just ONE core
3. Set priority to high
4. Go back to your game
5. NOW you can Click "Begin battle" button
6. The game should load almost instantly

I hope this helps. Let me know if you get through. I think we all are awaiting KOEI to provide a proper patch for this game.....

I really appreciate the fact that you are trying to help, but you have missed my point. I try amd start the game, I get a black window appear for a second, and it then quits.
terranrus64 May 14, 2014 @ 7:02pm 
You are right - 2 core affinity does work :)

Originally posted by D V D \:
just a note. it doesnt have to be one core... im working on 2 core affinity. so far a world of difference. max all settings minus the fact you have to work in windowed mode to access the task manager. cheers!
h a v May 14, 2014 @ 7:18pm 
or if running story mode you could simply just start a new game go to stage select and select the stage you're up to. That works every time for me without having to ♥♥♥♥ around with a bunch of settings.
Joe Johnson May 14, 2014 @ 7:51pm 
Rogue I think your bug is completely different than the issue being described here.
just wanted to say that tarranrus64's solution worked for me.

Also I had it set to VSYNC 2 on a 60hz monitor...locks it at 30fps.
Joe Johnson May 14, 2014 @ 7:56pm 
Wanted to throw my hat in on the 2 core thing. I do see an improvement as well.
Cute Little Girl💕 May 14, 2014 @ 8:29pm 
Just noticed something about this fix. Leaving your affinity to 2 cores and LEAVING it on that doesn't seem to work. The initial load with 2 cores worked for me but anything after that didn't. I didn't switch them all back on to test because right now I'm just frustrated at this whole issue. I'll try again in a few hours to see if any progress has been made...
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: May 14, 2014 @ 12:57pm
Posts: 22