Serena > General Discussions > Topic Details
AgustinCordes  [developer] Feb 1, 2014 @ 7:32am
Technical problems: What you should do
This seems to have been a fairly stable and bug-free launch, but keep in mind it's the first major release with a custom game engine under production called Dagon, freely available and open here: Dagon on GitHub[github.com]

Thus, there still seems to be some erratic problems occurring under very specific conditions. The vast majority of them should be fixed by updating your video card drivers. Note that support for OpenGL is mandatory. If you're having problems, please try the following:

  • Download the latest drivers from the video card manufacturer itself (don't use Windows update)
  • If that fails, edit the config.lua file present in the Serena SteamApps folder and set log = true. Run the game once and look at the contents of dagon.log. Usually, the reports give you a clear idea of what's going on.
  • If the engine complains about effects not being supported, try adding this line to config.lua: framebuffer = false. You will miss a lot of the eye candy, but hopefully the game will run.
  • If the mouse cursor is behaving like it's possessed by evil spirits, try setting verticalSync = false.
  • For audio related problems, try audioDevice = 1 or 2.
  • If you're experiencing sounds or music being cut, try numOfAudioBuffers = 8.

If all that fails, by all means, post a report here and we'll look into it. We're already investigating some of the problems reported.

IMPORTANT! There's a major bug on Windows XP that breaks the ending of the game. This is also our top priority (XP will be fully supported by Dagon).
Last edited by AgustinCordes; Feb 1, 2014 @ 7:33am
Showing 1-15 of 63 comments
< >
F4LLENP4WN Feb 1, 2014 @ 9:58am 
I have tried just about everything and I am running Windows 7 64 bit, with more than the necessary requirments. I guess I shouldn't expect all free games to actually work, but I was really interested in the story for this release.

If it all possible, update us in the near future when you have a full working game. Because I really wanted to support this project.
Last edited by F4LLENP4WN; Feb 1, 2014 @ 9:59am
f00fightrs Feb 1, 2014 @ 11:46am 
I am running this on a new Macbook Pro 15" w/ retina display w/ Nvidia 750m graphics. The game loads, but my trackpad is inactive, and the resolution is completely off and appears it's zoomed in too much. I can get to the menu by hitting SHIFT+TAB, but I can't select any options because the mouse/trackpad is inactive.
Estirdalin Feb 1, 2014 @ 1:53pm 
The game works fine for me in win 7 64 bit, Estrange, so doesn't look like it's an OS problem at least. Graphics card issue perhaps?
Farguz Feb 1, 2014 @ 2:33pm 
Stuck at the ending... Win XP... Sigh... I hope you'll fix it as soon as possible.
/subscribed
Last edited by Farguz; Feb 1, 2014 @ 2:33pm
RNGoDs Feb 1, 2014 @ 4:11pm 
[Feb 1 16:10:35] AUDIO -> Initializing audio manager...
[Feb 1 16:10:35] AUDIO -> Opening default device
[Feb 1 16:10:35] AUDIO -> ERROR: Failed to initialize OpenAL device
EvilKingGumby Feb 1, 2014 @ 7:05pm 
The game seems to load fine, but every time I go to look at a scene closer and examine stuff, there is no way to back out or move around the scene away from it. I tried viewing the bookcase first, got stuck there. exited, came back, tried top bookcase shelf..same.. moved towards bedroom, then towards the painting by the front door (of the 2 children?) and couldn't move or back away.. not sure what is causing this. what do people usually do to get back to their previous spot in the room?
Primal Fear Feb 2, 2014 @ 4:34am 
Originally posted by EvilKingGumby:
The game seems to load fine, but every time I go to look at a scene closer and examine stuff, there is no way to back out or move around the scene away from it. I tried viewing the bookcase first, got stuck there. exited, came back, tried top bookcase shelf..same.. moved towards bedroom, then towards the painting by the front door (of the 2 children?) and couldn't move or back away.. not sure what is causing this. what do people usually do to get back to their previous spot in the room?
Somewhere in the lower area of the screen you should find a spot where the cursor changes. Clicking there brings you back.
Mr Kantus Feb 2, 2014 @ 6:33am 
This game just keeps flashing, if feel as if im gonna have a seizure.
Steem Reeper Feb 2, 2014 @ 8:25am 
Audio is unbearably jerky on Linux Fedora 20 with default pulseaudio setup.
None of the upper tweaks make it any better.
Hw: 00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
[Feb 2 17:24:27] CONTROLLER -> Dagon version: 0.6.8a
[Feb 2 17:24:27] CONTROLLER -> Build: 1011
[Feb 2 17:24:27] SCRIPT -> Initializing script...
[Feb 2 17:24:27] SCRIPT -> Lua version: Lua 5.1.5
[Feb 2 17:24:27] SYSTEM -> Initializing system...
[Feb 2 17:24:27] SYSTEM -> SDL version: 2.0
[Feb 2 17:24:27] RENDER -> GLEW version: 1.6.0
[Feb 2 17:24:27] RENDER -> Initializing renderer...
[Feb 2 17:24:27] RENDER -> OpenGL version: 2.1.2 NVIDIA 304.119
[Feb 2 17:24:27] AUDIO -> Initializing audio manager...
[Feb 2 17:24:27] AUDIO -> Opening default device
[Feb 2 17:24:28] AUDIO -> OpenAL version: 1.1 ALSOFT 1.13
[Feb 2 17:24:28] AUDIO -> Vorbis version: Xiph.Org libVorbis 1.3.2
[Feb 2 17:24:28] FONT -> Initializing font manager...
[Feb 2 17:24:28] FONT -> Freetype version: 2.4.8
[Feb 2 17:24:28] VIDEO -> Initializing video manager...
[Feb 2 17:24:28] VIDEO -> Theora version: Xiph.Org libtheora 1.1 20090822 (Thusnelda)
[Feb 2 17:24:29] CONTROLLER -> System ready!
[Feb 2 17:24:36] CONTROLLER -> I'm afraid, Dave
eml Feb 2, 2014 @ 9:34am 
On OpenSUSE 13.1 game fails to start with complaint about libGLEW.so.1.6 missing, but only version 1.9 is in the repos. Making a properly named link to version 1.9 makes the game run OK (at least as far as I've played).
AgustinCordes  [developer] Feb 2, 2014 @ 12:27pm 
I'll respond to the individual problems shortly!
jakk1000 Feb 3, 2014 @ 12:37pm 
on dual monitors half the game is on both monitors so it makes nearly impossible to play.
AgustinCordes  [developer] Feb 3, 2014 @ 2:22pm 
Originally posted by EstrangeDemon:
I have tried just about everything and I am running Windows 7 64 bit, with more than the necessary requirments. I guess I shouldn't expect all free games to actually work, but I was really interested in the story for this release.

If it all possible, update us in the near future when you have a full working game. Because I really wanted to support this project.:serioussam:
Can you clarify a bit more what the problem is? Perhaps sending me the log to try and pinpoint exactly where it's failing? We didn't have issues with Windows 7 64-bit ourselves. Thank you.
AgustinCordes  [developer] Feb 3, 2014 @ 2:24pm 
Originally posted by f00fightrs:
I am running this on a new Macbook Pro 15" w/ retina display w/ Nvidia 750m graphics. The game loads, but my trackpad is inactive, and the resolution is completely off and appears it's zoomed in too much. I can get to the menu by hitting SHIFT+TAB, but I can't select any options because the mouse/trackpad is inactive.
Please, follow the instructions to edit the config.lua and try forcing the resolution of your screen with displayWidth and displayHeight. If that fails, see if windowed mode (fullscreen = false) works.
AgustinCordes  [developer] Feb 3, 2014 @ 2:25pm 
Originally posted by FlinDorN:
[Feb 1 16:10:35] AUDIO -> Initializing audio manager...
[Feb 1 16:10:35] AUDIO -> Opening default device
[Feb 1 16:10:35] AUDIO -> ERROR: Failed to initialize OpenAL device
Have you tried changing the audioDevice setting as I suggested in the original post?
Showing 1-15 of 63 comments
< >
Per page: 15 30 50