Melody's Escape

Melody's Escape

View Stats:
paalinge88 aka PsyBird Jul 12, 2014 @ 8:15am
Very often, the game doesn't do anything when I'm pressing the buttons on my game pad. And there comes an error message.
The game register that I'm pushing the buttons, but somtimes (actually very often, but not always) the character doesn't do anything and there comes an "error" message where the accuracy is displayed. The character moves those times it doesn't happen but the problem happens about 70% of the time.
I have tried with both my Logitech Gamepad F310 and my Xbox 360 controller and it's the same problem with both of them.
< >
Showing 1-15 of 22 comments
Loïc  [developer] Jul 12, 2014 @ 10:00am 
The input detection only feels unresponsive when the computer is struggling to keep up with performances (< 40 FPS), so if you want to fix the problem you can simply disable "Post-Processing" and "Background Visualizations" in the "Performances" option menu.
That should give you a smooth 60FPS (providing that your computer meets the minimum system specs requirements), and remove all the perceived input delay.

If that does not fix the issue, could you please give me more information about your computer specs, OS, and the FPS count when playing a song?
paalinge88 aka PsyBird Jul 12, 2014 @ 10:21am 
I have already tried to disable those things, but it didn't help.
The computer specs are as follows:

CPU: Intel Quad Core 17 - 4700HQ 2,4 GHz
Memory: 8,00 GB
OS. Windows 8, 64 bit.

FPS: Jumps from everything to about 640 to about 710.
Last edited by paalinge88 aka PsyBird; Jul 12, 2014 @ 10:26am
Loïc  [developer] Jul 12, 2014 @ 12:35pm 
Oh then it might the be the other way around, your FPS is too high due to such a powerful machine, and there is a "visual offset" due to screen tearing from having no vertical sync.

Could you please try in fullscreen with VSync enabled?
paalinge88 aka PsyBird Jul 16, 2014 @ 8:19am 
That helped, thank you, :) but there is another problem. The music and the game seems to be a little off sync. Is there any way to fix that, or are you going to update the game with a option that can you can adjust how early/late the arrows/icons appear? I need to adjust them to come earlier since the arrows/icons seems to come a little bit too late.
Loïc  [developer] Jul 16, 2014 @ 8:58am 
Are you playing on a TV? (I've never seen a delay on a computer monitor.)
freefall014 Jul 19, 2014 @ 2:18pm 
I am playing on a laptop with effectively identical specs to the guy in this thread and am having similar issues. FPS is fine and everything renders beautifully (in fullscreen, vsync enabled). However I find gameplay very frustrating due to the perceived timing offset -- I tend to find that the arrows come significantly ahead of the beat (musicians may know what I'm talking about when I say that you have to "lurch" in anticipation of the beat). Sometimes this isn't a big problem, as long as you're able to mentally calibrate the difference. Usually it becomes frustrating because it's incredibly hard to reset after missing a solid obstacle -- after missing one, losing that mental calibration of the timing difference + the unforgiving hitbox size means it can take half a minute to get back on track.
It'd be really helpful to fix the issue for anybody who experiences this if there was a tool for adjusting hitbox alignment / timing differences like the calibration tool from Guitar Hero, as one idea.
freefall014 Jul 19, 2014 @ 2:30pm 
update: after playing around with settings, going from Fullscreen to windowed and disabling Post-processing helped enormously for me.
Loïc  [developer] Jul 19, 2014 @ 2:59pm 
The specs are missing the most important part, what GPU adapter is used by the laptop? (you can see it in the Video options menu, as sometimes system with dual GPU don't always use the one you'd expect it to)
freefall014 Jul 19, 2014 @ 3:19pm 
I don't know about PsyBird, but mine is using NVIDIA GeForce GT 750M.

I reenabled post-processing and fullscreen separately -- the audio/video sync problem seems to be confined to fullscreen mode for me. The game plays as intended, though still difficult =), in Windowed mode.
Loïc  [developer] Jul 20, 2014 @ 2:59am 
What is your FPS in both of these modes? I think the issue is with VSync not being applied
paalinge88 aka PsyBird Jul 20, 2014 @ 5:54am 
You are supposed to press the buttons when the arrows/icons are beneath Melody, right? The arrows/icons are sychronized right on the beats, but the songs are starting too early which makes the arrows/icons coming beneath Melody when the beat is already played.
paalinge88 aka PsyBird Jul 20, 2014 @ 5:58am 
If you didn't understand what I meant, I will try to explain it better for you.
My CPU on the laptop is NVIDIA GEFORCE GTX 760M.
paalinge88 aka PsyBird Jul 20, 2014 @ 5:59am 
By the way. I've tried it on my stationary computer too (which has even better specs than my laptop), and the same problem happens there.
Last edited by paalinge88 aka PsyBird; Jul 20, 2014 @ 6:00am
Loïc  [developer] Jul 20, 2014 @ 6:11am 
I don't think I understand the problem correctly.

If you press F1 in game you will see a debug mode with lines drawn.
The red vertical line on Melody represents her position, and you're supposed to press the buttom exactly when she's above the arrow, or when a light orb touches her.

The red line will be above an obstacle (beat in Tempo sync mode) exactly when the sound plays.
paalinge88 aka PsyBird Jul 20, 2014 @ 6:44am 
I'll try to explain using a picture:
You see where Melody is on that picture, right? That is where the music starts. It is supposed to start at the first icon, but i doesn't. It starts too early.
< >
Showing 1-15 of 22 comments
Per page: 15 30 50

Date Posted: Jul 12, 2014 @ 8:15am
Posts: 22