Melody's Escape

Melody's Escape

View Stats:
KitCat Jul 20, 2014 @ 2:53pm
Minor Bug: Ingame Clock Timer
Just a minor report for a minor bug. When ingame, the clock showing the remaining time for the song on the upper right side is a bit laggy. It sometimes hangs on a little too long before continuing to tick down and has to skip a second or two in order to keep up. That results in orders like 0:44 - 0:43 - 0:43 - 0:41, instead of the expected behaviour.
< >
Showing 1-7 of 7 comments
Loïc  [developer] Jul 22, 2014 @ 4:45am 
Does that happen at stable 60 or + FPS?
KitCat Jul 22, 2014 @ 5:38am 
Happens with both, 60+ when in window and ~40 when out of the window.
Cynical Vampire Jul 23, 2014 @ 1:19am 
Never happened to me before, is your processor under high load?
KitCat Jul 23, 2014 @ 10:46am 
10% loadout.
KitCat Jul 23, 2014 @ 11:02am 
http://youtu.be/CcLheoZ9L-g

Catched it on video for you. Does unfortunately only show it on around 60 and 25 fps, as fraps does not allow higher FPS-Rates, but it's the same on 60+. Most noticable jumps are from 5:31 to 5:29 when I'm in the window (60 fps - at the start) and 3:57 to 3:55 (25 fps - end of the video).
Loïc  [developer] Jul 29, 2014 @ 1:58pm 
Thanks for the video. I've double-checked the code and I can't seem to find why this behaviour would happen. It's clearly not "lag" as the score updates correctly while the timing is "frozen", so it seems like the game doesn't read the system clock correctly.
KitCat Jul 31, 2014 @ 10:14am 
Probably related to x64? Beside that it's not that much of a big deal so I think we'll be able to survive without a fix
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Jul 20, 2014 @ 2:53pm
Posts: 7